summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-09-26 13:36:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-09-26 13:36:50 +0000
commit3d1faceaf118dc380894742b5b740ee7c4114f70 (patch)
tree6559554881eb85db99f3c66f8c12172f8e91bcad /sci-geosciences
parenttemporarily fix bug 336801 by depending on cairo[-qt4] (diff)
downloadgentoo-2-3d1faceaf118dc380894742b5b740ee7c4114f70.tar.gz
gentoo-2-3d1faceaf118dc380894742b5b740ee7c4114f70.tar.bz2
gentoo-2-3d1faceaf118dc380894742b5b740ee7c4114f70.zip
Version bump to latest. This is only basic ebuild and generic tested. Might need enhancement/touchups.
(Portage version: 2.2_rc87/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog9
-rw-r--r--sci-geosciences/gpsd/files/gpsd.conf-28
-rwxr-xr-xsci-geosciences/gpsd/files/gpsd.init-238
-rw-r--r--sci-geosciences/gpsd/gpsd-2.95.ebuild80
4 files changed, 134 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 58df01ad53f3..750e1f5f15e6 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.49 2010/05/30 20:48:39 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.50 2010/09/26 13:36:50 scarabeus Exp $
+
+*gpsd-2.95 (26 Sep 2010)
+
+ 26 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org> +files/gpsd.conf-2,
+ +files/gpsd.init-2, +gpsd-2.95.ebuild:
+ Version bump to latest. This is only basic ebuild and generic tested.
+ Might need enhancement/touchups.
30 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gpsd-2.32.ebuild, gpsd-2.38.ebuild, gpsd-2.39-r1.ebuild:
diff --git a/sci-geosciences/gpsd/files/gpsd.conf-2 b/sci-geosciences/gpsd/files/gpsd.conf-2
new file mode 100644
index 000000000000..b50bd46b0199
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd.conf-2
@@ -0,0 +1,8 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/files/gpsd.conf-2,v 1.1 2010/09/26 13:36:50 scarabeus Exp $
+
+# Config file for gpsd server
+GPSD_OPTIONS=""
+DEVICES=""
+GPSD_SOCKET="/var/run/gpsd.sock"
diff --git a/sci-geosciences/gpsd/files/gpsd.init-2 b/sci-geosciences/gpsd/files/gpsd.init-2
new file mode 100755
index 000000000000..7a09664bfb7b
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd.init-2
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/files/gpsd.init-2,v 1.1 2010/09/26 13:36:50 scarabeus Exp $
+
+depend() {
+ after dbus
+ before ntpd
+}
+
+PIDFILE=/var/run/$NAME.pid
+DAEMON=/usr/sbin/gpsd
+
+checkconfig() {
+ if [ -z "${GPSD_SOCKET}" ] && [ -z "${DEVICES}" ]; then
+ GPSD_SOCKET="/var/run/gpsd.sock"
+ fi
+
+ if [ -n "${GPSD_SOCKET}" ]; then
+ GPSD_OPTIONS="${GPSD_OPTIONS} -F ${GPSD_SOCKET}"
+ fi
+}
+
+start() {
+ checkconfig
+ ebegin "Starting gpsd"
+
+ start-stop-daemon --start --quiet --pidfile ${PIDFILE} --exec ${DAEMON} -- \
+ ${GPSD_OPTIONS} -P ${PIDFILE} ${DEVICES}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping gpsd"
+ start-stop-daemon --stop --quiet --retry=TERM/30/KILL/5 --pidfile ${PIDFILE}
+ eend $?
+ rm -f ${PIDFILE}
+}
diff --git a/sci-geosciences/gpsd/gpsd-2.95.ebuild b/sci-geosciences/gpsd/gpsd-2.95.ebuild
new file mode 100644
index 000000000000..7cc15db159c7
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-2.95.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.95.ebuild,v 1.1 2010/09/26 13:36:50 scarabeus Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+
+inherit python base
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients."
+HOMEPAGE="http://gpsd.berlios.de/"
+SRC_URI="mirror://berlios/gpsd/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+GPSD_PROTOCOLS="ashtech aivdm clientdebug earthmate evermore fv18 garmin
+ garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
+ oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
+ tripmate tnt ubx"
+for protocol in ${GPSD_PROTOCOLS}; do
+ IUSE_GPSD_PROTOCOLS+=" gpsd_protocols_${protocol}"
+done
+IUSE="${IUSE_GPSD_PROTOCOLS} dbus ipv6 ntp qt4"
+
+# those harddeps are de-facto automagicall
+RDEPEND="
+ dev-python/pygtk
+ sys-libs/ncurses
+ virtual/libusb:1
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ntp? ( net-misc/ntp )
+ qt4? ( x11-libs/qt-gui )
+"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+
+ # Run the gpsd daemon as gpsd and group uucp
+ enewuser gpsd -1 -1 -1 "uucp"
+}
+
+src_configure() {
+ local myopts
+
+ # enable specified protocols
+ for protocol in ${GPSD_PROTOCOLS}; do
+ myopts+=" $(use_enable gpsd_protocols_${protocol} ${protocol})"
+ done
+
+ # --disable-bluetooth: considered experimental -> disable
+ # hack to make it not generate docs on the fly
+ WITH_XSLTPROC=no WITH_XMLTO=no \
+ econf \
+ --disable-dependency-tracking \
+ --disable-bluetooth \
+ --disable-static \
+ --enable-libgpsmm \
+ --enable-gpsd-user=gpsd \
+ --enable-gpsd-group=uucp \
+ $(use_enable dbus) \
+ $(use_enable ipv6) \
+ $(use_enable ntp ntpshm) \
+ $(use_enable ntp pps) \
+ $(use_enable qt4 libQgpsmm) \
+ ${myopts}
+}
+
+src_install() {
+ base_src_install
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd || die
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd || die
+}