summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-06-07 17:53:38 +0000
committerMike Frysinger <vapier@gentoo.org>2015-06-07 17:53:38 +0000
commit3a347f7341f828ce0f7af6ddf43cee71ebbd4646 (patch)
tree1afb88344851e99330153aef552b5cd492429354 /sci-geosciences
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-3a347f7341f828ce0f7af6ddf43cee71ebbd4646.tar.gz
gentoo-2-3a347f7341f828ce0f7af6ddf43cee71ebbd4646.tar.bz2
gentoo-2-3a347f7341f828ce0f7af6ddf43cee71ebbd4646.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog9
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.15-broken-install.patch28
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.15-dynamic-libs.patch100
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.15-libgpsd.patch80
-rw-r--r--sci-geosciences/gpsd/gpsd-3.15.ebuild167
5 files changed, 383 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 1966be32ab09..2b45bd8a5917 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.128 2015/04/08 18:49:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.129 2015/06/07 17:53:38 vapier Exp $
+
+*gpsd-3.15 (07 Jun 2015)
+
+ 07 Jun 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/gpsd-3.15-broken-install.patch, +files/gpsd-3.15-dynamic-libs.patch,
+ +files/gpsd-3.15-libgpsd.patch, +gpsd-3.15.ebuild:
+ Version bump.
08 Apr 2015; Michał Górny <mgorny@gentoo.org> gpsd-3.10.ebuild,
gpsd-3.11.ebuild, gpsd-3.13.ebuild, gpsd-9999.ebuild:
diff --git a/sci-geosciences/gpsd/files/gpsd-3.15-broken-install.patch b/sci-geosciences/gpsd/files/gpsd-3.15-broken-install.patch
new file mode 100644
index 000000000000..ec68a3c21a9c
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.15-broken-install.patch
@@ -0,0 +1,28 @@
+From 798629da485b9504dbb5bd5c96c9ea1d3454ebe3 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 7 Jun 2015 13:39:55 -0400
+Subject: [PATCH] Revert "# Work arount a minor bug in InstallSharedLib() link
+ handling"
+
+This reverts commit 0532106c1ea0807922ea6f868fcde384f22d4e92 as it breaks
+parallel installs. The original commit itself contains no real details.
+---
+ SConstruct | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index 39a6b6a..c8a977e 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1336,8 +1336,6 @@ if env["ncurses"]:
+ binaryinstall.append(env.Install(installdir('bindir'), [cgps, gpsmon]))
+ binaryinstall.append(LibraryInstall(env, installdir('libdir'), compiled_gpslib, libgps_version))
+ binaryinstall.append(LibraryInstall(env, installdir('libdir'), compiled_gpsdlib, libgps_version))
+-# Work arount a minor bug in InstallSharedLib() link handling
+-env.AddPreAction(binaryinstall, 'rm -f %s/libgps.*' % (installdir('libdir'), ))
+
+ if qt_env:
+ binaryinstall.append(LibraryInstall(qt_env, installdir('libdir'), compiled_qgpsmmlib, libgps_version))
+--
+2.4.1
+
diff --git a/sci-geosciences/gpsd/files/gpsd-3.15-dynamic-libs.patch b/sci-geosciences/gpsd/files/gpsd-3.15-dynamic-libs.patch
new file mode 100644
index 000000000000..9461a666b031
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.15-dynamic-libs.patch
@@ -0,0 +1,100 @@
+From ac48583654e97ef04e8cbb52c2ae77a617c7add3 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 7 Jun 2015 01:08:39 -0400
+Subject: [PATCH] reenable dynamic libs
+
+Upstream decided to staticly link their own programs against their libs
+instead of using the shared ones. Restore dynamic linking to save space
+and such.
+---
+ SConstruct | 64 ++++++++++++++++++++++++++++++++++----------------------------
+ 1 file changed, 35 insertions(+), 29 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index 28cebf0..a050f38 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -961,6 +961,9 @@ if qt_env:
+ gpsflags = ["-lm"] + rtlibs + dbusflags
+ gpsdflags = usbflags + bluezflags + gpsflags
+
++gpslibs = ["-lgps"] + gpsflags
++gpsdlibs = ["-lgpsd"] + gpsdflags + gpslibs
++
+ # Source groups
+
+ gpsd_sources = ['gpsd.c','timehint.c', 'shmexport.c','dbusexport.c']
+@@ -983,38 +986,41 @@ gpsmon_sources = [
+ ## Production programs
+
+ gpsd = env.Program('gpsd', gpsd_sources,
+- LIBS=['gpsd', 'gps_static'], LIBPATH='.',
+- parse_flags=gpsdflags+gpsflags)
++ LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs)
++env.Depends(gpsd, [compiled_gpslib])
++
+ gpsdecode = env.Program('gpsdecode', ['gpsdecode.c'],
+- LIBS=['gpsd', 'gps_static'], LIBPATH='.',
+- parse_flags=gpsdflags+gpsflags)
++ LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs)
++env.Depends(gpsdecode, [compiled_gpslib])
++
+ gpsctl = env.Program('gpsctl', ['gpsctl.c'],
+- LIBS=['gpsd', 'gps_static'], LIBPATH='.',
+- parse_flags=gpsdflags+gpsflags)
++ LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs)
++env.Depends(gpsctl, [compiled_gpslib])
++
+ gpsmon = env.Program('gpsmon', gpsmon_sources,
+- LIBS=['gpsd', 'gps_static'], LIBPATH='.',
+- parse_flags=gpsdflags + gpsflags + ncurseslibs)
+-gpsdctl = env.Program('gpsdctl', ['gpsdctl.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags)
+-gpspipe = env.Program('gpspipe', ['gpspipe.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags)
+-gps2udp = env.Program('gps2udp', ['gps2udp.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags)
+-gpxlogger = env.Program('gpxlogger', ['gpxlogger.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags)
+-lcdgps = env.Program('lcdgps', ['lcdgps.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags)
+-cgps = env.Program('cgps', ['cgps.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags + ncurseslibs)
+-ntpshmmon = env.Program('ntpshmmon', ['ntpshmmon.c'],
+- LIBS=['gps_static'], LIBPATH='.',
+- parse_flags=gpsflags)
++ LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs + ncurseslibs)
++env.Depends(gpsmon, [compiled_gpslib])
++
++gpsdctl = env.Program('gpsdctl', ['gpsdctl.c'], parse_flags=gpslibs)
++env.Depends(gpsdctl, compiled_gpslib)
++
++gpspipe = env.Program('gpspipe', ['gpspipe.c'], parse_flags=gpslibs)
++env.Depends(gpspipe, compiled_gpslib)
++
++gps2udp = env.Program('gps2udp', ['gps2udp.c'], parse_flags=gpslibs)
++env.Depends(gps2udp, compiled_gpslib)
++
++gpxlogger = env.Program('gpxlogger', ['gpxlogger.c'], parse_flags=gpslibs)
++env.Depends(gpxlogger, compiled_gpslib)
++
++lcdgps = env.Program('lcdgps', ['lcdgps.c'], parse_flags=gpslibs)
++env.Depends(lcdgps, compiled_gpslib)
++
++cgps = env.Program('cgps', ['cgps.c'], parse_flags=gpslibs + ncurseslibs)
++env.Depends(cgps, compiled_gpslib)
++
++ntpshmmon = env.Program('ntpshmmon', ['ntpshmmon.c'], parse_flags=gpslibs)
++env.Depends(ntpshmmon, compiled_gpslib)
+
+ binaries = [gpsd, gpsdecode, gpsctl, gpsdctl, gpspipe, gps2udp, gpxlogger, lcdgps, ntpshmmon]
+ if env["ncurses"]:
+--
+2.4.1
+
diff --git a/sci-geosciences/gpsd/files/gpsd-3.15-libgpsd.patch b/sci-geosciences/gpsd/files/gpsd-3.15-libgpsd.patch
new file mode 100644
index 000000000000..b8d2cf02ee8b
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.15-libgpsd.patch
@@ -0,0 +1,80 @@
+From 7b29fcb88a476daab12957ac22512edf66aee813 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 7 Jun 2015 01:08:48 -0400
+Subject: [PATCH] reenable libgpsd
+
+Upstream has decided to drop the shared libgpsd (since it wasn't used
+externally anymore), but this also meant they statically link the code
+into every app. Re-enable the shared lib so that the various runtime
+programs can continue to share and save on resources.
+---
+ SConstruct | 25 +++++++++++++------------
+ 1 file changed, 13 insertions(+), 12 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index a050f38..53f697d 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -903,7 +903,7 @@ else:
+ obj_list = []
+ for s in Flatten(sources):
+ if type(s) is str:
+- obj_list.append(env.SharedObject(s))
++ obj_list.append(env.SharedObject(s, parse_flags=parse_flags))
+ else:
+ obj_list.append(s)
+ return env.SharedLibrary(target=target,
+@@ -925,9 +925,11 @@ static_gpslib = env.StaticLibrary("gps_static",
+ [env.StaticObject(s) for s in libgps_sources],
+ rtlibs)
+
+-compiled_gpsdlib = env.StaticLibrary(target="gpsd",
+- source=[env.StaticObject(s, parse_flags=usbflags + bluezflags) for s in libgpsd_sources],
+- parse_flags=usbflags + bluezflags)
++compiled_gpsdlib = Library(env=env,
++ target="gpsd",
++ sources=libgpsd_sources,
++ version=libgps_version,
++ parse_flags=usbflags + rtlibs + bluezflags + ["-lgps"])
+
+ libraries = [compiled_gpslib, compiled_gpsdlib]
+
+@@ -985,21 +987,19 @@ gpsmon_sources = [
+
+ ## Production programs
+
+-gpsd = env.Program('gpsd', gpsd_sources,
+- LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs)
+-env.Depends(gpsd, [compiled_gpslib])
++gpsd = env.Program('gpsd', gpsd_sources, parse_flags=gpsdlibs)
++env.Depends(gpsd, [compiled_gpsdlib, compiled_gpslib])
+
+-gpsdecode = env.Program('gpsdecode', ['gpsdecode.c'],
+- LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs)
+-env.Depends(gpsdecode, [compiled_gpslib])
++gpsdecode = env.Program('gpsdecode', ['gpsdecode.c'], parse_flags=gpsdlibs)
++env.Depends(gpsdecode, [compiled_gpsdlib, compiled_gpslib])
+
+ gpsctl = env.Program('gpsctl', ['gpsctl.c'],
+ LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs)
+-env.Depends(gpsctl, [compiled_gpslib])
++env.Depends(gpsctl, [compiled_gpslib, compiled_gpslib])
+
+ gpsmon = env.Program('gpsmon', gpsmon_sources,
+ LIBS=['gpsd'], parse_flags=gpsdflags+gpslibs + ncurseslibs)
+-env.Depends(gpsmon, [compiled_gpslib])
++env.Depends(gpsmon, [compiled_gpslib, compiled_gpslib])
+
+ gpsdctl = env.Program('gpsdctl', ['gpsdctl.c'], parse_flags=gpslibs)
+ env.Depends(gpsdctl, compiled_gpslib)
+@@ -1339,6 +1339,7 @@ binaryinstall.append(env.Install(installdir('bindir'), [gpsdecode, gpsctl, gpsp
+ if env["ncurses"]:
+ binaryinstall.append(env.Install(installdir('bindir'), [cgps, gpsmon]))
+ binaryinstall.append(LibraryInstall(env, installdir('libdir'), compiled_gpslib, libgps_version))
++binaryinstall.append(LibraryInstall(env, installdir('libdir'), compiled_gpsdlib, libgps_version))
+ # Work arount a minor bug in InstallSharedLib() link handling
+ env.AddPreAction(binaryinstall, 'rm -f %s/libgps.*' % (installdir('libdir'), ))
+
+--
+2.4.1
+
diff --git a/sci-geosciences/gpsd/gpsd-3.15.ebuild b/sci-geosciences/gpsd/gpsd-3.15.ebuild
new file mode 100644
index 000000000000..cb2b2ccd76dd
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-3.15.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.15.ebuild,v 1.1 2015/06/07 17:53:38 vapier Exp $
+
+EAPI="5"
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python2_7 )
+SCONS_MIN_VERSION="1.2.1"
+
+inherit eutils udev user multilib distutils-r1 scons-utils toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
+ inherit git-2
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
+HOMEPAGE="http://catb.org/gpsd/"
+
+LICENSE="BSD"
+SLOT="0"
+
+GPSD_PROTOCOLS=(
+ aivdm ashtech earthmate evermore fury fv18 garmin garmintxt
+ geostar gpsclock itrax mtk3301 navcom nmea0183 nmea2000 ntrip
+ oceanserver oncore passthrough rtcm104v2 rtcm104v3 sirf superstar2
+ tnt tripmate tsip ublox
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 latency_timing ncurses ntp python qt4 +shm +sockets static test udev usb X"
+REQUIRED_USE="X? ( python )
+ gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="X? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
+ ncurses? ( sys-libs/ncurses )
+ bluetooth? ( net-wireless/bluez )
+ usb? ( virtual/libusb:1 )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ntp? ( || ( net-misc/ntp net-misc/chrony ) )
+ qt4? ( dev-qt/qtgui:4 )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sys-devel/bc )"
+
+# xml packages are for man page generation
+if [[ ${PV} == "9999" ]] ; then
+ DEPEND+="
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*"
+fi
+
+src_prepare() {
+ # Make sure our list matches the source.
+ local src_protocols=$(echo $(
+ sed -n '/# GPS protocols/,/# Time service/{s:#.*::;s:[(",]::g;p}' "${S}"/SConstruct | awk '{print $1}' | LC_ALL=C sort
+ ) )
+ if [[ ${src_protocols} != ${GPSD_PROTOCOLS[*]} ]] ; then
+ eerror "Detected protocols: ${src_protocols}"
+ eerror "Ebuild protocols: ${GPSD_PROTOCOLS[*]}"
+ die "please sync ebuild & source"
+ fi
+
+ epatch "${FILESDIR}"/${PN}-3.8-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-3.15-dynamic-libs.patch
+ epatch "${FILESDIR}"/${PN}-3.15-libgpsd.patch
+ epatch "${FILESDIR}"/${PN}-3.15-broken-install.patch
+
+ # Avoid useless -L paths to the install dir
+ sed -i \
+ -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
+ SConstruct || die
+
+ use python && distutils-r1_src_prepare
+}
+
+python_prepare_all() {
+ python_export_best
+ # Extract python info out of SConstruct so we can use saner distribute
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+ local pybins=$(pyvar python_progs | tail -1)
+ local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
+ local packet=$("${PYTHON}" -c "${pysrcs}; print(python_extensions['gps/packet'])")
+ local client=$("${PYTHON}" -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
+ sed \
+ -e "s|@VERSION@|$(pyvar gpsd_version)|" \
+ -e "s|@URL@|$(pyvar website)|" \
+ -e "s|@EMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
+ -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ myesconsargs=(
+ prefix="${EPREFIX}/usr"
+ libdir="\$prefix/$(get_libdir)"
+ udevdir="$(get_udevdir)"
+ chrpath=False
+ gpsd_user=gpsd
+ gpsd_group=uucp
+ nostrip=True
+ python=False
+ manbuild=False
+ shared=$(usex !static True False)
+ $(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
+ $(use_scons debug clientdebug)
+ $(use_scons dbus dbus_export)
+ $(use_scons ipv6)
+ $(use_scons latency_timing timing)
+ $(use_scons ncurses)
+ $(use_scons ntp ntpshm)
+ $(use_scons ntp pps)
+ $(use_scons shm shm_export)
+ $(use_scons sockets socket_export)
+ $(use_scons qt4 libQgpsmm)
+ $(use_scons usb)
+ )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
+ done
+}
+
+src_compile() {
+ export CHRPATH=
+ tc-export CC CXX PKG_CONFIG
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons
+
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ DESTDIR="${D}" escons install $(usex udev udev-install "")
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ if use python ; then
+ distutils-r1_src_install
+ # Delete all X related packages if user doesn't want them
+ if ! use X ; then
+ rm "${ED%/}"/usr/bin/xgps* || die
+ fi
+ fi
+}
+
+pkg_preinst() {
+ # Run the gpsd daemon as gpsd and group uucp; create it here
+ # as it doesn't seem to be needed during compile/install ...
+ enewuser gpsd -1 -1 -1 "uucp"
+}