summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-09-05 04:41:48 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-09-05 04:41:48 +0000
commitc2ad389d18780b18366aeafb1d49486c340177af (patch)
treea098d48b29fda5a40ceb04a78487d3da0a71e901 /sci-geosciences/grass
parentMigrate to wxGTK-2.8. (diff)
downloadgentoo-2-c2ad389d18780b18366aeafb1d49486c340177af.tar.gz
gentoo-2-c2ad389d18780b18366aeafb1d49486c340177af.tar.bz2
gentoo-2-c2ad389d18780b18366aeafb1d49486c340177af.zip
s/wxwindows/wxwidgets
(Portage version: 2.2_rc75/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog5
-rw-r--r--sci-geosciences/grass/grass-6.3.0.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 87628bd64d33..3edb44c5ff3c 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.89 2010/09/04 02:29:11 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.90 2010/09/05 04:41:48 dirtyepic Exp $
+
+ 05 Sep 2010; Ryan Hill <dirtyepic@gentoo.org> grass-6.3.0.ebuild:
+ s/wxwindows/wxwidgets
*grass-6.4.0 (04 Sep 2010)
diff --git a/sci-geosciences/grass/grass-6.3.0.ebuild b/sci-geosciences/grass/grass-6.3.0.ebuild
index c33dd75167b9..fe57648031eb 100644
--- a/sci-geosciences/grass/grass-6.3.0.ebuild
+++ b/sci-geosciences/grass/grass-6.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.15 2010/06/17 21:03:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.3.0.ebuild,v 1.16 2010/09/05 04:41:48 dirtyepic Exp $
inherit eutils distutils fdo-mime versionator wxwidgets
@@ -17,7 +17,7 @@ SLOT="6"
KEYWORDS="amd64 ppc ~ppc64 sparc x86"
IUSE="ffmpeg fftw gmath jpeg largefile motif mysql nls odbc opengl png \
-postgres python readline sqlite tiff truetype wxwindows X"
+postgres python readline sqlite tiff truetype wxwidgets X"
RESTRICT="strip"
@@ -48,7 +48,7 @@ RDEPEND=">=sys-libs/zlib-1.1.4
sqlite? ( dev-db/sqlite )
tiff? ( >=media-libs/tiff-3.5.7 )
truetype? ( >=media-libs/freetype-2.0 )
- wxwindows? (
+ wxwidgets? (
>=dev-python/wxpython-2.8.1.1
>=dev-lang/python-2.4
)
@@ -69,7 +69,7 @@ RDEPEND=">=sys-libs/zlib-1.1.4
DEPEND="${RDEPEND}
>=sys-devel/flex-2.5.4a
>=sys-devel/bison-1.35
- wxwindows? ( >=dev-lang/swig-1.3.31 )
+ wxwidgets? ( >=dev-lang/swig-1.3.31 )
X? (
x11-proto/xproto
x11-proto/xextproto
@@ -80,7 +80,7 @@ pkg_setup() {
elog ""
elog "This version enables the experimental wxpython interface, which"
elog "you may want to try. If the legacy GUI seems a little wonky in"
- elog "this version, just enable the wxwindows USE flag and rebuild"
+ elog "this version, just enable the wxwidgets USE flag and rebuild"
elog "grass to use it."
elog ""
if use gmath; then
@@ -149,7 +149,7 @@ src_compile() {
myconf="${myconf} --with-tcltk --with-x \
--with-tcltk-includes=/usr/include \
--with-tcltk-libs=${TCL_LIBDIR}"
- if use wxwindows; then
+ if use wxwidgets; then
WX_GTK_VER=2.8
need-wxwidgets unicode
# The following lib should be there, based on the above and the
@@ -158,7 +158,7 @@ src_compile() {
LIBGDI="$(python_get_sitedir)/wx-${WX_GTK_VER}-gtk2-unicode/wx/_gdi_.so"
myconf="${myconf} --with-python --with-wxwidgets=${WX_CONFIG}"
else
- # USE=python must be enabled above if wxwindows is enabled
+ # USE=python must be enabled above if wxwidgets is enabled
myconf="${myconf} $(use_with python) --without-wxwidgets"
fi
else
@@ -221,7 +221,7 @@ src_compile() {
$(use_with readline) \
$(use_with tiff) || die "configure failed!"
- if use wxwindows; then
+ if use wxwidgets; then
# can't use die here since we need to hack the vdigit build
emake -j1
ln -sf "${LIBGDI}" dist.${CHOST}/lib/libgdi.so \
@@ -240,7 +240,7 @@ src_install() {
PREFIX="${D}"usr INST_DIR="${D}"usr/${MY_PM} \
|| die "make install failed!"
- if use wxwindows; then
+ if use wxwidgets; then
ln -sf "${LIBGDI}" "${D}"usr/${MY_PM}/lib/libgdi.so \
|| die "failed to find wx library"
fi
@@ -274,7 +274,7 @@ pkg_postrm() {
generate_files() {
local GUI="-gui"
- use wxwindows && GUI="-wxpython"
+ use wxwidgets && GUI="-wxpython"
cat <<-EOF > 99grass-6
GRASS_LD_LIBRARY_PATH="/usr/${MY_PM}/lib"