summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-03 07:37:07 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-03 07:37:07 +0000
commitf533d40f4ceb975a12baa19c61db50caaf123a4b (patch)
tree3fd49f8c85d39f631e552506fa1380f8c83ad508 /sci-electronics
parentUpdate wine to autotools-multilib.eclass (diff)
downloadgentoo-2-f533d40f4ceb975a12baa19c61db50caaf123a4b.tar.gz
gentoo-2-f533d40f4ceb975a12baa19c61db50caaf123a4b.tar.bz2
gentoo-2-f533d40f4ceb975a12baa19c61db50caaf123a4b.zip
Fix build with GCC 4.7 (bug #450856).
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/plcedit/ChangeLog6
-rw-r--r--sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch15
-rw-r--r--sci-electronics/plcedit/plcedit-2.2.1.ebuild4
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-electronics/plcedit/ChangeLog b/sci-electronics/plcedit/ChangeLog
index 707e3d48579e..cefcafd812f0 100644
--- a/sci-electronics/plcedit/ChangeLog
+++ b/sci-electronics/plcedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/plcedit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/plcedit/ChangeLog,v 1.17 2013/03/02 23:19:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/plcedit/ChangeLog,v 1.18 2013/03/03 07:37:07 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> plcedit-2.2.1.ebuild,
+ +files/plcedit-2.2.1-gcc47.patch:
+ Fix build with GCC 4.7 (bug #450856).
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> plcedit-2.2.1.ebuild:
Move Qt dependencies to the new category
diff --git a/sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch b/sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch
new file mode 100644
index 000000000000..046a27cbac8c
--- /dev/null
+++ b/sci-electronics/plcedit/files/plcedit-2.2.1-gcc47.patch
@@ -0,0 +1,15 @@
+ https://bugs.gentoo.org/450856
+
+ src/singleapp/qtlocalpeer.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/src/singleapp/qtlocalpeer.cpp
++++ b/src/singleapp/qtlocalpeer.cpp
+@@ -57,6 +57,7 @@ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
+ #include <time.h>
++#include <unistd.h>
+ #endif
+
+ namespace QtLP_Private {
diff --git a/sci-electronics/plcedit/plcedit-2.2.1.ebuild b/sci-electronics/plcedit/plcedit-2.2.1.ebuild
index c993cc7607ee..2b5fc08b01ff 100644
--- a/sci-electronics/plcedit/plcedit-2.2.1.ebuild
+++ b/sci-electronics/plcedit/plcedit-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/plcedit/plcedit-2.2.1.ebuild,v 1.5 2013/03/02 23:19:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/plcedit/plcedit-2.2.1.ebuild,v 1.6 2013/03/03 07:37:07 dirtyepic Exp $
EAPI="2"
@@ -21,6 +21,8 @@ RDEPEND="dev-qt/qtgui:4"
DEPEND="${RDEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+
if use doc; then
sed -i -e "/helpDir =/s:Help:html:" \
-e "s:(QApplication\:\:applicationDirPath():\"/usr/share/doc/${PF}\":g" \