summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-26 09:22:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-26 09:22:55 +0000
commit8e8b1806e4c1add1a8b709c17747385d8cfbf233 (patch)
tree0cea2e593ed37fe90980f4c8c738f4149ce352ea /sci-electronics/xcircuit
parentToday's python patches added (diff)
downloadgentoo-2-8e8b1806e4c1add1a8b709c17747385d8cfbf233.tar.gz
gentoo-2-8e8b1806e4c1add1a8b709c17747385d8cfbf233.tar.bz2
gentoo-2-8e8b1806e4c1add1a8b709c17747385d8cfbf233.zip
Version bump.
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog10
-rw-r--r--sci-electronics/xcircuit/files/xcircuit-3.6.165-implicit.patch12
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.6.165.ebuild (renamed from sci-electronics/xcircuit/xcircuit-3.6.161.ebuild)30
3 files changed, 40 insertions, 12 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index afe59472ca90..16227aa1fc3d 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/xcircuit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.44 2009/12/26 17:45:00 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.45 2010/02/26 09:22:54 ssuominen Exp $
+
+*xcircuit-3.6.165 (26 Feb 2010)
+
+ 26 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xcircuit-3.6.165.ebuild, +files/xcircuit-3.6.165-implicit.patch:
+ Version bump wrt #294774, thanks to Lukas Sandström for reporting.
26 Dec 2009; Peter Volkov <pva@gentoo.org> xcircuit-3.4.30.ebuild,
xcircuit-3.6.161.ebuild:
diff --git a/sci-electronics/xcircuit/files/xcircuit-3.6.165-implicit.patch b/sci-electronics/xcircuit/files/xcircuit-3.6.165-implicit.patch
new file mode 100644
index 000000000000..210070a71719
--- /dev/null
+++ b/sci-electronics/xcircuit/files/xcircuit-3.6.165-implicit.patch
@@ -0,0 +1,12 @@
+svg.c:240: warning: incompatible implicit declaration of built-in function ‘execlp’
+
+--- svg.c
++++ svg.c
+@@ -10,6 +10,7 @@
+ #include <limits.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <unistd.h> /* execlp */
+
+ #ifndef _MSC_VER
+ #include <X11/Intrinsic.h>
diff --git a/sci-electronics/xcircuit/xcircuit-3.6.161.ebuild b/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild
index a7ae333c75b5..782b0d82c486 100644
--- a/sci-electronics/xcircuit/xcircuit-3.6.161.ebuild
+++ b/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild
@@ -1,27 +1,33 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.6.161.ebuild,v 1.2 2009/12/26 17:45:00 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild,v 1.1 2010/02/26 09:22:54 ssuominen Exp $
EAPI=2
-inherit autotools
+inherit autotools eutils
DESCRIPTION="Circuit drawing and schematic capture program."
SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
HOMEPAGE="http://opencircuitdesign.com/xcircuit"
-KEYWORDS=""
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND="app-text/ghostscript-gpl
- dev-lang/tk
- x11-libs/libXt"
-DEPEND="${RDEPEND}"
+DEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE
+ sys-libs/zlib
+ app-text/ghostscript-gpl
+ dev-lang/tcl
+ dev-lang/tk"
RESTRICT="test" #131024
src_prepare() {
+ epatch "${FILESDIR}"/${P}-implicit.patch
eautoreconf
}
@@ -32,8 +38,12 @@ src_configure() {
--with-ngspice
}
+src_compile() {
+ emake appdefaultsdir="/usr/share/X11/app-defaults" || die
+}
+
src_install () {
emake DESTDIR="${D}" appdefaultsdir="/usr/share/X11/app-defaults" \
- appmandir="/usr/share/man/man1" install || die "emake install failed"
+ appmandir="/usr/share/man/man1" install || die
dodoc CHANGES README* TODO
}