summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-05-06 17:02:28 +0000
committerMichael Weber <xmw@gentoo.org>2013-05-06 17:02:28 +0000
commit408ab8c3c91250f1fb491e67974f86b1175b1c0e (patch)
tree898d512fe74c62021e53e611f0e811ee020ce2b1 /sci-electronics/xcircuit
parentFix results coming from misusage of 'patch', now it's correct. (diff)
downloadgentoo-2-408ab8c3c91250f1fb491e67974f86b1175b1c0e.tar.gz
gentoo-2-408ab8c3c91250f1fb491e67974f86b1175b1c0e.tar.bz2
gentoo-2-408ab8c3c91250f1fb491e67974f86b1175b1c0e.zip
Version bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sci-electronics/xcircuit')
-rw-r--r--sci-electronics/xcircuit/ChangeLog8
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.6.165.ebuild5
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.8.38.ebuild63
3 files changed, 73 insertions, 3 deletions
diff --git a/sci-electronics/xcircuit/ChangeLog b/sci-electronics/xcircuit/ChangeLog
index 156f0b438423..6a60e574c56b 100644
--- a/sci-electronics/xcircuit/ChangeLog
+++ b/sci-electronics/xcircuit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/xcircuit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.58 2013/03/13 14:53:57 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/ChangeLog,v 1.59 2013/05/06 17:02:28 xmw Exp $
+
+*xcircuit-3.8.38 (06 May 2013)
+
+ 06 May 2013; Michael Weber <xmw@gentoo.org> +xcircuit-3.8.38.ebuild,
+ xcircuit-3.6.165.ebuild:
+ Version bump
*xcircuit-3.8.37 (13 Mar 2013)
diff --git a/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild b/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild
index db2b6d73ea60..447ab95e401b 100644
--- a/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild
+++ b/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild,v 1.5 2010/07/18 13:36:50 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.6.165.ebuild,v 1.6 2013/05/06 17:02:28 xmw Exp $
EAPI=2
inherit autotools eutils multilib
@@ -23,6 +23,7 @@ DEPEND="x11-libs/libX11
app-text/ghostscript-gpl
dev-lang/tcl
dev-lang/tk"
+RDEPEND="${DEPEND}"
RESTRICT="test" #131024
diff --git a/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild b/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild
new file mode 100644
index 000000000000..b94654e06ccc
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xcircuit/xcircuit-3.8.38.ebuild,v 1.1 2013/05/06 17:02:28 xmw Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils multilib
+
+DESCRIPTION="Circuit drawing and schematic capture program."
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ app-text/ghostscript-gpl
+ dev-lang/tk
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libSM
+ x11-libs/libICE"
+RDEPEND=${DEPEND}
+
+RESTRICT="test" #131024
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ # automake-1.12
+ sed \
+ -e '/AM_C_PROTOTYPES/d' \
+ -i configure.in || die
+ # automake-1.13
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ export loader_run_path="/usr/$(get_libdir)"
+ local myeconfargs=(
+ --disable-dependency-tracking
+ --with-tcl
+ --with-ngspice
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults"
+}
+
+src_install () {
+ autotools-utils_src_install \
+ appdefaultsdir="/usr/share/X11/app-defaults" \
+ appmandir="/usr/share/man/man1"
+}