summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-02-16 00:49:16 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-02-16 00:49:16 +0000
commitf521c9609156dda1009232e9b208a2d75f628bba (patch)
treec98569efd1976149b2663791332c15883009f6e9 /sci-electronics/vbs
parentmove log file name into a variable (diff)
downloadgentoo-2-f521c9609156dda1009232e9b208a2d75f628bba.tar.gz
gentoo-2-f521c9609156dda1009232e9b208a2d75f628bba.tar.bz2
gentoo-2-f521c9609156dda1009232e9b208a2d75f628bba.zip
Add gcc-4.3 patch per bug 251627. Thanks to Gene Seto <geneseto@hotmail.com> for the patch.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/vbs')
-rw-r--r--sci-electronics/vbs/ChangeLog9
-rw-r--r--sci-electronics/vbs/files/vbs-1.4.0-gcc-4.3.patch30
-rw-r--r--sci-electronics/vbs/vbs-1.4.0.ebuild5
3 files changed, 40 insertions, 4 deletions
diff --git a/sci-electronics/vbs/ChangeLog b/sci-electronics/vbs/ChangeLog
index 4c34adc77f4d..a56f0e90f883 100644
--- a/sci-electronics/vbs/ChangeLog
+++ b/sci-electronics/vbs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/vbs
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/ChangeLog,v 1.6 2007/03/09 22:34:48 calchan Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/ChangeLog,v 1.7 2009/02/16 00:49:15 loki_val Exp $
+
+ 16 Feb 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/vbs-1.4.0-gcc-4.3.patch, vbs-1.4.0.ebuild:
+ Add gcc-4.3 patch per bug 251627. Thanks to Gene Seto
+ <geneseto@hotmail.com> for the patch.
09 Mar 2007; Denis Dupeyron <calchan@gentoo.org>
+files/vbs-1.4.0-gcc-4.1.patch, -files/vbs-gcc-3.4.patch,
diff --git a/sci-electronics/vbs/files/vbs-1.4.0-gcc-4.3.patch b/sci-electronics/vbs/files/vbs-1.4.0-gcc-4.3.patch
new file mode 100644
index 000000000000..c0a62e1d0e22
--- /dev/null
+++ b/sci-electronics/vbs/files/vbs-1.4.0-gcc-4.3.patch
@@ -0,0 +1,30 @@
+--- vbs-1.4.0b/src/common/dumpstrm.cc 2009-01-21 02:42:43.000000000 -0400
++++ vbs-1.4.0/src/common/dumpstrm.cc 2009-01-21 02:48:57.000000000 -0400
+@@ -13,6 +13,7 @@
+
+ #include <cstdio> // sprintf
+ #include <iostream>
++#include <cstdlib>
+ #include "dumpstrm.h"
+
+ using std::cerr;
+--- vbs-1.4.0b/src/common/logic.h 2009-01-21 02:42:43.000000000 -0400
++++ vbs-1.4.0/src/common/logic.h 2009-01-21 02:48:05.000000000 -0400
+@@ -18,6 +18,7 @@
+
+ #ifndef _LOGIC_H
+ #define _LOGIC_H
++#include <cstdlib>
+
+ class logic
+ {
+--- vbs-1.4.0b/src/common/bvector.h 2009-01-21 02:42:43.000000000 -0400
++++ vbs-1.4.0/src/common/bvector.h 2009-01-21 02:46:31.000000000 -0400
+@@ -30,6 +30,7 @@
+ #include <string>
+ #include <utility>
+ #include <iostream>
++#include <cstring>
+ #include "common/logic.h"
+
+ class bit_vector
diff --git a/sci-electronics/vbs/vbs-1.4.0.ebuild b/sci-electronics/vbs/vbs-1.4.0.ebuild
index d7cf0e3a5a9a..975ba2b152f1 100644
--- a/sci-electronics/vbs/vbs-1.4.0.ebuild
+++ b/sci-electronics/vbs/vbs-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
+# Copyright 1999-2009 Gentoo Foundation and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/vbs-1.4.0.ebuild,v 1.3 2007/03/09 22:34:48 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/vbs/vbs-1.4.0.ebuild,v 1.4 2009/02/16 00:49:15 loki_val Exp $
inherit eutils
@@ -20,6 +20,7 @@ src_unpack () {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-gcc-4.1.patch
+ epatch ${FILESDIR}/${P}-gcc-4.3.patch
}
src_compile () {