summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-10-11 12:44:59 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-10-11 12:44:59 +0000
commit7f611faac45250e0568dda978c6512ed099e89d3 (patch)
tree94338f681059014d517f9d69312291934b8da5e1 /sci-electronics/ghdl
parentstable ppc, bug #195387 (diff)
downloadgentoo-2-7f611faac45250e0568dda978c6512ed099e89d3.tar.gz
gentoo-2-7f611faac45250e0568dda978c6512ed099e89d3.tar.bz2
gentoo-2-7f611faac45250e0568dda978c6512ed099e89d3.zip
Fixed issue similar to bug #195074, thanks to vapier for his binutils fix which I have ported to ghdl. Quoting fixes.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sci-electronics/ghdl')
-rw-r--r--sci-electronics/ghdl/ChangeLog6
-rw-r--r--sci-electronics/ghdl/ghdl-0.26.ebuild28
2 files changed, 21 insertions, 13 deletions
diff --git a/sci-electronics/ghdl/ChangeLog b/sci-electronics/ghdl/ChangeLog
index 5c95cdb6e422..4e397006a614 100644
--- a/sci-electronics/ghdl/ChangeLog
+++ b/sci-electronics/ghdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/ghdl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.1 2007/06/29 21:11:15 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ChangeLog,v 1.2 2007/10/11 12:44:59 calchan Exp $
+
+ 11 Oct 2007; Denis Dupeyron <calchan@gentoo.org> ghdl-0.26.ebuild:
+ Fixed issue similar to bug #195074, thanks to vapier for his binutils fix
+ which I have ported to ghdl. Quoting fixes.
*ghdl-0.26 (29 Jun 2007)
diff --git a/sci-electronics/ghdl/ghdl-0.26.ebuild b/sci-electronics/ghdl/ghdl-0.26.ebuild
index ed551bb37981..de728728af34 100644
--- a/sci-electronics/ghdl/ghdl-0.26.ebuild
+++ b/sci-electronics/ghdl/ghdl-0.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.26.ebuild,v 1.1 2007/06/29 21:11:15 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ghdl/ghdl-0.26.ebuild,v 1.2 2007/10/11 12:44:59 calchan Exp $
inherit multilib
@@ -22,14 +22,18 @@ MAKEOPTS="-j1"
src_unpack() {
unpack ${A}
- cd ${S}
- mv ${WORKDIR}/${P}/vhdl gcc
+ cd "${S}"
+ mv "${WORKDIR}/${P}"/vhdl gcc
sed -i \
-e 's/ADAC = \$(CC)/ADAC = gnatgcc/' \
-e '/^CFLAGS = -g/d' \
gcc/vhdl/Makefile.in || die "sed failed"
sed -i -e 's/"-O -g"/"$(CFLAGS)"/' gcc/vhdl/Make-lang.in || die "sed failed"
+ # Fix issue similar to bug #195074, ported from vapier's fix for binutils
+ sed -i -e "s:egrep.*texinfo.*dev/null:egrep 'texinfo[^0-9]*(4\.([4-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null:" \
+ configure* || die "sed failed"
+
# Fix atan2 bug in math_complex-body.vhdl
sed -i -e 's/atan2(z.re,z.im)/atan2(z.im,z.re)/' \
gcc/vhdl/libraries/ieee/math_complex-body.vhdl || die "sed failed"
@@ -43,13 +47,13 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "Installation failed"
- cd ${D}/usr/bin ; rm `ls --ignore=ghdl`
- rm -rf ${D}/usr/include
- rm ${D}/usr/$(get_libdir)/lib*
- cd ${D}/usr/$(get_libdir)/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=vhdl*`
- cd ${D}/usr/libexec/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=ghdl*`
- cd ${D}/usr/share/info ; rm `ls --ignore=ghdl*`
- cd ${D}/usr/share/man/man1 ; rm `ls --ignore=ghdl*`
- rm -Rf ${D}/usr/share/locale
- rm -Rf ${D}/usr/share/man/man7
+ cd "${D}"/usr/bin ; rm `ls --ignore=ghdl`
+ rm -rf "${D}"/usr/include
+ rm "${D}"/usr/$(get_libdir)/lib*
+ cd "${D}"/usr/$(get_libdir)/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=vhdl*`
+ cd "${D}"/usr/libexec/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=ghdl*`
+ cd "${D}"/usr/share/info ; rm `ls --ignore=ghdl*`
+ cd "${D}"/usr/share/man/man1 ; rm `ls --ignore=ghdl*`
+ rm -Rf "${D}"/usr/share/locale
+ rm -Rf "${D}"/usr/share/man/man7
}