summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-02-10 06:35:25 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-02-10 06:35:25 +0000
commit9683069b6742fe6fd5e482602560d5c8693dd31f (patch)
treee82a536a2bf3c9dea6ba5a95b7fe4dcb9773686f /sci-electronics/gerbv
parentRemove old. (diff)
downloadgentoo-2-9683069b6742fe6fd5e482602560d5c8693dd31f.tar.gz
gentoo-2-9683069b6742fe6fd5e482602560d5c8693dd31f.tar.bz2
gentoo-2-9683069b6742fe6fd5e482602560d5c8693dd31f.zip
Version bump (bug #401825). Thanks to A. Walker
(Portage version: 2.1.10.45/cvs/Linux x86_64)
Diffstat (limited to 'sci-electronics/gerbv')
-rw-r--r--sci-electronics/gerbv/ChangeLog9
-rw-r--r--sci-electronics/gerbv/gerbv-2.6.0.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/sci-electronics/gerbv/ChangeLog b/sci-electronics/gerbv/ChangeLog
index c918f8cc9257..2a54947cfe4b 100644
--- a/sci-electronics/gerbv/ChangeLog
+++ b/sci-electronics/gerbv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/gerbv
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.41 2011/06/28 19:53:20 ranger Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/ChangeLog,v 1.42 2012/02/10 06:35:25 tomjbe Exp $
+
+*gerbv-2.6.0 (10 Feb 2012)
+
+ 10 Feb 2012; Thomas Beierlein <tomjbe@gentoo.org> +gerbv-2.6.0.ebuild:
+ Version bump (bug #401825). Thanks to A. Walker
28 Jun 2011; Brent Baude <ranger@gentoo.org> gerbv-2.4.0.ebuild:
Marking gerbv-2.4.0 ppc for bug 342811
diff --git a/sci-electronics/gerbv/gerbv-2.6.0.ebuild b/sci-electronics/gerbv/gerbv-2.6.0.ebuild
new file mode 100644
index 000000000000..0acb260d5672
--- /dev/null
+++ b/sci-electronics/gerbv/gerbv-2.6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gerbv/gerbv-2.6.0.ebuild,v 1.1 2012/02/10 06:35:25 tomjbe Exp $
+
+EAPI="4"
+
+inherit fdo-mime
+
+DESCRIPTION="A RS-274X (Gerber) and NC drill (Excellon) file viewer"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://gerbv.sourceforge.net/"
+
+IUSE="unit-mm doc examples"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/cairo"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable unit-mm) \
+ --disable-update-desktop-database
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS BUGS ChangeLog CONTRIBUTORS HACKING NEWS README* TODO
+
+ rm doc/Doxyfile.nopreprocessing
+ if use doc; then
+ find doc -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r doc/*
+ fi
+
+ if use examples; then
+ find example -name "Makefile*" -exec rm -f '{}' \;
+ dodoc -r example/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}