summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2007-11-10 22:52:52 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2007-11-10 22:52:52 +0000
commite7fa2d76d2c2cb15597c2e31d17964e45ce95481 (patch)
treee3d1c67abba23260223a2970dd0213e2f6cb9e43 /sci-electronics/eagle
parentStable on ppc64; bug #198719 (diff)
downloadgentoo-2-e7fa2d76d2c2cb15597c2e31d17964e45ce95481.tar.gz
gentoo-2-e7fa2d76d2c2cb15597c2e31d17964e45ce95481.tar.bz2
gentoo-2-e7fa2d76d2c2cb15597c2e31d17964e45ce95481.zip
Added script to /usr/bin to execute eagle as recommended by CadSoft - see bug #188368.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-electronics/eagle')
-rw-r--r--sci-electronics/eagle/ChangeLog11
-rw-r--r--sci-electronics/eagle/eagle-4.16_p1.ebuild9
-rw-r--r--sci-electronics/eagle/eagle-4.16_p2-r1.ebuild93
-rw-r--r--sci-electronics/eagle/eagle-4.16_p2.ebuild11
-rw-r--r--sci-electronics/eagle/files/digest-eagle-4.16_p2-r112
-rw-r--r--sci-electronics/eagle/files/eagle_wrapper_script8
6 files changed, 134 insertions, 10 deletions
diff --git a/sci-electronics/eagle/ChangeLog b/sci-electronics/eagle/ChangeLog
index 1fbd0aba08d8..b46c3311d076 100644
--- a/sci-electronics/eagle/ChangeLog
+++ b/sci-electronics/eagle/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-electronics/eagle
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.9 2007/10/13 14:11:06 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/ChangeLog,v 1.10 2007/11/10 22:52:51 nixphoeni Exp $
+
+*eagle-4.16_p2-r1 (10 Nov 2007)
+
+ 10 Nov 2007; Joe Sapp <nixphoeni@gentoo.org> +files/eagle_wrapper_script,
+ eagle-4.16_p1.ebuild, eagle-4.16_p2.ebuild, +eagle-4.16_p2-r1.ebuild:
+ Added script to /usr/bin to execute eagle as recommended by CadSoft at
+ http://www.cadsoft.de/faq.htm#17040701 . Also see bug #188368. This
+ eliminates the need to append the eagle directory to the PATH env var.
+ Also quoted variables that may need it.
13 Oct 2007; Christoph Mende <angelos@gentoo.org> eagle-4.16_p2.ebuild:
Stable on amd64 wrt bug #188368
diff --git a/sci-electronics/eagle/eagle-4.16_p1.ebuild b/sci-electronics/eagle/eagle-4.16_p1.ebuild
index 50f1ad339ea7..26b3c71f753c 100644
--- a/sci-electronics/eagle/eagle-4.16_p1.ebuild
+++ b/sci-electronics/eagle/eagle-4.16_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p1.ebuild,v 1.5 2007/09/13 01:42:17 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p1.ebuild,v 1.6 2007/11/10 22:52:51 nixphoeni Exp $
inherit eutils
@@ -37,7 +37,7 @@ case "${LINGUAS}" in
esac
MANFILE=${MANDOC}-${MY_LANG}-${MANVER}.pdf
MY_P=${PN}-lin-${MY_LANG}-${MY_PV}
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack() {
@@ -55,7 +55,7 @@ src_install() {
# Install the documentation
dodoc README doc/*
- use doc && cp ${MANFILE} ${D}/usr/share/doc/${PF}
+ use doc && cp ${MANFILE} "${D}"/usr/share/doc/${PF}
doman man/eagle.1
# Remove docs left in INSTALLDIR
rm -rf "${D}"/${INSTALLDIR}/{README,install,${MANFILE}} "${D}"/${INSTALLDIR}/doc "${D}"/${INSTALLDIR}/man
@@ -71,7 +71,8 @@ src_install() {
pkg_postinst() {
- elog "Run \`env-update && source /etc/profile\` now to set up the correct paths."
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
elog "You must first run eagle as root to invoke product registration."
}
diff --git a/sci-electronics/eagle/eagle-4.16_p2-r1.ebuild b/sci-electronics/eagle/eagle-4.16_p2-r1.ebuild
new file mode 100644
index 000000000000..ff4561bb8d63
--- /dev/null
+++ b/sci-electronics/eagle/eagle-4.16_p2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p2-r1.ebuild,v 1.1 2007/11/10 22:52:51 nixphoeni Exp $
+
+inherit eutils
+
+DESCRIPTION="EAGLE Layout Editor"
+HOMEPAGE="http://www.cadsoft.de"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_de doc"
+LICENSE="cadsoft"
+RESTRICT="strip"
+SLOT="0"
+
+MY_PV=${PV/_p/r}
+MANDOC="cadsoft_eagle_manual"
+#
+# When updating this package:
+# 1) fetch the english and german documentation
+# 2) update the following MANVER to the document's date
+# 3) rename the docs to "${MANDOC}-{eng,ger}-${MANVER}.pdf"
+# 4) stick them on the mirrors (or in your local ${DISTDIR})
+#
+MANVER="2006.12.13"
+
+SRC_URI="linguas_de? ( ftp://ftp.cadsoft.de/pub/program/${MY_PV}/${PN}-lin-ger-${MY_PV}.tgz
+ doc? ( mirror://gentoo/${MANDOC}-ger-${MANVER}.pdf ) )
+ !linguas_de? ( ftp://ftp.cadsoft.de/pub/program/${MY_PV}/${PN}-lin-eng-${MY_PV}.tgz
+ doc? ( mirror://gentoo/${MANDOC}-eng-${MANVER}.pdf ) )"
+
+RDEPEND="sys-libs/glibc
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+
+INSTALLDIR="/opt/eagle"
+case "${LINGUAS}" in
+ *de*)
+ MY_LANG="ger";;
+ *)
+ MY_LANG="eng";;
+esac
+MANFILE=${MANDOC}-${MY_LANG}-${MANVER}.pdf
+MY_P=${PN}-lin-${MY_LANG}-${MY_PV}
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+
+ unpack ${MY_P}.tgz
+ use doc && cp "${DISTDIR}"/${MANFILE} "${S}"
+
+}
+
+src_install() {
+
+ cd "${S}"
+ dodir ${INSTALLDIR}
+ # Copy all to INSTALLDIR
+ cp -r . "${D}"/${INSTALLDIR}
+
+ # Install wrapper (suppressing leading tabs)
+ # see bug #188368 or http://www.cadsoft.de/faq.htm#17040701
+ exeinto /usr/bin
+ newexe "${FILESDIR}/eagle_wrapper_script" eagle
+ # Finally, append the path of the eagle binary respecting INSTALLDIR
+ echo "${INSTALLDIR}/bin/eagle" >> "${D}/usr/bin/eagle"
+
+ # Install the documentation
+ dodoc README doc/*
+ doman man/eagle.1
+ # Conditionally install the user's manual
+ use doc && cp ${MANFILE} "${D}/usr/share/doc/${PF}"
+ # Remove docs left in INSTALLDIR
+ rm -rf "${D}${INSTALLDIR}/{README,install,${MANFILE}}" "${D}${INSTALLDIR}/doc" "${D}${INSTALLDIR}/man"
+
+ echo -e "ROOTPATH=${INSTALLDIR}/bin\nPRELINK_PATH_MASK=${INSTALLDIR}" > "${S}/90eagle"
+ doenvd "${S}/90eagle"
+
+ # Create desktop entry
+ doicon bin/${PN}.xpm
+ make_desktop_entry ${PN} ${PN} ${PN}.xpm "Graphics;Electronics"
+
+}
+
+pkg_postinst() {
+
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
+ elog "You must first run eagle as root to invoke product registration."
+
+}
diff --git a/sci-electronics/eagle/eagle-4.16_p2.ebuild b/sci-electronics/eagle/eagle-4.16_p2.ebuild
index c3b50a718434..c6473924d599 100644
--- a/sci-electronics/eagle/eagle-4.16_p2.ebuild
+++ b/sci-electronics/eagle/eagle-4.16_p2.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p2.ebuild,v 1.4 2007/10/13 14:11:06 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/eagle/eagle-4.16_p2.ebuild,v 1.5 2007/11/10 22:52:51 nixphoeni Exp $
inherit eutils
DESCRIPTION="EAGLE Layout Editor"
HOMEPAGE="http://www.cadsoft.de"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 x86"
IUSE="linguas_de doc"
LICENSE="cadsoft"
RESTRICT="strip"
@@ -44,7 +44,7 @@ case "${LINGUAS}" in
esac
MANFILE=${MANDOC}-${MY_LANG}-${MANVER}.pdf
MY_P=${PN}-lin-${MY_LANG}-${MY_PV}
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_unpack() {
@@ -62,7 +62,7 @@ src_install() {
# Install the documentation
dodoc README doc/*
- use doc && cp ${MANFILE} ${D}/usr/share/doc/${PF}
+ use doc && cp ${MANFILE} "${D}"/usr/share/doc/${PF}
doman man/eagle.1
# Remove docs left in INSTALLDIR
rm -rf "${D}"/${INSTALLDIR}/{README,install,${MANFILE}} "${D}"/${INSTALLDIR}/doc "${D}"/${INSTALLDIR}/man
@@ -78,7 +78,8 @@ src_install() {
pkg_postinst() {
- elog "Run \`env-update && source /etc/profile\` now to set up the correct paths."
+ elog "Run \`env-update && source /etc/profile\` from within \${ROOT}"
+ elog "now to set up the correct paths."
elog "You must first run eagle as root to invoke product registration."
}
diff --git a/sci-electronics/eagle/files/digest-eagle-4.16_p2-r1 b/sci-electronics/eagle/files/digest-eagle-4.16_p2-r1
new file mode 100644
index 000000000000..2661398bb634
--- /dev/null
+++ b/sci-electronics/eagle/files/digest-eagle-4.16_p2-r1
@@ -0,0 +1,12 @@
+MD5 1e85f214b4229023ec22167ee8c6b485 cadsoft_eagle_manual-eng-2006.12.13.pdf 1875608
+RMD160 a5a8cf52cb3c027dcf9e38638813db9fc5728be7 cadsoft_eagle_manual-eng-2006.12.13.pdf 1875608
+SHA256 805fbef15bd4584f6a976d8a2cc672f00ce3ad32d018ce53b7c9ce80b9965733 cadsoft_eagle_manual-eng-2006.12.13.pdf 1875608
+MD5 bc5a380e943e741b4b85f6c9e8b23ddc cadsoft_eagle_manual-ger-2006.12.13.pdf 3178176
+RMD160 79e021301507e12fefec3d227f0e3a495f12b42b cadsoft_eagle_manual-ger-2006.12.13.pdf 3178176
+SHA256 1b2bba3af2bfa14194a17aa0218101f934204e54b207c0617b7d86a522ea55cd cadsoft_eagle_manual-ger-2006.12.13.pdf 3178176
+MD5 9648bed26f901ea634a69d18b9c33dce eagle-lin-eng-4.16r2.tgz 8922532
+RMD160 32449bbed7df918e7825cd91f1c559cc0d8966f9 eagle-lin-eng-4.16r2.tgz 8922532
+SHA256 dc71102780621022c5f3b124bbcde075f23d3e04d624a2985afa733fbae8c7e4 eagle-lin-eng-4.16r2.tgz 8922532
+MD5 e4605f15dde129a2b1a5d65d87d832b2 eagle-lin-ger-4.16r2.tgz 9018957
+RMD160 e6d978c131c5af767f2c6bcee52907460de121d7 eagle-lin-ger-4.16r2.tgz 9018957
+SHA256 6c570e41668da23e1f473da3bfd879cbeb76bea02d35ae13970db48b3aa36259 eagle-lin-ger-4.16r2.tgz 9018957
diff --git a/sci-electronics/eagle/files/eagle_wrapper_script b/sci-electronics/eagle/files/eagle_wrapper_script
new file mode 100644
index 000000000000..a670e99c372f
--- /dev/null
+++ b/sci-electronics/eagle/files/eagle_wrapper_script
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+# From http://www.cadsoft.de/faq.htm#17040701
+# Work around problems with the Composite X extension
+export XLIB_SKIP_ARGB_VISUALS=1
+
+# The ebuild will append the final line respecting INSTALLDIR
+# Default is /opt/eagle/bin/eagle