summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-09-20 02:20:37 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-09-20 02:20:37 +0000
commitda0504635d39996d38bce88fef93c6bf07d5db2f (patch)
treead1c82470d12de7eb923d6bb40a43e1f368ce762 /sci-chemistry
parentfix mips multilib cross-compile (diff)
downloadgentoo-2-da0504635d39996d38bce88fef93c6bf07d5db2f.tar.gz
gentoo-2-da0504635d39996d38bce88fef93c6bf07d5db2f.tar.bz2
gentoo-2-da0504635d39996d38bce88fef93c6bf07d5db2f.zip
Initial import (fixes bug #105901).
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/gamess/ChangeLog15
-rw-r--r--sci-chemistry/gamess/Manifest9
-rw-r--r--sci-chemistry/gamess/files/comp-gentoo.patch40
-rw-r--r--sci-chemistry/gamess/files/compall-gentoo.patch15
-rw-r--r--sci-chemistry/gamess/files/compddi-gentoo.patch28
-rw-r--r--sci-chemistry/gamess/files/ddi-use-ssh-gentoo.patch13
-rw-r--r--sci-chemistry/gamess/files/digest-gamess-052720051
-rw-r--r--sci-chemistry/gamess/files/lked-gentoo.patch26
-rw-r--r--sci-chemistry/gamess/files/runall-gentoo.patch22
-rw-r--r--sci-chemistry/gamess/files/rungms-gentoo.patch49
-rw-r--r--sci-chemistry/gamess/gamess-05272005.ebuild223
-rw-r--r--sci-chemistry/gamess/metadata.xml9
12 files changed, 450 insertions, 0 deletions
diff --git a/sci-chemistry/gamess/ChangeLog b/sci-chemistry/gamess/ChangeLog
new file mode 100644
index 000000000000..05deab0f24e9
--- /dev/null
+++ b/sci-chemistry/gamess/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for sci-chemistry/gamess
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/ChangeLog,v 1.1 2005/09/20 02:20:37 ribosome Exp $
+
+*gamess-05272005 (20 Sep 2005)
+
+ 20 Sep 2005; Olivier Fisette <ribosome@gentoo.org>
+ +files/comp-gentoo.patch, +files/compall-gentoo.patch,
+ +files/compddi-gentoo.patch, +files/ddi-use-ssh-gentoo.patch,
+ +files/lked-gentoo.patch, +files/runall-gentoo.patch,
+ +files/rungms-gentoo.patch, +metadata.xml, +gamess-05272005.ebuild:
+ Initial import (fixes bug #105901). Package masked to allow for some
+ testing. Many thanks to Markus Dittrich <markusle@gmail.com> for his ebuild
+ and patches.
+
diff --git a/sci-chemistry/gamess/Manifest b/sci-chemistry/gamess/Manifest
new file mode 100644
index 000000000000..af797af9b495
--- /dev/null
+++ b/sci-chemistry/gamess/Manifest
@@ -0,0 +1,9 @@
+MD5 febcf13175d0964e4389224b18e4c56e gamess-05272005.ebuild 6629
+MD5 bfc4049f6e2546889b161c6c9b3be72f files/runall-gentoo.patch 688
+MD5 42ad79e7a475c0246839aa8137381e43 files/digest-gamess-05272005 67
+MD5 d2f6837d02ac960e7bed4addf9632eec files/lked-gentoo.patch 783
+MD5 e980cc327bd2de746b91a395f1af3e0f files/compddi-gentoo.patch 975
+MD5 cc629344d268783ea8be555bd06249af files/comp-gentoo.patch 1276
+MD5 88aa0ef3a19289c609a5167e2176bbf6 files/compall-gentoo.patch 445
+MD5 7635651c5b13ead41c16d56094238fcb files/ddi-use-ssh-gentoo.patch 518
+MD5 5fa801207d43042213344c896962c84d files/rungms-gentoo.patch 1754
diff --git a/sci-chemistry/gamess/files/comp-gentoo.patch b/sci-chemistry/gamess/files/comp-gentoo.patch
new file mode 100644
index 000000000000..5329bc3566e7
--- /dev/null
+++ b/sci-chemistry/gamess/files/comp-gentoo.patch
@@ -0,0 +1,40 @@
+# patch to enable linux-x86 arch in GAMESS comp script
+# includes a small fix that compiles module zheev using -O1
+# since anything more agressive might break things
+
+--- gamess-orig/comp 2005-07-23 20:30:18.000000000 +0000
++++ gamess/comp 2005-09-06 16:27:07.000000000 +0000
+@@ -14,8 +14,8 @@
+ # linux-ia64,linux-pc,mac32,macG5,necsx,sgi32,sgi64,sun32,sun64
+ # 2. Choose your GAMESS directory tree.
+ #
+-set TARGET=ibm64
+-chdir /u1/mike/gamess
++set TARGET=linux-pc
++#chdir /u1/mike/gamess
+ #
+ # ---- and now the script begins...
+ #
+@@ -992,11 +992,12 @@
+ # Pentium II fractionally). None of these optimizations are used below.
+ #
+ if ($TARGET == linux-pc) then
+- set OPT = '-O2'
++ set gentoo-OPT = '-O2'
+ if ($MODULE == ormas1) set OPT='-O2 -fno-move-all-movables' # RH9, g77 3.3
+ #
+ # g77 does not support FORTRAN logical units above 99, or 128 bit math.
+ #
++ if ($MODULE == zheev) set OPT='-O1'
+ if (($MODULE == qeigen) || ($MODULE == int2c)) then
+ mv $MODULE.f $MODULE.junk
+ sed -e "s/Q-/D-/g" \
+@@ -1010,7 +1011,7 @@
+ rm -f $MODULE.junk
+ endif
+ set echo
+- g77 -c $OPT -malign-double -fautomatic \
++ gentoo-g77 -c $OPT -malign-double -fautomatic \
+ -Wno-globals -fno-globals $MODULE.f
+ unset echo
+ endif
diff --git a/sci-chemistry/gamess/files/compall-gentoo.patch b/sci-chemistry/gamess/files/compall-gentoo.patch
new file mode 100644
index 000000000000..6ea5f77b7139
--- /dev/null
+++ b/sci-chemistry/gamess/files/compall-gentoo.patch
@@ -0,0 +1,15 @@
+# patch to enable linux-x86 arch in main GAMESS compile driver
+
+--- gamess/compall 2005-07-18 22:37:23.000000000 +0000
++++ gamess-gentoo/compall 2005-09-04 15:00:18.000000000 +0000
+@@ -12,8 +12,8 @@
+ # linux-ia64,linux-pc,mac32,macG5,necsx,sgi32,sgi64,sun32,sun64
+ # 2. Choose your GAMESS directory tree.
+ #
+-set TARGET=ibm64
+-chdir /u1/mike/gamess
++set TARGET=linux-pc
++#chdir /u1/mike/gamess
+ #
+ # ----- and now the script begins...
+ #
diff --git a/sci-chemistry/gamess/files/compddi-gentoo.patch b/sci-chemistry/gamess/files/compddi-gentoo.patch
new file mode 100644
index 000000000000..dcfd5d71a953
--- /dev/null
+++ b/sci-chemistry/gamess/files/compddi-gentoo.patch
@@ -0,0 +1,28 @@
+# patch to enable linux-x86 arch in GAMESS DDI socket compile
+# script
+
+--- gamess/ddi/compddi 2005-07-23 20:32:02.000000000 +0000
++++ gamess-gentoo/ddi/compddi 2005-09-05 12:20:02.000000000 +0000
+@@ -14,7 +14,7 @@
+ # fuji-pp32,fuji-pp64,hpux32,hpux64,ibm32,ibm64,ibm64-sp,ibm-bg,
+ # linux-ia64,linux-pc,mac32,macG5,necsx,sgi32,sgi64,sun32,sun64
+ #
+- set TARGET = ibm64
++ set TARGET = linux-pc
+
+ # 2. Choose DDI communication layer, the only legal values are
+ # sockets,mpi,shmem,lapi
+@@ -470,11 +470,11 @@
+ # select only one rather than two trailing underscores below.
+ if($TARGET == linux-pc) then
+
+- set CC = 'gcc'
++ set gentoo-CC = 'gcc'
+ set CFLAGS = "-DLINUX -O3 -fstrict-aliasing -I./include"
+ set CLIBS = "-lpthread"
+
+- set F77_OPTS = '-DINT_SIZE=int -D_UNDERSCORES=2'
++ set gentoo-F77_OPTS = '-DINT_SIZE=int -D_UNDERSCORES=2'
+
+ set AR_FLAGS = 'cr'
+ set RANLIB_FLAGS = ' '
diff --git a/sci-chemistry/gamess/files/ddi-use-ssh-gentoo.patch b/sci-chemistry/gamess/files/ddi-use-ssh-gentoo.patch
new file mode 100644
index 000000000000..61c7090886a0
--- /dev/null
+++ b/sci-chemistry/gamess/files/ddi-use-ssh-gentoo.patch
@@ -0,0 +1,13 @@
+# patch to use ssh rather than rsh for TCP/IP socket communication
+# in GAMESS' DDI_SOC interface
+--- gamess/ddi/tools/ddikick/ddikick.c 2004-05-03 16:23:13.000000000 +0000
++++ gamess-gentoo/ddi/tools/ddikick/ddikick.c 2005-09-04 15:56:50.000000000 +0000
+@@ -102,7 +102,7 @@
+ remoteshell = argv[++i];
+ } else {
+ if((remoteshell = getenv("DDI_RSH")) == NULL) {
+- remoteshell = (char *) strdup("rsh");
++ remoteshell = (char *) strdup("ssh");
+ }
+ }
+
diff --git a/sci-chemistry/gamess/files/digest-gamess-05272005 b/sci-chemistry/gamess/files/digest-gamess-05272005
new file mode 100644
index 000000000000..505c63894ac0
--- /dev/null
+++ b/sci-chemistry/gamess/files/digest-gamess-05272005
@@ -0,0 +1 @@
+MD5 3aa67e3db20051d372f6fc79c47c3abe gamess-current.tar.gz 5761028
diff --git a/sci-chemistry/gamess/files/lked-gentoo.patch b/sci-chemistry/gamess/files/lked-gentoo.patch
new file mode 100644
index 000000000000..defdcbfd4cf8
--- /dev/null
+++ b/sci-chemistry/gamess/files/lked-gentoo.patch
@@ -0,0 +1,26 @@
+# patch to enable linux-x86 arch in GAMESS linking script
+
+--- gamess/lked 2005-06-30 20:47:59.000000000 +0000
++++ gamess-gentoo/lked 2005-09-04 15:01:54.000000000 +0000
+@@ -14,8 +14,8 @@
+ # linux-ia64,linux-pc,mac32,macG5,necsx,sgi32,sgi64,sun32,sun64
+ # 2. Choose your GAMESS directory tree.
+ #
+-set TARGET=ibm64
+-chdir /u1/mike/gamess
++set TARGET=linux-pc
++#chdir /u1/mike/gamess
+ #
+ # ---- and now the script begins...
+ #
+@@ -321,8 +321,8 @@
+ # about matching the number of trailing underscores.
+ #
+ if ($TARGET == linux-pc) then
+- set LDR='g77'
+- set LDOPTS=' ' # add '-Wl,-M' to see load map
++ set gentoo-LDR='g77'
++ set gentoo-LDOPTS=' ' # add '-Wl,-M' to see load map
+ if (-e /usr/lib/libblas.a) then
+ set LIBRARIES='-lblas'
+ set BLAS=' '
diff --git a/sci-chemistry/gamess/files/runall-gentoo.patch b/sci-chemistry/gamess/files/runall-gentoo.patch
new file mode 100644
index 000000000000..8ad9535cd4bb
--- /dev/null
+++ b/sci-chemistry/gamess/files/runall-gentoo.patch
@@ -0,0 +1,22 @@
+# patch to adjust paths in runall script according to our GENTOO
+# install
+
+--- gamess/runall 2005-07-05 14:08:04.000000000 +0000
++++ gamess-gentoo/runall 2005-09-05 11:05:31.000000000 +0000
+@@ -10,7 +10,7 @@
+ # Edit this file to set the base path to GAMESS, and execute it to be
+ # sure all the jobs TERMINATED NORMALLY, and got correct numbers too.
+ #
+-chdir /u1/mike/gamess
++#chdir /u1/mike/gamess/
+ set VERNO=00
+ #
+ foreach NUM ( 01 02 03 04 05 06 07 08 09 10 11 12 13 14 15 \
+@@ -20,6 +20,6 @@
+ gms -v $VERNO -q ti -l exam$NUM.log exam$NUM
+ sleep 5
+ else
+- rungms exam$NUM $VERNO 1 >& exam$NUM.log
++ ./rungms exam$NUM $VERNO 1 >& exam$NUM.log
+ endif
+ end
diff --git a/sci-chemistry/gamess/files/rungms-gentoo.patch b/sci-chemistry/gamess/files/rungms-gentoo.patch
new file mode 100644
index 000000000000..8e6e9641145c
--- /dev/null
+++ b/sci-chemistry/gamess/files/rungms-gentoo.patch
@@ -0,0 +1,49 @@
+# patch to make rungms wrapper script for GAMESS work on our
+# gentoo install
+
+--- gamess/rungms 2005-07-23 20:33:54.000000000 +0000
++++ gamess-gentoo/rungms 2005-09-04 17:01:19.000000000 +0000
+@@ -39,7 +39,7 @@
+ # its own list of further requirements.
+ #
+ set TARGET=sockets
+-set SCR=/scr/$USER
++set SCR=./
+ #
+ set JOB=$1 # name of the input file xxx.inp, give only the xxx part
+ set VERNO=$2 # revision number of the executable created by 'lked' step
+@@ -90,11 +90,11 @@
+ # is therefore most suitable to be stored only once, on the file server.
+ #
+ set echo
+-setenv ERICFMT ~mike/gamess/ericfmt.dat
++setenv ERICFMT /usr/share/gamess/ericfmt/ericfmt.dat
+ setenv EXTBAS /dev/null
+-setenv IRCDATA ~/scr/$JOB.irc
++setenv IRCDATA $SCR/$JOB.irc
+ setenv INPUT $SCR/$JOB.F05
+-setenv PUNCH ~/scr/$JOB.dat
++setenv PUNCH $SCR/$JOB.dat
+ setenv AOINTS $SCR/$JOB.F08
+ setenv MOINTS $SCR/$JOB.F09
+ setenv DICTNRY $SCR/$JOB.F10
+@@ -124,8 +124,8 @@
+ setenv SOINTY $SCR/$JOB.F32
+ setenv SOINTZ $SCR/$JOB.F33
+ setenv SORESC $SCR/$JOB.F34
+-setenv SIMEN ~/scr/$JOB.simen
+-setenv SIMCOR ~/scr/$JOB.simcor
++setenv SIMEN $SCR/$JOB.simen
++setenv SIMCOR $SCR/$JOB.simcor
+ setenv GCILIST $SCR/$JOB.F37
+ setenv HESSIAN $SCR/$JOB.F38
+ setenv SOCCDAT $SCR/$JOB.F40
+@@ -266,7 +266,7 @@
+ if ($os == HP-UX) set GMSPATH=/zr/mike/gamess
+ if ($os == IRIX) set GMSPATH=/home/hbar4/people/schmidt/gamess
+ if ($os == IRIX64) set GMSPATH=/home/hbar4/people/schmidt/gamess
+- if ($os == Linux) set GMSPATH=/cu/mike/gamess
++ if ($os == Linux) set GMSPATH=/usr/bin
+ if ($os == OSF1) set GMSPATH=/au/mike/gamess
+ if ($os == SunOS) set GMSPATH=/hf/mike/gamess
+ # special compilation for my old Sun (uname also replies SunOS)
diff --git a/sci-chemistry/gamess/gamess-05272005.ebuild b/sci-chemistry/gamess/gamess-05272005.ebuild
new file mode 100644
index 000000000000..8ac890c4cee2
--- /dev/null
+++ b/sci-chemistry/gamess/gamess-05272005.ebuild
@@ -0,0 +1,223 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gamess/gamess-05272005.ebuild,v 1.1 2005/09/20 02:20:37 ribosome Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="A powerful quantum chemistry package"
+LICENSE="gamess"
+HOMEPAGE="http://www.msg.ameslab.gov/GAMESS/GAMESS.html"
+SRC_URI="${PN}-current.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ifc hardened blas"
+
+RESTRICT="fetch"
+
+DEPEND="app-shells/tcsh
+ ifc? ( >=dev-lang/ifc-8.1 )
+ hardened? ( sys-apps/paxctl )
+ blas? ( virtual/blas )"
+
+RDEPEND="app-shells/tcsh
+ net-misc/openssh
+ ifc? ( >=dev-lang/ifc-8.1 )"
+
+S="${WORKDIR}/${PN}"
+
+GAMESS_DOWNLOAD="http://www.msg.ameslab.gov/GAMESS/License_Agreement.html"
+
+pkg_nofetch() {
+ echo
+ einfo "Please download ${PN}-current.tar.gz from"
+ einfo "${GAMESS_DOWNLOAD}"
+ einfo "after agreeing to the license and then move it to "
+ einfo "${DISTDIR}"
+ einfo "Be sure to select the version 27 JUN 2005 tarball!!"
+ echo
+}
+
+pkg_setup() {
+ # make sure we have the proper fortan compiler;
+ # use ifc for USE="ifc" and g77 otherwise
+ if use ifc; then
+ need_fortran ifc
+ else
+ need_fortran g77
+ fi
+
+ # blas and ifc don't go together
+ if use blas && use ifc; then
+ die "${PN} can not be compiled with USE=blas and USE=ifc"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # apply LINUX-arch patches to gamess makesfiles
+ epatch "${FILESDIR}"/comp-gentoo.patch
+ epatch "${FILESDIR}"/compall-gentoo.patch
+ epatch "${FILESDIR}"/lked-gentoo.patch
+ epatch "${FILESDIR}"/ddi-use-ssh-gentoo.patch
+ epatch "${FILESDIR}"/compddi-gentoo.patch
+ epatch "${FILESDIR}"/rungms-gentoo.patch
+ epatch "${FILESDIR}"/runall-gentoo.patch
+
+ # for hardened-gcc let't turn off ssp, since it breakes
+ # a few routines
+ cd "${S}"
+ if use hardened && [[ $(tc-getF77) = f77 ]]; then
+ FFLAGS="${FFLAGS} -fno-stack-protector-all"
+ fi
+
+ # greate proper activate sourcefile
+ cp "./tools/actvte.code" "./tools/actvte.f" || \
+ die || "Failed to create actvte.f"
+ sed -e "s/^\*UNX/ /" -i "./tools/actvte.f" || \
+ die || "Failed to perform UNX substitutions in actvte.f"
+
+ # fix GAMESS' compall script to use proper CC
+ sed -e "s|\$CCOMP -c \$extraflags source/zunix.c|$(tc-getCC) -c \$extraflags source/zunix.c|" \
+ -i compall || die "Failed setting up compall script"
+
+ # insert proper FFLAGS into GAMESS' comp makefile
+ # in case we're using ifc let's strip all the gcc
+ # specific stuff
+ if use ifc; then
+ sed -e "s/-malign-double -fautomatic /-cm -w \$MODULE.f/" \
+ -e "s/-Wno-globals -fno-globals \$MODULE.f//" \
+ -e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS} -quiet'/" \
+ -e "s/gentoo-g77/$(tc-getF77)/" \
+ -i comp || die "Failed setting up comp script"
+ else
+ sed -e "s/gentoo-OPT = '-O2'/OPT = '${FFLAGS}'/" \
+ -e "s/gentoo-g77/$(tc-getF77)/" \
+ -i comp || die "Failed setting up comp script"
+ fi
+
+ # use proper blas
+ if ! use blas; then
+ sed -e "s|/usr/lib/libblas.a|/usr/lib/dontuselibblas.a|" \
+ -i lked || die "Failed to adjust blas in lked"
+ fi
+
+ # fix up GAMESS' linker script;
+ if use ifc; then
+ sed -e "s/gentoo-LDR='g77'/LDR='$(tc-getF77)'/" \
+ -e "s/gentoo-LDOPTS=' '/LDOPTS='${LDFLAGS}'/" \
+ -i lked || die "Failed setting up lked script"
+ else
+ sed -e "s/gentoo-LDR='g77'/LDR='$(tc-getF77)'/" \
+ -e "s/gentoo-LDOPTS=' '/LDOPTS='${LDFLAGS}'/" \
+ -i lked || die "Failed patching lked script"
+ fi
+
+ # fix up GAMESS' ddi TCP/IP socket build
+ sed -e "s/gentoo-CC = 'gcc'/CC = '$(tc-getCC)'/" \
+ -i ddi/compddi || die "Failed setting up compddi script"
+
+ # for ifc we have to fix the number of underscores of fortran
+ # symbols, otherwise the linker will barf
+ if use ifc; then
+ sed -e "s/gentoo-F77_OPTS = '-DINT_SIZE=int -D_UNDERSCORES=2/F77_OPTS = '-DINT_SIZE=int -D_UNDERSCORES=1/" \
+ -i ddi/compddi || die "Failed fixing underscores in compddi"
+ else
+ sed -e "s/gentoo-F77_OPTS/F77_OPTS/" \
+ -i ddi/compddi || die "Failed fixing underscores in compddi"
+ fi
+}
+
+src_compile() {
+ # build actvte
+ cd "${S}"/tools
+ $(tc-getF77) -o actvte.x actvte.f || die "Failed to compile actvte.x"
+
+ # for hardened (PAX) users and ifc we need to turn
+ # MPROTECT off
+ if use ifc && use hardened; then
+ /sbin/paxctl -PemRxS actvte.x 2> /dev/null || \
+ die "paxctl failed on actvte.x"
+ fi
+
+ # build gamess
+ cd "${S}"
+ ./compall || die "compall failed"
+
+ # build the ddi TCP/IP socket stuff
+ cd ${S}/"ddi"
+ ./compddi || die "compddi failed"
+
+ # finally, link it all together
+ cd "${S}"
+ ./lked || die "lked failed"
+
+ # for hardened (PAX) users and ifc we need to turn
+ # MPROTECT off
+ if use ifc && use hardened; then
+ /sbin/paxctl -PemRxS ${PN}.00.x 2> /dev/null || \
+ die "paxctl failed on actvte.x"
+ fi
+}
+
+src_install() {
+ cd "${S}"
+
+ # the executables
+ dobin ${PN}.00.x || die "Failed installing gamess executable"
+ dobin ddi/ddikick.x || die "Failed installing ddikick.x"
+
+ # the docs
+ dodoc *.DOC || die "Failed installing docs"
+
+ # install ericftm
+ insinto /usr/share/${PN}/ericfmt
+ doins ericfmt.dat || die "Failed installing ericfmt.dat"
+
+ # install rungms, also supply a copy for the test
+ # files
+ insinto /usr/share/${PN}/rungms
+ insopts -m0744
+ doins rungms || die "Failed installing rungms"
+
+ # install the tests the user should run, and
+ # fix up the runscript; also grab a copy of rungms
+ # so the user is ready to run the tests
+ insinto /usr/share/${PN}/tests
+ insopts -m0644
+ doins tests/* || die "Failed installing tests"
+ insopts -m0744
+ doins runall rungms || die "Failed installing tests"
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Before you use GAMESS for any serious work you HAVE"
+ ewarn "to run the supplied test files located in"
+ ewarn "/usr/share/gamess/tests and check them thoroughly."
+ ewarn "Otherwise all scientific publications resulting from"
+ ewarn "your GAMESS runs should be immediately rejected :)"
+ ewarn "To do so copy the content of /usr/share/gamess/tests"
+ ewarn "to some temporary location and execute './runall'. "
+ ewarn "Please consult TEST.DOC and the other docs!"
+
+ if use ifc; then
+ echo
+ ewarn "IMPORTANT NOTE: We STRONGLY recommend to stay away"
+ ewarn "from ifc-9.0 for now and use the ifc-8.1 series of"
+ ewarn "compilers UNLESS you can run through ALL of the "
+ ewarn "test cases (see above) successfully."
+ fi
+
+ echo
+ einfo "To perform a GAMESS run copy the the rungms script from"
+ einfo "/usr/share/gamess/rungms into your local directory"
+ einfo "and type ./rungms <myinputfile> >& <myoutputfile> "
+ einfo
+ einfo "If you want to run on more than a single CPU"
+ einfo "you will have to acquaint yourself with the way GAMESS"
+ einfo "does multiprocessor runs and adjust rungms according to"
+ einfo "your target network architecture."
+ echo
+}
diff --git a/sci-chemistry/gamess/metadata.xml b/sci-chemistry/gamess/metadata.xml
new file mode 100644
index 000000000000..e9391a41a838
--- /dev/null
+++ b/sci-chemistry/gamess/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ribosome@gentoo.org</email>
+ <name>Olivier Fisette</name>
+ </maintainer>
+ <herd>sci</herd>
+</pkgmetadata>