summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:21:12 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-13 22:21:12 +0000
commita5ef0a5a821cd863ec29a8e0eba2a0f228078237 (patch)
tree87aa870cf33df1abe134e7b711872e345febe5ff /sci-chemistry
parentFix ghemical mask to only apply to development versions. (diff)
downloadgentoo-2-a5ef0a5a821cd863ec29a8e0eba2a0f228078237.tar.gz
gentoo-2-a5ef0a5a821cd863ec29a8e0eba2a0f228078237.tar.bz2
gentoo-2-a5ef0a5a821cd863ec29a8e0eba2a0f228078237.zip
Always build shared libraries, so other programs can link against them without mixing PIC and non-PIC code. That breaks architectures including ppc, ppc64, amd64. Do some general ebuild cleanup, and add an RDEPEND so not all the build-time tools are required at runtime.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mpqc/ChangeLog11
-rw-r--r--sci-chemistry/mpqc/files/digest-mpqc-2.3.1-r13
-rw-r--r--sci-chemistry/mpqc/mpqc-2.3.1-r1.ebuild102
3 files changed, 115 insertions, 1 deletions
diff --git a/sci-chemistry/mpqc/ChangeLog b/sci-chemistry/mpqc/ChangeLog
index b8facb8814e5..96251aa2a67f 100644
--- a/sci-chemistry/mpqc/ChangeLog
+++ b/sci-chemistry/mpqc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-chemistry/mpqc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/ChangeLog,v 1.10 2006/04/11 16:43:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/ChangeLog,v 1.11 2006/05/13 22:21:12 spyderous Exp $
+
+*mpqc-2.3.1-r1 (13 May 2006)
+
+ 13 May 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +mpqc-2.3.1-r1.ebuild:
+ Always build shared libraries, so other programs can link against them
+ without mixing PIC and non-PIC code. That breaks architectures including
+ ppc, ppc64, amd64. Do some general ebuild cleanup, and add an RDEPEND so not
+ all the build-time tools are required at runtime.
*mpqc-2.3.1 (11 Apr 2006)
diff --git a/sci-chemistry/mpqc/files/digest-mpqc-2.3.1-r1 b/sci-chemistry/mpqc/files/digest-mpqc-2.3.1-r1
new file mode 100644
index 000000000000..976f0297cdc7
--- /dev/null
+++ b/sci-chemistry/mpqc/files/digest-mpqc-2.3.1-r1
@@ -0,0 +1,3 @@
+MD5 2f9b4f7487387730d78066a53764f848 mpqc-2.3.1.tar.bz2 2521392
+RMD160 0e3b395e9ed663b9c3de120fb4f5a00bc40c7e0f mpqc-2.3.1.tar.bz2 2521392
+SHA256 18f162ca9cb8b3b05372b0ec3d02b4b8a4a7aabfc7b2abead350ddef8f048ecc mpqc-2.3.1.tar.bz2 2521392
diff --git a/sci-chemistry/mpqc/mpqc-2.3.1-r1.ebuild b/sci-chemistry/mpqc/mpqc-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..f6e9d5c83322
--- /dev/null
+++ b/sci-chemistry/mpqc/mpqc-2.3.1-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mpqc/mpqc-2.3.1-r1.ebuild,v 1.1 2006/05/13 22:21:12 spyderous Exp $
+
+inherit fortran
+
+DESCRIPTION="The Massively Parallel Quantum Chemistry Program"
+HOMEPAGE="http://www.mpqc.org/"
+SRC_URI="mirror://sourceforge/mpqc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Should work on x86, amd64 and ppc, at least
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc threads tcltk"
+
+RDEPEND="virtual/blas
+ virtual/lapack
+ tcltk? ( dev-lang/tk )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ dev-lang/perl
+ >=sys-apps/sed-4
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # do not install tkmolrender if not requested
+ if ! use tcltk; then
+ sed -e "s:.*/bin/molrender/tkmolrender.*::" \
+ -e "s:.*\$(INSTALLBINOPT) tkmolrender.*::" \
+ -e "s:/bin/rm -f tkmolrender::" \
+ -i "./src/bin/molrender/Makefile" \
+ || die "failed to disable tkmolrender"
+ fi
+}
+
+
+src_compile() {
+# CFLAGS_SAVE=${CFLAGS}; CXXFLAGS_SAVE=${CXXFLAGS}
+
+ # Only shared will work on ppc64 - bug #62124
+ # But we always want shared libraries
+ econf \
+ $(use_enable threads) \
+ --enable-shared \
+ ${myconf} || die "configure failed"
+
+ sed -i -e "s:^CFLAGS =.*$:CFLAGS=${CFLAGS}:" \
+ -e "s:^FFLAGS =.*$:FFLAGS=${FFLAGS:- -O2}:" \
+ -e "s:^CXXFLAGS =.*$:CXXFLAGS=${CXXFLAGS}:" \
+ lib/LocalMakefile
+ emake || die "emake failed"
+}
+
+
+src_test() {
+ cd "${S}"/src/bin/mpqc/validate
+
+ # we'll only run the small test set, since the
+ # medium and large ones take >10h and >24h on my
+ # 1.8Ghz P4M
+ make check0 || die "failed in test routines"
+}
+
+
+
+src_install() {
+ make installroot="${D}" install install_devel install_inc \
+ || die "install failed"
+
+ dodoc CHANGES CITATION README || die "failed to install docs"
+
+ # make extended docs
+ if use doc; then
+ cd "${S}"/doc
+ make all || die "failed to generate documentation"
+ doman man/man1/* && doman man/man3/* || \
+ die "failed to install man pages"
+ dohtml -r html/
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "MPQC can be picky with regard to compilation flags."
+ einfo "If during mpqc runs you have trouble converging or "
+ einfo "experience oscillations during SCF interations, "
+ einfo "consider recompiling with less aggressive CFLAGS/CXXFLAGS."
+ einfo "Particularly, replacing -march=pentium4 by -march=pentium3"
+ einfo "might help if you encounter problems with correlation "
+ einfo "consistent basis sets."
+ echo
+}
+
+
+
+
+