summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-05-17 20:15:13 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-05-17 20:15:13 +0000
commita44a2c4524e5539789e6f9d301b0f05146163f1c (patch)
tree8ebc528239f2687c5e9d417a34d50cf4c7d25e69 /sci-chemistry
parentBump to 2.6.2. Bug fixes and translation updates. (diff)
downloadgentoo-2-a44a2c4524e5539789e6f9d301b0f05146163f1c.tar.gz
gentoo-2-a44a2c4524e5539789e6f9d301b0f05146163f1c.tar.bz2
gentoo-2-a44a2c4524e5539789e6f9d301b0f05146163f1c.zip
Fixed by alexxy for tcl8.5
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/vmd/ChangeLog12
-rw-r--r--sci-chemistry/vmd/vmd-1.8.6-r1.ebuild161
-rw-r--r--sci-chemistry/vmd/vmd-1.8.6.ebuild6
3 files changed, 175 insertions, 4 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index e45f8bfe26f9..3e5a97dad5d2 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/vmd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.19 2008/11/12 18:41:47 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.20 2009/05/17 20:15:13 je_fro Exp $
+
+ 17 May 2009; Jeff Gardner <je_fro@gentoo.org> +vmd-1.8.6-r1.ebuild:
+ Fixed by alexxy to work with tcl8.5
+
+*vmd-1.8.6-r1 (17 May 2009)
+
+ 17 May 2009; Jeff Gardner <je_fro@gentoo.org> +vmd-1.8.6-r1.ebuild:
+ Fixed by alexxy to work with tcl5.8
12 Nov 2008; Markus Dittrich <markusle@gentoo.org> -vmd-1.8.5.ebuild,
vmd-1.8.6.ebuild:
diff --git a/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild b/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild
new file mode 100644
index 000000000000..276830b62098
--- /dev/null
+++ b/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild,v 1.1 2009/05/17 20:15:13 je_fro Exp $
+
+EAPI="1"
+
+inherit eutils toolchain-funcs python
+
+DESCRIPTION="Visual Molecular Dynamics"
+LICENSE="vmd"
+HOMEPAGE="http://www.ks.uiuc.edu/Research/vmd/"
+SRC_URI="${P}.src.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+DEPEND="app-shells/tcsh
+ x11-libs/libXft
+ virtual/opengl
+ x11-libs/fltk:1.1
+ >=dev-lang/tcl-8.4
+ >=dev-lang/tk-8.4
+ >=dev-lang/python-2.3
+ sci-biology/stride
+ sci-libs/netcdf"
+
+RDEPEND="${DEPEND}"
+
+VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD"
+
+pkg_nofetch() {
+ echo
+ einfo "Please download ${SRC_URI} from"
+ einfo "${VMD_DOWNLOAD}"
+ einfo "after agreeing to the license and then move it to "
+ einfo "${DISTDIR}"
+ echo
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # apply LINUX-arch patches to vmd configure
+ epatch "${FILESDIR}/${P}-config-gentoo.patch"
+ epatch "${FILESDIR}/${P}-python-2.5.patch"
+
+ TCL_LIB_PATH="/usr/$(get_libdir)/tcl8.4"
+ if has_version =dev-lang/tcl-8.5*; then
+ epatch "${FILESDIR}/${P}-tcltk8.5.patch"
+ epatch "${FILESDIR}/${P}-fix-crash-on-tcl8.5.patch"
+ TCL_LIB_PATH="/usr/$(get_libdir)/tcl8.5"
+ fi
+
+ # prepare the plugins
+
+ cd "${WORKDIR}"/plugins
+
+ sed -e "s:CC = gcc:CC = $(tc-getCC):" \
+ -e "s:CXX = g++:CXX = $(tc-getCXX):" \
+ -e "s:COPTO = -o :COPTO = -fPIC -o :" \
+ -e "s:LOPTO = -o :LOPTO = -fPIC -o :" \
+ -e "s:CCFLAGS = -O2 -Wall:CCFLAGS = ${CFLAGS}:" \
+ -e "s:CXXFLAGS = -O2 -Wall:CXXFLAGS = ${CXXFLAGS}:" \
+ -e "s:SHLD = gcc:SHLD = $(tc-getCC):" \
+ -e "s:-ltcl8.4:-ltcl:" \
+ -i Make-arch || die "Failed to set up plugins Makefile"
+
+ sed -e "s:1.0:1.2:" -i vdna/pkgIndex.tcl \
+ || die "Failed to fix vdna plugin"
+
+ # prepare vmd itself
+
+ cd "${S}"
+
+ sed -e "s:gentoo-bindir:${D}/usr/bin:" \
+ -e "s:gentoo-libdir:${D}/usr/$(get_libdir):" \
+ -i configure || die "failed to adjust install paths"
+
+ sed -e "s:gentoo-gcc:$(tc-getCC):" \
+ -e "s:gentoo-g++:$(tc-getCXX):" \
+ -e "s:gentoo-cflags:${CFLAGS}:" \
+ -i configure || die "Failed to adjust C compiler/flags"
+
+ sed -e "s:gentoo-plugindir:${WORKDIR}/plugins:" \
+ -i configure || die "Failed to set up linking to plugin files"
+
+ sed -e "s:gentoo-fltk-include:/usr/include/fltk-1.1:" \
+ -e "s:gentoo-fltk-libs:/usr/$(get_libdir)/fltk-1.1:" \
+ -i configure || die "failed setting up fltk"
+
+ sed -e "s:gentoo-netcdf-include:/usr/include:" \
+ -e "s:gentoo-netcdf-libs:/usr/$(get_libdir):" \
+ -i configure || die "failed to set up netcdf"
+
+ # get installed python version
+ python_version
+ local PY="python${PYVER}"
+
+ sed -e "s:gentoo-python-include:/usr/include/${PY}:" \
+ -e "s:gentoo-python-lib:/usr/$(get_libdir)/${PY}:" \
+ -e "s:gentoo-python-link:${PY}:" \
+ -i configure || die "failed setting up python"
+
+ sed -e "s:LINUXPPC:LINUX:g" \
+ -e "s:LINUXALPHA:LINUX:g" \
+ -e "s:LINUXAMD64:LINUX:g" \
+ -i "${S}"/bin/vmd || die "failed setting up vmd wrapper script"
+
+ local myconfig="LINUX OPENGL FLTK TK TCL PTHREADS PYTHON IMD NETCDF"
+
+ rm -f configure.options && echo $myconfig >> configure.options
+
+ ./configure &> /dev/null || die "failed to configure"
+}
+
+src_compile() {
+ # build plugins
+ cd "${WORKDIR}"/plugins
+
+ make LINUX TCLINC="-I/usr/include" \
+ TCLLIB=-L/"${TCL_LIB_PATH}" \
+ || die "failed to build plugins"
+
+ # build vmd
+ cd "${S}"/src
+ emake || die "failed to build vmd"
+}
+
+src_install() {
+ # install plugins
+ cd "${WORKDIR}"/plugins
+ PLUGINDIR=${D}/usr/$(get_libdir)/${PN}/plugins make distrib || \
+ die "failed to install plugins"
+
+ # install vmd
+ cd "${S}"/src
+ make install || die "failed to install vmd"
+
+ # export STRIDE_BIN so VMD knows where to find stride
+ echo "STRIDE_BIN=/usr/bin/stride" > "${T}"/99${PN} || \
+ die "Failed to create vmd env file"
+ doenvd "${T}"/99${PN} || die "Failed to install vmd env file"
+
+ # install docs
+ cd "${S}"
+ dodoc Announcement README doc/ig.pdf doc/ug.pdf
+
+ # remove some of the things we don't want and need in
+ # /usr/lib
+ cd "${D}"/usr/$(get_libdir)/vmd
+ rm -fr doc README Announcement LICENSE || \
+ die "failed to clean up /usr/lib/vmd directory"
+
+ # adjust path in vmd wrapper
+ sed -e "s:${D}::" -i "${D}"/usr/bin/${PN} \
+ || die "failed to set up vmd wrapper script"
+}
diff --git a/sci-chemistry/vmd/vmd-1.8.6.ebuild b/sci-chemistry/vmd/vmd-1.8.6.ebuild
index bc7ae929fd91..90680f8822da 100644
--- a/sci-chemistry/vmd/vmd-1.8.6.ebuild
+++ b/sci-chemistry/vmd/vmd-1.8.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6.ebuild,v 1.7 2008/11/12 18:41:47 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6.ebuild,v 1.8 2009/05/17 20:15:13 je_fro Exp $
EAPI="1"
@@ -27,6 +27,8 @@ DEPEND="app-shells/tcsh
sci-biology/stride
sci-libs/netcdf"
+RDEPEND="${DEPEND}"
+
VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageName=VMD"
pkg_nofetch() {