summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-01-04 19:17:35 +0000
committerJustin Lecher <jlec@gentoo.org>2015-01-04 19:17:35 +0000
commit2b9cd4b120ba49cccb3d24038e0538e097107707 (patch)
treedd93bf86218ab1027a958e86ff255fbc6071a7b9 /sci-chemistry
parentsci-chemistry/pdb2pqr: Drop obsolete dep (diff)
downloadgentoo-2-2b9cd4b120ba49cccb3d24038e0538e097107707.tar.gz
gentoo-2-2b9cd4b120ba49cccb3d24038e0538e097107707.tar.bz2
gentoo-2-2b9cd4b120ba49cccb3d24038e0538e097107707.zip
sci-chemistry/pdb2pqr: Drop old
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pdb2pqr/ChangeLog6
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild165
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild159
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.8.0-r1.ebuild114
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild109
5 files changed, 5 insertions, 548 deletions
diff --git a/sci-chemistry/pdb2pqr/ChangeLog b/sci-chemistry/pdb2pqr/ChangeLog
index 820a17b96385..e2208e020cac 100644
--- a/sci-chemistry/pdb2pqr/ChangeLog
+++ b/sci-chemistry/pdb2pqr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/pdb2pqr
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.46 2015/01/04 19:15:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/ChangeLog,v 1.47 2015/01/04 19:17:35 jlec Exp $
+
+ 04 Jan 2015; Justin Lecher <jlec@gentoo.org> -pdb2pqr-1.7.0.ebuild,
+ -pdb2pqr-1.7.0-r2.ebuild, -pdb2pqr-1.8.0-r1.ebuild, -pdb2pqr-1.9.0.ebuild:
+ Drop old
04 Jan 2015; Justin Lecher <jlec@gentoo.org> pdb2pqr-1.9.0-r1.ebuild:
Drop obsolete dep
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild
deleted file mode 100644
index ac9f5cf46b9c..000000000000
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0-r2.ebuild,v 1.2 2012/10/19 10:10:18 jlec Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* 2.7-pypy-*"
-
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
-
-MY_PV=$(get_version_component_range 1-2)
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
-LICENSE="BSD"
-HOMEPAGE="http://pdb2pqr.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-IUSE="doc examples opal +pdb2pka"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/numpy
- sci-chemistry/openbabel
- opal? ( dev-python/zsi )
- pdb2pka? ( sci-chemistry/apbs[python,-mpi] )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if [[ -z ${MAXATOMS} ]]; then
- einfo "If you like to have support for more then 10000 atoms,"
- einfo "export MAXATOMS=\"your value\""
- else
- einfo "Allow usage of ${MAXATOMS} during calculations"
- fi
- python_pkg_setup
- fortran-2_pkg_setup
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.4.0-ldflags.patch \
- "${FILESDIR}"/${PN}-1.4.0-automagic.patch \
- "${FILESDIR}"/${PV}-install.patch
- sed \
- -e '50,200s:CWD:DESTDIR:g' \
- -i Makefile.am || die
-
- python_src_prepare
-
- preparation() {
- sed \
- -e "s:python\$PY_VERSION:$(PYTHON):g" \
- -i configure.ac || die
-
- eautoreconf
- }
- python_execute_function -s preparation
-
- tc-export CC
-}
-
-src_configure() {
- # we need to compile the *.so as pic
- append-flags -fPIC
- FFLAGS="${FFLAGS} -fPIC"
-
- configuration() {
- # Avoid automagic to numeric
- econf \
- --enable-propka \
- --with-max-atoms=${MAXATOMS:-10000} \
- $(use_enable pdb2pka) \
- $(use_with opal) \
- NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="$(tc-getFC)"
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_test() {
- testing() {
- emake -j1 test
- }
- python_execute_function -s testing
-}
-
-src_install() {
- installation() {
- dodir $(python_get_sitedir)/${PN}
- emake -j1 DESTDIR="${ED}$(python_get_sitedir)/${PN}" \
- PREFIX="" install
-
- INPATH="$(python_get_sitedir)/${PN}"
-
- # generate pdb2pqr wrapper
- cat >> "${T}"/${PN}-$(python_get_version) <<-EOF
- #!/bin/sh
- $(PYTHON) ${EPREFIX}${INPATH}/${PN}.py \$*
- EOF
-
- cat >> "${T}"/pdb2pka-$(python_get_version) <<-EOF
- #!/bin/sh
- $(PYTHON) ${EPREFIX}${INPATH}/pdb2pka/pka.py \$*
- EOF
-
- dobin "${T}"/{${PN},pdb2pka}-$(python_get_version)
-
- insinto "${INPATH}" && doins __init__.py
-
- exeinto "${INPATH}" && doexe ${PN}.py
-
- insinto "${INPATH}"/dat && doins dat/*
-
- exeinto "${INPATH}"/extensions && doexe extensions/*
-
- insinto "${INPATH}"/src && doins src/*.py
-
- exeinto "${INPATH}"/propka && doexe propka/_propkalib.so
-
- insinto "${INPATH}"/propka && doins propka/propkalib.py propka/__init__.py
-
- insinto "${INPATH}"/pdb2pka && doins pdb2pka/*.{py,so,DAT,h}
-
- dosym ../../apbs/_apbs.so "${INPATH}"/pdb2pka/_apbslib.so
- dosym ../../apbs/apbslib.py "${INPATH}"/pdb2pka/apbslib.py
- dosym ../../apbs/apbslib.pyc "${INPATH}"/pdb2pka/apbslib.pyc
- dosym ../../apbs/apbslib.pyo "${INPATH}"/pdb2pka/apbslib.pyo
- }
- python_execute_function -s installation
-
- dosym ${PN}-$(python_get_version -f) /usr/bin/${PN}
- dosym pdb2pka-$(python_get_version -f) /usr/bin/pdb2pka
-
- if use doc; then
- pushd doc > /dev/null
- sh genpydoc.sh || die "genpydoc failed"
- dohtml -r *.html images pydoc
- popd > /dev/null
- fi
-
- use examples && \
- insinto /usr/share/${PN}/ && \
- doins -r examples
-
- dodoc ChangeLog NEWS README AUTHORS
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
deleted file mode 100644
index 180ca27d19d3..000000000000
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.9 2012/10/19 10:10:18 jlec Exp $
-
-EAPI="3"
-
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
-
-MY_PV=$(get_version_component_range 1-2)
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
-LICENSE="BSD"
-HOMEPAGE="http://pdb2pqr.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-IUSE="doc examples opal"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/numpy
- sci-chemistry/openbabel
- opal? ( dev-python/zsi )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- fortran-2_pkg_setup
- python_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.4.0-ldflags.patch
- epatch "${FILESDIR}"/${PN}-1.4.0-automagic.patch
- epatch "${FILESDIR}"/${PV}-install.patch
- sed '50,200s:CWD:DESTDIR:g' -i Makefile.am \
- || die "Failed to fix Makefile.am"
- python_src_prepare
- preparation() {
- eautoreconf
- }
- python_execute_function -s preparation
-}
-
-src_configure() {
- # we need to compile the *.so as pic
- append-flags -fPIC
- FFLAGS="${FFLAGS} -fPIC"
-
- configuration() {
- # Avoid automagic to numeric
- NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="$(tc-getFC)" \
- econf \
- $(use_with opal)
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- compilation() {
- emake || die
- }
- python_execute_function -s compilation
-}
-
-src_test() {
- testing() {
- emake -j1 test \
- || die "tests failed"
- }
- python_execute_function -s testing
-}
-
-src_install() {
- installation() {
- dodir $(python_get_sitedir)/${PN}
- emake -j1 DESTDIR="${ED}$(python_get_sitedir)/${PN}" \
- PREFIX="" install || die "install failed"
-
- INPATH="$(python_get_sitedir)/${PN}"
-
- # generate pdb2pqr wrapper
- cat >> "${T}"/${PN}-$(python_get_version) <<-EOF
- #!/bin/sh
- $(PYTHON) ${EPREFIX}/${INPATH}/${PN}.py \$*
- EOF
-
- dobin "${T}"/${PN}-$(python_get_version) || die "Failed to install pdb2pqr wrapper."
-
- insinto "${INPATH}"
- doins __init__.py || \
- die "Setting up the pdb2pqr site-package failed."
-
- exeinto "${INPATH}"
- doexe ${PN}.py || die "Installing pdb2pqr failed."
-
- insinto "${INPATH}"/dat
- doins dat/* || die "Installing data failed."
-
- exeinto "${INPATH}"/extensions
- doexe extensions/* || \
- die "Failed to install extensions."
-
- insinto "${INPATH}"/src
- doins src/*.py || die "Installing of python scripts failed."
-
- exeinto "${INPATH}"/propka
- doexe propka/_propkalib.so || \
- die "Failed to install propka."
-
- insinto "${INPATH}"/propka
- doins propka/propkalib.py propka/__init__.py || \
- die "Failed to install propka."
-
- insinto "${INPATH}"/pdb2pka
- doins pdb2pka/*.{py,so,DAT,h} || \
- die "Failed to install pdb2pka."
-
- insinto "${INPATH}"/pdb2pka/
- doins pdb2pka/*.{py,so,DAT,h} || \
- die "Failed to install pdb2pka."
- }
- python_execute_function -s installation
-
- dosym ${PN}-$(python_get_version -f) /usr/bin/${PN}
-
- if use doc; then
- cd doc
- sh genpydoc.sh \
- || die "genpydoc failed"
- dohtml -r *.html images pydoc \
- || die "failed to install html docs"
- cd -
- fi
-
- if use examples; then
- insinto /usr/share/${PN}/
- doins -r examples || die "Failed to install examples."
- fi
-
- dodoc ChangeLog NEWS README AUTHORS || \
- die "Failed to install docs"
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.8.0-r1.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.8.0-r1.ebuild
deleted file mode 100644
index 4a3004f21dd7..000000000000
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.8.0-r1.ebuild,v 1.1 2014/10/24 12:06:42 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools eutils fortran-2 flag-o-matic python-single-r1 toolchain-funcs versionator
-
-MY_PV=$(get_version_component_range 1-2)
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
-LICENSE="BSD"
-HOMEPAGE="http://www.poissonboltzmann.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-IUSE="doc examples opal +pdb2pka"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-chemistry/openbabel[python]
- opal? ( dev-python/zsi[${PYTHON_USEDEP}] )
- pdb2pka? ( sci-chemistry/apbs[${PYTHON_USEDEP},-mpi] )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if [[ -z ${MAXATOMS} ]]; then
- einfo "If you like to have support for more then 10000 atoms,"
- einfo "export MAXATOMS=\"your value\""
- else
- einfo "Allow usage of ${MAXATOMS} during calculations"
- fi
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- rm -rf contrib/* || die
- epatch \
- "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${PN}-1.4.0-automagic.patch \
- "${FILESDIR}"/1.7.0-install.patch
- sed \
- -e '50,200s:CWD:DESTDIR:g' \
- -i Makefile.am || die
-
- eautoreconf
-
- tc-export CC
-}
-
-src_configure() {
- # we need to compile the *.so as pic
- append-flags -fPIC
- FFLAGS="${FFLAGS} -fPIC"
- econf \
- --with-max-atoms=${MAXATOMS:-10000} \
- --with-python="${PYTHON}" \
- $(usex pdb2pka "" --disable-pdb2pka) \
- $(use_with opal) \
- NUMPY="${EPREFIX}/$(python_get_sitedir)" \
- F77="$(tc-getFC)"
-}
-
-src_compile() {
- default
- if use doc; then
- pushd doc > /dev/null
- sh genpydoc.sh || die "genpydoc failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- emake -j1 test
-}
-
-src_install() {
- local lib
- dodir $(python_get_sitedir)/${PN}
- emake -j1 \
- DESTDIR="${ED}$(python_get_sitedir)/${PN}" \
- PREFIX="" install
- INPATH="$(python_get_sitedir)/${PN}"
-
- make_wrapper ${PN} "${PYTHON} /$(python_get_sitedir)/${PN}/${PN}.py"
- make_wrapper pdb2pka "${PYTHON} /$(python_get_sitedir)/${PN}/pdb2pka/pka.py"
-
- for lib in _apbs.so apbslib.py{,c,o}; do
- dosym /usr/share/apbs/tools/python/${lib} $(python_get_sitedir)/${PN}/pdb2pka/${lib}
- done
-
- if use doc; then
- pushd doc > /dev/null
- dohtml -r *.html images pydoc
- popd > /dev/null
- fi
-
- use examples && \
- insinto /usr/share/${PN}/ && \
- doins -r examples
-
- dodoc ChangeLog NEWS README AUTHORS
-
- python_optimize
-}
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild
deleted file mode 100644
index bce2a68f8450..000000000000
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.9.0.ebuild,v 1.3 2014/10/29 02:42:21 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit scons-utils fortran-2 flag-o-matic python-single-r1 toolchain-funcs
-
-DESCRIPTION="An automated pipeline for performing Poisson-Boltzmann electrostatics calculations"
-HOMEPAGE="http://www.poissonboltzmann.org/"
-SRC_URI="https://github.com/Electrostatics/apbs-${PN}/releases/download/${P}/${PN}-src-${PV}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-IUSE="doc examples opal +pdb2pka"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-chemistry/openbabel[python]
- sci-chemistry/openbabel-python[${PYTHON_USEDEP}]
- opal? ( dev-python/zsi[${PYTHON_USEDEP}] )
- pdb2pka? ( sci-chemistry/apbs[${PYTHON_USEDEP},-mpi] )"
-DEPEND="${RDEPEND}
- dev-lang/swig:0"
-
-pkg_setup() {
- if [[ -z ${MAXATOMS} ]]; then
- einfo "If you like to have support for more then 10000 atoms,"
- einfo "export MAXATOMS=\"your value\""
- export MAXATOMS=10000
- else
- einfo "Allow usage of ${MAXATOMS} during calculations"
- fi
- fortran-2_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- find -type f \( -name "*\.pyc" -o -name "*\.pyo" \) -delete || die
-
- cat > build_config.py <<- EOF
- PREFIX="${ED}/$(python_get_sitedir)/${PN}"
- #URL="http://<COMPUTER NAME>/pdb2pqr/"
- APBS="${EPREFIX}/usr/bin/apbs"
- #OPAL="http://nbcr-222.ucsd.edu/opal2/services/pdb2pqr_1.8"
- #APBS_OPAL="http://nbcr-222.ucsd.edu/opal2/services/apbs_1.3"
- MAX_ATOMS=${MAXATOMS}
- BUILD_PDB2PKA=$(usex pdb2pka True False)
- REBUILD_SWIG=True
- EOF
-
- export CXXFLAGS="${CXXFLAGS}"
- export LDFLAGS="${LDFLAGS}"
-
- epatch "${FILESDIR}"/${P}-flags.patch
- tc-export CXX
- rm -rf scons || die
-}
-
-src_compile() {
- escons
-}
-
-src_test() {
- local myesconsargs=( -j1 )
- escons test
- escons advtest
- escons complete-test
-}
-
-src_install() {
- escons install
-
- local lib
-
- make_wrapper ${PN} "${PYTHON} /$(python_get_sitedir)/${PN}/${PN}.py"
- make_wrapper pdb2pka "${PYTHON} /$(python_get_sitedir)/${PN}/pdb2pka/pka.py"
-
- for lib in apbslib.py{,c,o}; do
- dosym ../../apbs/${lib} $(python_get_sitedir)/${PN}/pdb2pka/${lib}
- done
- dosym ../../_apbslib.so $(python_get_sitedir)/${PN}/pdb2pka/_apbslib.so
-
- if use doc; then
- pushd doc > /dev/null
- dohtml -r *.html images pydoc
- popd > /dev/null
- fi
-
- use examples && \
- insinto /usr/share/${PN}/ && \
- doins -r examples
-
- dodir /usr/share/doc/${PF}/html
- mv "${ED}"$(python_get_sitedir)/${PN}/doc/pydoc/* "${ED}"/usr/share/doc/${PF}/html || die
- rmdir "${ED}"$(python_get_sitedir)/${PN}/doc/pydoc || die
- mv "${ED}"$(python_get_sitedir)/${PN}/doc/* "${ED}"/usr/share/doc/${PF}/ || die
-
- dodoc *md NEWS
-
- find "${ED}"$(python_get_sitedir)/${PN}/contrib -delete || die
-
- python_optimize
-}