summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-04 16:14:00 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-04 16:14:00 +0000
commit2a5520b2e2437d89a679a0a99a5158d9c95c22b2 (patch)
tree951f7cff3fd801371d5fdfe937e2914ba10d66d8 /sci-chemistry
parentdev-python/netcdf4-python: Add missing dep on sci-libs/hdf5; Fix USEDEP; impl... (diff)
downloadgentoo-2-2a5520b2e2437d89a679a0a99a5158d9c95c22b2.tar.gz
gentoo-2-2a5520b2e2437d89a679a0a99a5158d9c95c22b2.tar.bz2
gentoo-2-2a5520b2e2437d89a679a0a99a5158d9c95c22b2.zip
sci-chemistry/mdanalysis: New addition written by me
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mdanalysis/ChangeLog10
-rw-r--r--sci-chemistry/mdanalysis/Manifest4
-rw-r--r--sci-chemistry/mdanalysis/mdanalysis-0.7.7.ebuild35
-rw-r--r--sci-chemistry/mdanalysis/metadata.xml8
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-chemistry/mdanalysis/ChangeLog b/sci-chemistry/mdanalysis/ChangeLog
new file mode 100644
index 000000000000..03436cd52f9b
--- /dev/null
+++ b/sci-chemistry/mdanalysis/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/mdanalysis
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mdanalysis/ChangeLog,v 1.1 2013/07/04 16:14:00 jlec Exp $
+
+*mdanalysis-0.7.7 (04 Jul 2013)
+
+ 04 Jul 2013; Justin Lecher <jlec@gentoo.org> +mdanalysis-0.7.7.ebuild,
+ +metadata.xml:
+ New addition written by me
+
diff --git a/sci-chemistry/mdanalysis/Manifest b/sci-chemistry/mdanalysis/Manifest
new file mode 100644
index 000000000000..6aa1f37c3dcc
--- /dev/null
+++ b/sci-chemistry/mdanalysis/Manifest
@@ -0,0 +1,4 @@
+DIST MDAnalysis-0.7.7.tar.gz 3262287 SHA256 9dd72b776bf7f2be83da562a638895a94f629422798cc309c14965795847eac1 SHA512 c26085c767ec213d5aa27709029e5a3b9df786c10e23e3841ffc9644e2fd66c8add0358f013c51a95fa3452c5c900b44901db736830504b669916ea45a924712 WHIRLPOOL 2acaa02d641d67bef4cd9ec311c787f57884d83bf350b46af9e862ca6d3a03a6d4ff3d71a2e866f5ab57e29036c5a3182a167e3bcc492667e9a5a60778de0b39
+EBUILD mdanalysis-0.7.7.ebuild 906 SHA256 e29dbfa942d3b0ee6daf64a81a895c09659ffc8cb81987db19ea41e4493ee7c1 SHA512 8bf3c04ac0ad3c2a57103129a174ae67f5271c3fdf1f20caf0d07fe86b4e2957abf20e07894740873f8c2211f8c6866148b25a4030729675c6cc314901cefade WHIRLPOOL b04120158ea027a6ddeace564d93abe1d934ae68d0c43aec05a7288654e93da723e2caf7ef4274e2928d1697787ee1b6b83546572473c53a994431f284bfce05
+MISC ChangeLog 278 SHA256 9206f1f9ffb9cb177141f3b2de09912311615d6dfa7760abfbeb9a1427ee6bfc SHA512 429c2f596847f3caaec07f221ce3ff9056ed204e40e1b5161ed5a0b7c58fb6502629dad4298c96f7ff9056119ac4e43a30f4192ffe9423e4b11b722511f33fab WHIRLPOOL 90cc1230d1725166dae71b386fc23d66ca183d8aae446db7d1277bfa4b30572056cb152469ebf9a53b05f95526199bf3cce462ce3f67af3a697b6475e09a893f
+MISC metadata.xml 224 SHA256 84b014a026c2945b1b4c6eda4a4576b09039b36c27c2f9f8920ae146a8acfa3e SHA512 3b70a09392d7a939bc59e483e63789152e8dc73351dc682548a47db282224b5d9df7eac8c51bca9847e0b647f88fe2a1e4059ffe262c89a84002a13507fb3586 WHIRLPOOL 078ad63719dd7c12015a2e69f1f00322eda7e4a85f8499b89779a9bdedc92e11bb6c8cb28d6cbdc61c144fe5f22b11264d65a06cc2e67d09a0e4ef37529df71a
diff --git a/sci-chemistry/mdanalysis/mdanalysis-0.7.7.ebuild b/sci-chemistry/mdanalysis/mdanalysis-0.7.7.ebuild
new file mode 100644
index 000000000000..e69bfa29d879
--- /dev/null
+++ b/sci-chemistry/mdanalysis/mdanalysis-0.7.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mdanalysis/mdanalysis-0.7.7.ebuild,v 1.1 2013/07/04 16:14:00 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN="MDAnalysis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A python library to analyze and manipulate molecular dynamics trajectories"
+HOMEPAGE="https://code.google.com/p/mdanalysis/"
+SRC_URI="https://mdanalysis.googlecode.com/files/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/scientificpython[${PYTHON_USEDEP}]
+ dev-python/GridDataFormats[${PYTHON_USEDEP}]
+ dev-python/netcdf4-python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/${MY_P}
diff --git a/sci-chemistry/mdanalysis/metadata.xml b/sci-chemistry/mdanalysis/metadata.xml
new file mode 100644
index 000000000000..5ef07a39e7e1
--- /dev/null
+++ b/sci-chemistry/mdanalysis/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>