summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-18 16:36:29 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-18 16:36:29 +0000
commit1add751d16a1c8feecd51294ad3a61641cca5ce5 (patch)
tree6f9585c50c503d76c60b82b60a45a1638a52d9cc /sci-chemistry
parentversion bump; stable x86 amd64 (diff)
downloadgentoo-2-1add751d16a1c8feecd51294ad3a61641cca5ce5.tar.gz
gentoo-2-1add751d16a1c8feecd51294ad3a61641cca5ce5.tar.bz2
gentoo-2-1add751d16a1c8feecd51294ad3a61641cca5ce5.zip
Fixed implicit declarations
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/imosflm/ChangeLog6
-rw-r--r--sci-chemistry/imosflm/files/1.0.4-impl-dec.patch12
-rw-r--r--sci-chemistry/imosflm/imosflm-1.0.4.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/sci-chemistry/imosflm/ChangeLog b/sci-chemistry/imosflm/ChangeLog
index 19a5ad830362..d6d76b0acd68 100644
--- a/sci-chemistry/imosflm/ChangeLog
+++ b/sci-chemistry/imosflm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/imosflm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/ChangeLog,v 1.2 2011/01/16 12:24:25 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/ChangeLog,v 1.3 2011/01/18 16:36:29 jlec Exp $
+
+ 18 Jan 2011; Justin Lecher <jlec@gentoo.org> +files/1.0.4-impl-dec.patch,
+ imosflm-1.0.4.ebuild:
+ Fixed implicit declarations
16 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> imosflm-1.0.4.ebuild:
marked ~ppc wrt #303931
diff --git a/sci-chemistry/imosflm/files/1.0.4-impl-dec.patch b/sci-chemistry/imosflm/files/1.0.4-impl-dec.patch
new file mode 100644
index 000000000000..5d0dd7010910
--- /dev/null
+++ b/sci-chemistry/imosflm/files/1.0.4-impl-dec.patch
@@ -0,0 +1,12 @@
+diff --git a/c/tkImageLoad.c b/c/tkImageLoad.c
+index e7c46f0..1496a15 100755
+--- a/c/tkImageLoad.c
++++ b/c/tkImageLoad.c
+@@ -12,6 +12,7 @@
+ #include <tcl.h>
+ #include <tk.h>
+ #include <assert.h>
++#include <stdlib.h>
+
+ #define HEADER_LINE_LENGTH 512
+ #define BYTES_PER_PIXEL 2
diff --git a/sci-chemistry/imosflm/imosflm-1.0.4.ebuild b/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
index 8888e9136192..88f06d8892a5 100644
--- a/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
+++ b/sci-chemistry/imosflm/imosflm-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/imosflm-1.0.4.ebuild,v 1.2 2011/01/16 12:24:25 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/imosflm/imosflm-1.0.4.ebuild,v 1.3 2011/01/18 16:36:29 jlec Exp $
EAPI="3"
@@ -34,7 +34,9 @@ DEPEND="app-arch/unzip"
S="${WORKDIR}"/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${PV}-tk.patch
+ epatch \
+ "${FILESDIR}"/${PV}-tk.patch \
+ "${FILESDIR}"/${PV}-impl-dec.patch
}
src_compile() {