summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-01-24 12:14:49 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-01-24 12:14:49 +0000
commit05ac526eb6d3258b2e630ca83f17fed3e1304174 (patch)
tree19bb5077d35621644df7d9dbe76b966ee0800519 /sci-chemistry/wxmacmolplt
parentMask capistrano-1.x and its dependencies. (diff)
downloadgentoo-2-05ac526eb6d3258b2e630ca83f17fed3e1304174.tar.gz
gentoo-2-05ac526eb6d3258b2e630ca83f17fed3e1304174.tar.bz2
gentoo-2-05ac526eb6d3258b2e630ca83f17fed3e1304174.zip
[sci-chemistry/wxmacmolplt] Version bump per bug #292977
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/wxmacmolplt')
-rw-r--r--sci-chemistry/wxmacmolplt/ChangeLog7
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/sci-chemistry/wxmacmolplt/ChangeLog b/sci-chemistry/wxmacmolplt/ChangeLog
index c6dc9adb3375..9f9b9d48e869 100644
--- a/sci-chemistry/wxmacmolplt/ChangeLog
+++ b/sci-chemistry/wxmacmolplt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/wxmacmolplt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.2 2010/01/22 23:46:35 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/ChangeLog,v 1.3 2010/01/24 12:14:49 alexxy Exp $
+
+*wxmacmolplt-7.4 (24 Jan 2010)
+
+ 24 Jan 2010; Alexey Shvetsov <alexxy@gentoo.org> +wxmacmolplt-7.4.ebuild:
+ Version bump per bug #292977
*wxmacmolplt-7.3-r1 (22 Jan 2010)
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild
new file mode 100644
index 000000000000..35c023182f2c
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.4.ebuild,v 1.1 2010/01/24 12:14:49 alexxy Exp $
+
+EAPI="2"
+
+inherit base eutils autotools
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
+
+SRC_URI="http://www.scl.ameslab.gov/MacMolPlt/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="flash"
+
+DEPEND="x11-libs/wxGTK[opengl]
+ flash? ( media-libs/ming )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "/^dist_doc_DATA/d" Makefile.am \
+ || die "Failed to disable installation of LICENSE file"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with flash ming)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN}.png "Science;Education"
+}