summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-07 22:54:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-07-07 22:54:52 +0000
commit6bf627127a2f25128ede79c48d5035cfaef1f4ba (patch)
tree81f015ce1eee4cc8ba69530ee968ee84777c5209 /sci-chemistry/vmd
parentAdd patch to fix compilation with gcc 4.4, fixes bug 273837 (diff)
downloadgentoo-2-6bf627127a2f25128ede79c48d5035cfaef1f4ba.tar.gz
gentoo-2-6bf627127a2f25128ede79c48d5035cfaef1f4ba.tar.bz2
gentoo-2-6bf627127a2f25128ede79c48d5035cfaef1f4ba.zip
Use elog for fetch error.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/vmd')
-rw-r--r--sci-chemistry/vmd/ChangeLog5
-rw-r--r--sci-chemistry/vmd/vmd-1.8.6-r1.ebuild14
2 files changed, 11 insertions, 8 deletions
diff --git a/sci-chemistry/vmd/ChangeLog b/sci-chemistry/vmd/ChangeLog
index 605875f2ac0f..2b86734de4dd 100644
--- a/sci-chemistry/vmd/ChangeLog
+++ b/sci-chemistry/vmd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-chemistry/vmd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.21 2009/05/18 03:57:38 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/ChangeLog,v 1.22 2009/07/07 22:54:52 flameeyes Exp $
+
+ 07 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> vmd-1.8.6-r1.ebuild:
+ Use elog for fetch error.
18 May 2009; Jeff Gardner <je_fro@gentoo.org>
+files/vmd-1.8.6-fix-crash-on-tcl8.5.patch:
diff --git a/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild b/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild
index 276830b62098..f36702f326ff 100644
--- a/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild
+++ b/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild,v 1.1 2009/05/17 20:15:13 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/vmd/vmd-1.8.6-r1.ebuild,v 1.2 2009/07/07 22:54:52 flameeyes Exp $
EAPI="1"
@@ -33,10 +33,10 @@ VMD_DOWNLOAD="http://www.ks.uiuc.edu/Development/Download/download.cgi?PackageNa
pkg_nofetch() {
echo
- einfo "Please download ${SRC_URI} from"
- einfo "${VMD_DOWNLOAD}"
- einfo "after agreeing to the license and then move it to "
- einfo "${DISTDIR}"
+ elog "Please download ${SRC_URI} from"
+ elog "${VMD_DOWNLOAD}"
+ elog "after agreeing to the license and then move it to "
+ elog "${DISTDIR}"
echo
}
@@ -60,14 +60,14 @@ src_unpack() {
cd "${WORKDIR}"/plugins
sed -e "s:CC = gcc:CC = $(tc-getCC):" \
- -e "s:CXX = g++:CXX = $(tc-getCXX):" \
+ -e "s:CXX = g++:CXX = $(tc-getCXX):" \
-e "s:COPTO = -o :COPTO = -fPIC -o :" \
-e "s:LOPTO = -o :LOPTO = -fPIC -o :" \
-e "s:CCFLAGS = -O2 -Wall:CCFLAGS = ${CFLAGS}:" \
-e "s:CXXFLAGS = -O2 -Wall:CXXFLAGS = ${CXXFLAGS}:" \
-e "s:SHLD = gcc:SHLD = $(tc-getCC):" \
-e "s:-ltcl8.4:-ltcl:" \
- -i Make-arch || die "Failed to set up plugins Makefile"
+ -i Make-arch || die "Failed to set up plugins Makefile"
sed -e "s:1.0:1.2:" -i vdna/pkgIndex.tcl \
|| die "Failed to fix vdna plugin"