summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-05-06 07:59:31 +0000
committerJustin Lecher <jlec@gentoo.org>2011-05-06 07:59:31 +0000
commite543e0335608cc69b87f0286a8d5627cec6e0492 (patch)
tree0dfe9bbb5e8173ecc86b99a9475534f80cc07d70 /sci-chemistry/pymol
parentRemove myself as explicit python-twitter maintainer. (diff)
downloadgentoo-2-e543e0335608cc69b87f0286a8d5627cec6e0492.tar.gz
gentoo-2-e543e0335608cc69b87f0286a8d5627cec6e0492.tar.bz2
gentoo-2-e543e0335608cc69b87f0286a8d5627cec6e0492.zip
Version Bump, notified by euscan; cleaned old
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pymol')
-rw-r--r--sci-chemistry/pymol/ChangeLog9
-rw-r--r--sci-chemistry/pymol/files/1.4.1-data-path.patch87
-rw-r--r--sci-chemistry/pymol/files/1.4.1-shaders.patch58
-rw-r--r--sci-chemistry/pymol/pymol-1.3.0.ebuild104
-rw-r--r--sci-chemistry/pymol/pymol-1.3.1_pre3924.ebuild105
-rw-r--r--sci-chemistry/pymol/pymol-1.4.1.ebuild (renamed from sci-chemistry/pymol/pymol-1.4_beta1.ebuild)11
6 files changed, 157 insertions, 217 deletions
diff --git a/sci-chemistry/pymol/ChangeLog b/sci-chemistry/pymol/ChangeLog
index efa1bcba930e..b49fd6595b49 100644
--- a/sci-chemistry/pymol/ChangeLog
+++ b/sci-chemistry/pymol/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/pymol
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.77 2011/04/05 06:39:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/ChangeLog,v 1.78 2011/05/06 07:59:31 jlec Exp $
+
+*pymol-1.4.1 (06 May 2011)
+
+ 06 May 2011; Justin Lecher <jlec@gentoo.org> +files/1.4.1-data-path.patch,
+ -pymol-1.3.0.ebuild, -pymol-1.3.1_pre3924.ebuild, -pymol-1.4_beta1.ebuild,
+ +pymol-1.4.1.ebuild, +files/1.4.1-shaders.patch:
+ Version Bump, notified by euscan; cleaned old
05 Apr 2011; Justin Lecher <jlec@gentoo.org> pymol-1.4_beta1.ebuild:
Cleaned unneeded SRC_URI entries
diff --git a/sci-chemistry/pymol/files/1.4.1-data-path.patch b/sci-chemistry/pymol/files/1.4.1-data-path.patch
new file mode 100644
index 000000000000..903714cd223a
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.4.1-data-path.patch
@@ -0,0 +1,87 @@
+ modules/chempy/__init__.py | 2 +-
+ modules/chempy/tinker/__init__.py | 2 +-
+ modules/pymol/commanding.py | 6 +++---
+ modules/pymol/importing.py | 2 +-
+ modules/pymol/wizard/mutagenesis.py | 4 ++--
+ 5 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/modules/chempy/__init__.py b/modules/chempy/__init__.py
+index 998e8f8..02fe156 100644
+--- a/modules/chempy/__init__.py
++++ b/modules/chempy/__init__.py
+@@ -229,7 +229,7 @@ if os.environ.has_key('CHEMPY_DATA'): #
+ elif os.environ.has_key('PYMOL_DATA'):
+ path = os.environ['PYMOL_DATA'] + '/chempy/'
+ elif os.environ.has_key('PYMOL_PATH'):
+- path = os.environ['PYMOL_PATH'] + '/data/chempy/'
++ path = os.environ['PYMOL_PATH'] + '/chempy/'
+ elif os.environ.has_key('FREEMOL_MODULES'):
+ path = os.environ['FREEMOL_MODULES'] + '/chempy/'
+ else:
+diff --git a/modules/chempy/tinker/__init__.py b/modules/chempy/tinker/__init__.py
+index a2d8eb1..1e48f81 100644
+--- a/modules/chempy/tinker/__init__.py
++++ b/modules/chempy/tinker/__init__.py
+@@ -147,7 +147,7 @@ else:
+
+ if os.environ.has_key('PYMOL_PATH'):
+ pymol_path = os.environ['PYMOL_PATH']
+- test_path = pymol_path + '/data/chempy/tinker/'
++ test_path = pymol_path + '/chempy/tinker/'
+ if os.path.exists(test_path):
+ params_path = test_path
+
+diff --git a/modules/pymol/commanding.py b/modules/pymol/commanding.py
+index 5a202d0..5cb27a6 100644
+--- a/modules/pymol/commanding.py
++++ b/modules/pymol/commanding.py
+@@ -219,11 +219,11 @@ USAGE
+ _self.unlock(0,_self)
+ r = DEFAULT_SUCCESS
+ if show_splash==1: # generic / open-source
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/splash.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/splash.png")
+ elif show_splash==2: # evaluation builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/epymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/epymol.png")
+ else: # incentive builds
+- png_path = _self.exp_path("$PYMOL_PATH/data/pymol/ipymol.png")
++ png_path = _self.exp_path("$PYMOL_DATA/pymol/ipymol.png")
+ if os.path.exists(png_path):
+ _self.do("_ cmd.load_png('%s',0,quiet=1)"%png_path)
+ else:
+diff --git a/modules/pymol/importing.py b/modules/pymol/importing.py
+index 1ccf986..72ae9f3 100644
+--- a/modules/pymol/importing.py
++++ b/modules/pymol/importing.py
+@@ -191,7 +191,7 @@ SEE ALSO
+ '''
+ r = DEFAULT_ERROR
+
+- tables = { 'cmyk' : "$PYMOL_PATH/data/pymol/cmyk.png",
++ tables = { 'cmyk' : "$PYMOL_DATA/pymol/cmyk.png",
+ 'pymol' : 'pymol',
+ 'rgb' : 'rgb',
+ 'greyscale': 'greyscale' }
+diff --git a/modules/pymol/wizard/mutagenesis.py b/modules/pymol/wizard/mutagenesis.py
+index 8a5250d..6c1b26c 100644
+--- a/modules/pymol/wizard/mutagenesis.py
++++ b/modules/pymol/wizard/mutagenesis.py
+@@ -53,7 +53,7 @@ class Mutagenesis(Wizard):
+ self.dep = default_dep
+
+ self.ind_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_ind.pkl")
++ "/chempy/sidechains/sc_bb_ind.pkl")
+ self.load_library()
+ self.status = 0 # 0 no selection, 1 mutagenizing
+ self.bump_check = 1
+@@ -218,7 +218,7 @@ class Mutagenesis(Wizard):
+ if self.dep == 'dep':
+ if not hasattr(self,'dep_library'):
+ self.dep_library = io.pkl.fromFile(os.environ['PYMOL_PATH']+
+- "/data/chempy/sidechains/sc_bb_dep.pkl")
++ "/chempy/sidechains/sc_bb_dep.pkl")
+
+ def set_mode(self,mode):
+ cmd=self.cmd
diff --git a/sci-chemistry/pymol/files/1.4.1-shaders.patch b/sci-chemistry/pymol/files/1.4.1-shaders.patch
new file mode 100644
index 000000000000..2caac2dc4bce
--- /dev/null
+++ b/sci-chemistry/pymol/files/1.4.1-shaders.patch
@@ -0,0 +1,58 @@
+Index: layer0/ShaderMgr.c
+===================================================================
+--- layer0/ShaderMgr.c (revision 3945)
++++ layer0/ShaderMgr.c (working copy)
+@@ -400,7 +400,7 @@
+ char * CShaderMgr_ReadShaderFromDisk(PyMOLGlobals * G, const char * fileName) {
+ FILE* f;
+ long size;
+- char* buffer = NULL, *p, *pymol_path, *shader_path, *fullFile;
++ char* buffer = NULL, *p, *pymol_data, *shader_path, *fullFile;
+
+ PRINTFB(G, FB_ShaderMgr, FB_Debugging)
+ "CShaderMgr_ReadShaderFromDisk: fileName='%s'\n", fileName
+@@ -412,16 +412,16 @@
+ return NULL;
+ }
+
+- pymol_path = getenv("PYMOL_PATH");
+- if (!pymol_path){
++ pymol_data = getenv("PYMOL_DATA");
++ if (!pymol_data){
+ PRINTFB(G, FB_ShaderMgr, FB_Warnings)
+- " PyMOLShader_NewFromFile-Warning: PYMOL_PATH not set, cannot read shader config files from disk\n", fileName ENDFB(G);
++ " PyMOLShader_NewFromFile-Warning: PYMOL_DATA not set, cannot read shader config files from disk\n", fileName ENDFB(G);
+ return NULL;
+ }
+ /* make this a setting */
+- shader_path = "/data/shaders/";
+- fullFile = malloc( sizeof(char) * (strlen(pymol_path)+strlen(shader_path)+strlen(fileName)+1));
+- fullFile = strcpy(fullFile, pymol_path);
++ shader_path = "/shaders/";
++ fullFile = malloc( sizeof(char) * (strlen(pymol_data)+strlen(shader_path)+strlen(fileName)+1));
++ fullFile = strcpy(fullFile, pymol_data);
+ fullFile = strcat(fullFile, shader_path);
+ fullFile = strcat(fullFile, fileName);
+
+@@ -430,7 +430,7 @@
+
+ if (!f) {
+ PRINTFB(G, FB_ShaderMgr, FB_Errors)
+- " PyMOLShader_NewFromFile-Error: Unable to open file '%s' PYMOL_PATH='%s'\n", fullFile, pymol_path ENDFB(G);
++ " PyMOLShader_NewFromFile-Error: Unable to open file '%s' PYMOL_DATA='%s'\n", fullFile, pymol_data ENDFB(G);
+ return NULL;
+ } else {
+ PRINTFB(G, FB_ShaderMgr, FB_Blather)
+Index: layer1/Setting.c
+===================================================================
+--- layer1/Setting.c (revision 3945)
++++ layer1/Setting.c (working copy)
+@@ -3990,7 +3990,7 @@
+ set_b(I, cSetting_line_use_shader, 1);
+ set_b(I, cSetting_sphere_use_shader, 1);
+ set_b(I, cSetting_use_shaders, 0); /* disable by default until optimized shaders present; doesn't effect vol */
+- set_s(I, cSetting_shader_path, "data/shaders");
++ set_s(I, cSetting_shader_path, "shaders");
+ set_i(I, cSetting_volume_bit_depth, 8);
+ set_color(I, cSetting_volume_color, "-1");
+ set_f(I, cSetting_volume_layers, 256);
diff --git a/sci-chemistry/pymol/pymol-1.3.0.ebuild b/sci-chemistry/pymol/pymol-1.3.0.ebuild
deleted file mode 100644
index 0c44426dde69..000000000000
--- a/sci-chemistry/pymol/pymol-1.3.0.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.3.0.ebuild,v 1.4 2010/09/19 19:32:44 jlec Exp $
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
-PYTHON_USE_WITH="tk"
-REV="3909"
-
-inherit eutils distutils prefix
-
-DESCRIPTION="A Python-extensible molecular graphics system."
-HOMEPAGE="http://pymol.sourceforge.net/"
-SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
-
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="apbs numpy shaders vmd"
-
-DEPEND="
- dev-python/numpy
- dev-python/pmw
- media-libs/freetype:2
- media-libs/libpng
- media-video/mpeg-tools
- sys-libs/zlib
- media-libs/freeglut
- apbs? (
- dev-libs/maloc
- sci-chemistry/apbs
- sci-chemistry/pdb2pqr
- sci-chemistry/pymol-apbs-plugin
- )"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.* 2.4 2.5"
-
-S="${WORKDIR}"/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/1.2.2-data-path.patch
-
- epatch "${FILESDIR}"/1.2.2-prefix.patch && \
- eprefixify setup.py
-
- # Turn off splash screen. Please do make a project contribution
- # if you are able though. #299020
- epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
-
- # Respect CFLAGS
- sed -i \
- -e "s:\(ext_comp_args=\).*:\1[]:g" \
- "${S}"/setup.py || die "Failed running sed on setup.py"
-
- use shaders && epatch "${FILESDIR}"/${PN}-1.2.2-shaders.patch
-
- use vmd && epatch "${FILESDIR}"/${PV}-vmd.patch
-
- use numpy && \
- sed \
- -e '/PYMOL_NUMPY/s:^#::g' \
- -i setup.py
-
- rm ./modules/pmg_tk/startup/apbs_tools.py || die
-
- # python 3.* fix
- # sed '452,465d' -i setup.py
- distutils_src_prepare
-}
-
-src_configure() {
- :
-}
-
-src_install() {
- distutils_src_install
-
- # These environment variables should not go in the wrapper script, or else
- # it will be impossible to use the PyMOL libraries from Python.
- cat >> "${T}"/20pymol <<- EOF
- PYMOL_PATH="${EPREFIX}/$(python_get_sitedir -f)/${PN}"
- PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
- PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
- EOF
-
- doenvd "${T}"/20pymol || die "Failed to install env.d file."
-
- cat >> "${T}"/pymol <<- EOF
- #!/bin/sh
- $(PYTHON -f) -O \${PYMOL_PATH}/__init__.py \$*
- EOF
-
- dobin "${T}"/pymol || die "Failed to install wrapper."
-
- insinto /usr/share/pymol
- doins -r test data scripts || die "no shared data"
-
- insinto /usr/share/pymol/examples
- doins -r examples || die "Failed to install docs."
-
- dodoc DEVELOPERS README || die "Failed to install docs."
-}
diff --git a/sci-chemistry/pymol/pymol-1.3.1_pre3924.ebuild b/sci-chemistry/pymol/pymol-1.3.1_pre3924.ebuild
deleted file mode 100644
index c86d2c4f7108..000000000000
--- a/sci-chemistry/pymol/pymol-1.3.1_pre3924.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.3.1_pre3924.ebuild,v 1.1 2010/10/22 08:36:38 jlec Exp $
-
-EAPI="3"
-
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2:2.6"
-PYTHON_USE_WITH="tk"
-REV="3923"
-
-inherit eutils distutils prefix
-
-DESCRIPTION="A Python-extensible molecular graphics system."
-HOMEPAGE="http://pymol.sourceforge.net/"
-#SRC_URI="http://pymol.svn.sourceforge.net/viewvc/pymol/trunk/pymol.tar.gz?view=tar&pathrev=${REV} -> ${P}.tar.gz"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="PSF-2.2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="apbs numpy shaders vmd"
-
-DEPEND="
- dev-python/numpy
- dev-python/pmw
- media-libs/freetype:2
- media-libs/libpng
- media-video/mpeg-tools
- sys-libs/zlib
- media-libs/freeglut
- apbs? (
- dev-libs/maloc
- sci-chemistry/apbs
- sci-chemistry/pdb2pqr
- sci-chemistry/pymol-apbs-plugin
- )"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.* 2.4 2.5"
-
-S="${WORKDIR}"/${PN}
-
-src_prepare() {
- epatch "${FILESDIR}"/1.2.2-data-path.patch
-
- epatch "${FILESDIR}"/1.2.2-prefix.patch && \
- eprefixify setup.py
-
- # Turn off splash screen. Please do make a project contribution
- # if you are able though. #299020
- epatch "${FILESDIR}"/1.2.1/nosplash-gentoo.patch
-
- # Respect CFLAGS
- sed -i \
- -e "s:\(ext_comp_args=\).*:\1[]:g" \
- "${S}"/setup.py || die "Failed running sed on setup.py"
-
- use shaders && epatch "${FILESDIR}"/${PN}-1.2.2-shaders.patch
-
- use vmd && epatch "${FILESDIR}"/1.3.0-vmd.patch
-
- use numpy && \
- sed \
- -e '/PYMOL_NUMPY/s:^#::g' \
- -i setup.py
-
- rm ./modules/pmg_tk/startup/apbs_tools.py || die
-
- # python 3.* fix
- # sed '452,465d' -i setup.py
- distutils_src_prepare
-}
-
-src_configure() {
- :
-}
-
-src_install() {
- distutils_src_install
-
- # These environment variables should not go in the wrapper script, or else
- # it will be impossible to use the PyMOL libraries from Python.
- cat >> "${T}"/20pymol <<- EOF
- PYMOL_PATH="${EPREFIX}/$(python_get_sitedir -f)/${PN}"
- PYMOL_DATA="${EPREFIX}/usr/share/pymol/data"
- PYMOL_SCRIPTS="${EPREFIX}/usr/share/pymol/scripts"
- EOF
-
- doenvd "${T}"/20pymol || die "Failed to install env.d file."
-
- cat >> "${T}"/pymol <<- EOF
- #!/bin/sh
- $(PYTHON -f) -O \${PYMOL_PATH}/__init__.py \$*
- EOF
-
- dobin "${T}"/pymol || die "Failed to install wrapper."
-
- insinto /usr/share/pymol
- doins -r test data scripts || die "no shared data"
-
- insinto /usr/share/pymol/examples
- doins -r examples || die "Failed to install docs."
-
- dodoc DEVELOPERS README || die "Failed to install docs."
-}
diff --git a/sci-chemistry/pymol/pymol-1.4_beta1.ebuild b/sci-chemistry/pymol/pymol-1.4.1.ebuild
index aaa83cce538f..c2a37b37235d 100644
--- a/sci-chemistry/pymol/pymol-1.4_beta1.ebuild
+++ b/sci-chemistry/pymol/pymol-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.4_beta1.ebuild,v 1.2 2011/04/05 06:39:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol/pymol-1.4.1.ebuild,v 1.1 2011/05/06 07:59:31 jlec Exp $
EAPI="3"
@@ -9,13 +9,12 @@ SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
PYTHON_USE_WITH="tk"
PYTHON_MODNAME="${PN} chempy pmg_tk pmg_wx"
-REV="3925"
inherit eutils distutils prefix versionator
DESCRIPTION="A Python-extensible molecular graphics system."
HOMEPAGE="http://pymol.sourceforge.net/"
-SRC_URI="mirror://sourceforge/project/${PN}/${PN}/$(get_version_component_range 1-2)/${PN}-v${PV/_beta/b}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
LICENSE="PSF-2.2"
SLOT="0"
@@ -39,12 +38,10 @@ DEPEND="
)"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"/${PN}
-
src_prepare() {
epatch \
- "${FILESDIR}"/1.2.2-data-path.patch \
- "${FILESDIR}"/$(get_version_component_range 1-2)-shaders.patch
+ "${FILESDIR}"/${PV}-data-path.patch \
+ "${FILESDIR}"/${PV}-shaders.patch
epatch "${FILESDIR}"/1.2.2-prefix.patch && \
eprefixify setup.py