summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-06 13:30:25 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-06 13:30:25 +0000
commit231baa936c6900989e057b159903c370cfe3c689 (patch)
tree28b1a972ba4f93584e46bdadead8b99449e7ea0a /sci-chemistry/probe
parentFix tests (bug #326857). (diff)
downloadgentoo-2-231baa936c6900989e057b159903c370cfe3c689.tar.gz
gentoo-2-231baa936c6900989e057b159903c370cfe3c689.tar.bz2
gentoo-2-231baa936c6900989e057b159903c370cfe3c689.zip
As-needed fix
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/probe')
-rw-r--r--sci-chemistry/probe/ChangeLog8
-rw-r--r--sci-chemistry/probe/files/as-needed.patch21
-rw-r--r--sci-chemistry/probe/probe-2.12.071128-r1.ebuild44
3 files changed, 72 insertions, 1 deletions
diff --git a/sci-chemistry/probe/ChangeLog b/sci-chemistry/probe/ChangeLog
index dba956393097..1e0be3a5494f 100644
--- a/sci-chemistry/probe/ChangeLog
+++ b/sci-chemistry/probe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/probe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/ChangeLog,v 1.9 2010/06/28 15:49:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/ChangeLog,v 1.10 2010/07/06 13:30:24 jlec Exp $
+
+*probe-2.12.071128-r1 (06 Jul 2010)
+
+ 06 Jul 2010; Justin Lecher <jlec@gentoo.org> probe-2.12.071128.ebuild,
+ +probe-2.12.071128-r1.ebuild, +files/as-needed.patch:
+ As-needed fix
28 Jun 2010; Justin Lecher <jlec@gentoo.org> probe-2.12.071128.ebuild:
Keyworded for linux prefix, some QA (die missing)
diff --git a/sci-chemistry/probe/files/as-needed.patch b/sci-chemistry/probe/files/as-needed.patch
new file mode 100644
index 000000000000..9ddecf5f569e
--- /dev/null
+++ b/sci-chemistry/probe/files/as-needed.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 68d7469..bcb821c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ MACHINEFLAGS =
+ CFLAGS = $(MACHINEFLAGS)
+-LFLAGS = -lm $(MACHINEFLAGS)
++LFLAGS = -lm
+ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ parse.o atomprops.o stdconntable.o autobondrot.o hybrid_36_c.o
+
+@@ -8,7 +8,7 @@ OBJLIST = dots.o abin.o readPDBrecs.o geom3d.o utility.o select.o \
+ cc -c $*.c $(CFLAGS)
+
+ probe: probe.o $(OBJLIST)
+- cc -o $@ probe.o $(OBJLIST) $(LFLAGS)
++ cc $(MACHINEFLAGS) -o $@ probe.o $(OBJLIST) $(LFLAGS)
+
+ clean:
+ @rm -f *.o *.ckp
diff --git a/sci-chemistry/probe/probe-2.12.071128-r1.ebuild b/sci-chemistry/probe/probe-2.12.071128-r1.ebuild
new file mode 100644
index 000000000000..8ac069be0279
--- /dev/null
+++ b/sci-chemistry/probe/probe-2.12.071128-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/probe/probe-2.12.071128-r1.ebuild,v 1.1 2010/07/06 13:30:24 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}.${PV}"
+DESCRIPTION="Evaluates atomic packing within or between molecules"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/probe.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/probe/${MY_P}.src.zip"
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}.scr"
+
+src_prepare() {
+ epatch "${FILESDIR}"/as-needed.patch
+ # Respect CC
+ sed -i \
+ -e 's:cc:$(CC):g' \
+ "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ MACHINEFLAGS="${LDFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/probe || die
+ dodoc "${S}"/README* || die
+}