summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-18 08:57:09 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-18 08:57:09 +0000
commitc14d4fda5374dee29bdd9309d19a2d07099972d1 (patch)
tree385883af9f453f49cd386e068d227b913cfa748e /sci-chemistry/prekin/prekin-6.51.081122.ebuild
parentqa: formatting (diff)
downloadgentoo-2-c14d4fda5374dee29bdd9309d19a2d07099972d1.tar.gz
gentoo-2-c14d4fda5374dee29bdd9309d19a2d07099972d1.tar.bz2
gentoo-2-c14d4fda5374dee29bdd9309d19a2d07099972d1.zip
New Addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/prekin/prekin-6.51.081122.ebuild')
-rw-r--r--sci-chemistry/prekin/prekin-6.51.081122.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-chemistry/prekin/prekin-6.51.081122.ebuild b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
new file mode 100644
index 000000000000..efe0dabb7ea2
--- /dev/null
+++ b/sci-chemistry/prekin/prekin-6.51.081122.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/prekin/prekin-6.51.081122.ebuild,v 1.1 2010/07/18 08:57:09 jlec Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils multilib
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="Prepares molecular kinemages (input files for Mage & KiNG) from PDB-format coordinate files"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/prekin.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/prekin/${MY_P}.src.tgz"
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ X? ( x11-libs/openmotif )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ sed \
+ -e 's:cc:$(CC):g' \
+ -e "s:GENTOOLIBDIR:$(get_libdir):g" \
+ "${S}"/Makefile.linux > Makefile
+}
+
+src_compile() {
+ local mytarget
+
+ if use X; then
+ mytarget="${PN}"
+ else
+ mytarget="nogui"
+ fi
+
+ emake \
+ CC="$(tc-getCC)" \
+ ${mytarget} || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/prekin || die "dobin failed"
+}