summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-29 08:09:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-29 08:09:04 +0000
commitad697834bcf62c33af4ae39cf8d977efe31ea252 (patch)
treeffa6e26d3346ad4f059c1fed9f34f80736e467ad /sci-chemistry/pointless
parentVersion bumped. (diff)
downloadgentoo-2-ad697834bcf62c33af4ae39cf8d977efe31ea252.tar.gz
gentoo-2-ad697834bcf62c33af4ae39cf8d977efe31ea252.tar.bz2
gentoo-2-ad697834bcf62c33af4ae39cf8d977efe31ea252.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/pointless')
-rw-r--r--sci-chemistry/pointless/ChangeLog8
-rw-r--r--sci-chemistry/pointless/pointless-1.5.2.ebuild (renamed from sci-chemistry/pointless/pointless-1.4.8.ebuild)13
2 files changed, 17 insertions, 4 deletions
diff --git a/sci-chemistry/pointless/ChangeLog b/sci-chemistry/pointless/ChangeLog
index 171489d1bb84..d508c8b1eb97 100644
--- a/sci-chemistry/pointless/ChangeLog
+++ b/sci-chemistry/pointless/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pointless
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/ChangeLog,v 1.4 2010/05/16 11:50:16 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/ChangeLog,v 1.5 2010/05/29 08:09:04 jlec Exp $
+
+*pointless-1.5.2 (29 May 2010)
+
+ 29 May 2010; Justin Lecher <jlec@gentoo.org> -pointless-1.4.8.ebuild,
+ +pointless-1.5.2.ebuild:
+ Version Bump
*pointless-1.5.1 (16 May 2010)
diff --git a/sci-chemistry/pointless/pointless-1.4.8.ebuild b/sci-chemistry/pointless/pointless-1.5.2.ebuild
index 32789d380ff3..b46b1b613ea5 100644
--- a/sci-chemistry/pointless/pointless-1.4.8.ebuild
+++ b/sci-chemistry/pointless/pointless-1.5.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/pointless-1.4.8.ebuild,v 1.1 2010/02/06 22:28:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/pointless-1.5.2.ebuild,v 1.1 2010/05/29 08:09:04 jlec Exp $
-inherit toolchain-funcs multilib
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
DESCRIPTION="Scores crystallographic Laue and space groups"
HOMEPAGE="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/pointless.html"
@@ -21,6 +23,11 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}"
+src_prepare() {
+ epatch "${FILESDIR}"/1.5.1-gcc4.4.patch
+#epatch "${FILESDIR}"/${PV}-linking.patch
+}
+
src_compile() {
emake \
-f Makefile.make \
@@ -35,7 +42,7 @@ src_compile() {
ICCP4=-I"${EPREFIX}"/usr/include/ccp4 \
ICLPR="-I${EPREFIX}/usr/include -I${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_sources -I${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/include" \
LTBX="-L${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/lib -lcctbx" \
- LCCP4="$(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -L${EPREFIX}/usr/$(get_libdir) -lgfortran -lgfortranbegin -lccp4c -lccp4f -lm" \
+ SLIB="$(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -L${EPREFIX}/usr/$(get_libdir) -lgfortran -lgfortranbegin" \
|| die
}