summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-26 08:08:15 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-26 08:08:15 +0000
commit9cc3479ac9de9bd2711f937b82160760d59bc4b0 (patch)
treea7e368222b177c69dbba768417e71e3e2e3ea6dd /sci-chemistry/pointless
parentVersion bump. Fixes compilation with xerces-c-3.1.0. (diff)
downloadgentoo-2-9cc3479ac9de9bd2711f937b82160760d59bc4b0.tar.gz
gentoo-2-9cc3479ac9de9bd2711f937b82160760d59bc4b0.tar.bz2
gentoo-2-9cc3479ac9de9bd2711f937b82160760d59bc4b0.zip
Version bump
(Portage version: 2.2_rc63/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/pointless')
-rw-r--r--sci-chemistry/pointless/ChangeLog8
-rw-r--r--sci-chemistry/pointless/pointless-1.4.9.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sci-chemistry/pointless/ChangeLog b/sci-chemistry/pointless/ChangeLog
index 8c6bf4d220e3..0506df29ab20 100644
--- a/sci-chemistry/pointless/ChangeLog
+++ b/sci-chemistry/pointless/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pointless
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/ChangeLog,v 1.1 2010/02/06 22:28:23 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/ChangeLog,v 1.2 2010/02/26 08:08:15 jlec Exp $
+
+*pointless-1.4.9 (26 Feb 2010)
+
+ 26 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +pointless-1.4.9.ebuild:
+ Version Bump
*pointless-1.4.8 (06 Feb 2010)
diff --git a/sci-chemistry/pointless/pointless-1.4.9.ebuild b/sci-chemistry/pointless/pointless-1.4.9.ebuild
new file mode 100644
index 000000000000..cfaec67b4796
--- /dev/null
+++ b/sci-chemistry/pointless/pointless-1.4.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pointless/pointless-1.4.9.ebuild,v 1.1 2010/02/26 08:08:15 jlec Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Scores crystallographic Laue and space groups"
+HOMEPAGE="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/pointless.html"
+SRC_URI="ftp://ftp.mrc-lmb.cam.ac.uk/pub/pre/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ccp4"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ sci-chemistry/ccp4-apps
+ >=sci-libs/ccp4-libs-6.1.3
+ sci-libs/cctbx"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake \
+ -f Makefile.make \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ CLIB="${EPREFIX}/usr/$(get_libdir)" \
+ CCTBX_sources="${EPREFIX}"/usr/$(get_libdir)/cctbx/cctbx_sources \
+ CCTBX_VERSION=2009 \
+ ICCP4=-I"${EPREFIX}"/usr/include/ccp4 \
+ ICLPR="-I${EPREFIX}/usr/include -I${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_sources -I${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/include" \
+ LTBX="-L${EPREFIX}/usr/$(get_libdir)/cctbx/cctbx_build/lib -lcctbx" \
+ LCCP4="$(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -L${EPREFIX}/usr/$(get_libdir) -lgfortran -lgfortranbegin -lccp4c -lccp4f -lm" \
+ || die
+}
+
+src_install() {
+ dobin pointless othercell || die
+}