summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2009-02-28 20:49:33 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2009-02-28 20:49:33 +0000
commit53f9ca874cd764ebcdc2423800666b875a678490 (patch)
treed16f7be506db24f9c96485a6a17b54d666fae330 /sci-chemistry/openbabel
parentInitial import. Fixes #207716. Ebuild contributed by Pawel Hajdan Jr. (diff)
downloadgentoo-2-53f9ca874cd764ebcdc2423800666b875a678490.tar.gz
gentoo-2-53f9ca874cd764ebcdc2423800666b875a678490.tar.bz2
gentoo-2-53f9ca874cd764ebcdc2423800666b875a678490.zip
Integrated some improvements from My Th <rei4dan@gmail.com> in bug 212212.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/openbabel')
-rw-r--r--sci-chemistry/openbabel/ChangeLog8
-rw-r--r--sci-chemistry/openbabel/openbabel-2.2.1_beta3-r1.ebuild70
-rw-r--r--sci-chemistry/openbabel/openbabel-2.2.1_beta3.ebuild32
3 files changed, 77 insertions, 33 deletions
diff --git a/sci-chemistry/openbabel/ChangeLog b/sci-chemistry/openbabel/ChangeLog
index 716ff83c7c0b..ec037c29ba04 100644
--- a/sci-chemistry/openbabel/ChangeLog
+++ b/sci-chemistry/openbabel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/openbabel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.20 2009/02/18 21:44:47 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/ChangeLog,v 1.21 2009/02/28 20:49:33 cryos Exp $
+
+*openbabel-2.2.1_beta3-r1 (28 Feb 2009)
+
+ 28 Feb 2009; Marcus D. Hanwell <cryos@gentoo.org>
+ -openbabel-2.2.1_beta3.ebuild, +openbabel-2.2.1_beta3-r1.ebuild:
+ Integrated some improvements from My Th <rei4dan@gmail.com> in bug 212212.
*openbabel-2.2.1_beta3 (18 Feb 2009)
diff --git a/sci-chemistry/openbabel/openbabel-2.2.1_beta3-r1.ebuild b/sci-chemistry/openbabel/openbabel-2.2.1_beta3-r1.ebuild
new file mode 100644
index 000000000000..d2c526d6160c
--- /dev/null
+++ b/sci-chemistry/openbabel/openbabel-2.2.1_beta3-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.2.1_beta3-r1.ebuild,v 1.1 2009/02/28 20:49:33 cryos Exp $
+
+EAPI=1
+
+inherit eutils
+
+MY_PV="2.2.1b3-20090215-r2890"
+
+DESCRIPTION="interconverts file formats used in molecular modeling"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/${PN}-${MY_PV}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc"
+
+RDEPEND="!sci-chemistry/babel
+ >=dev-libs/libxml2-2.6.5
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.33.1
+ dev-lang/perl
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.2.0-doxyfile.patch"
+}
+
+src_compile() {
+ econf \
+ --enable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake docs || "make docs failed"
+ fi
+}
+
+src_test() {
+ emake check || die "make check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ cd doc
+ dohtml *.html *.png
+ dodoc *.inc README* *.inc *.mol2
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/API/html
+ insinto /usr/share/doc/${PF}/API/html
+ cd API/html
+ doins *
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "This version of OpenBabel includes InChI version 1 (software version"
+ elog "1.02_beta). It does not produce Standard InChI/InChIKey."
+ elog "To get Standard InChI/InChIKey software version 1.02 must be used."
+}
diff --git a/sci-chemistry/openbabel/openbabel-2.2.1_beta3.ebuild b/sci-chemistry/openbabel/openbabel-2.2.1_beta3.ebuild
deleted file mode 100644
index b70f072b9a31..000000000000
--- a/sci-chemistry/openbabel/openbabel-2.2.1_beta3.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.2.1_beta3.ebuild,v 1.1 2009/02/18 21:44:47 cryos Exp $
-
-inherit eutils
-
-MY_PV="2.2.1b3-20090215-r2890"
-
-DESCRIPTION="interconverts file formats used in molecular modeling"
-HOMEPAGE="http://openbabel.sourceforge.net/"
-SRC_URI="mirror://sourceforge/openbabel/${PN}-${MY_PV}.tar.gz"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-RDEPEND="!sci-chemistry/babel
- dev-libs/libxml2"
-DEPEND="${RDEPEND}
- dev-libs/boost
- dev-lang/perl"
-
-S=${WORKDIR}/${PN}-${MY_PV}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed."
- dodoc AUTHORS ChangeLog NEWS README THANKS
- cd doc
- dohtml *.html *.png
- dodoc *.inc README* *.inc *.mol2
-}