summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-01-06 15:24:26 +0000
committerJustin Lecher <jlec@gentoo.org>2014-01-06 15:24:26 +0000
commit288910f09e66cf5831bc62c502013a931b91cca5 (patch)
treebd5b8a426e972c8f0bf93a2da5adb1f18c043843 /sci-chemistry/massxpert
parentAdd ~x86-fbsd wrt bug #497068 (diff)
downloadgentoo-2-288910f09e66cf5831bc62c502013a931b91cca5.tar.gz
gentoo-2-288910f09e66cf5831bc62c502013a931b91cca5.tar.bz2
gentoo-2-288910f09e66cf5831bc62c502013a931b91cca5.zip
sci-chemistry/massxpert: Drop old; punt base.eclass
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/massxpert')
-rw-r--r--sci-chemistry/massxpert/ChangeLog12
-rw-r--r--sci-chemistry/massxpert/files/massxpert-1.7.6-gcc43.patch28
-rw-r--r--sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch91
-rw-r--r--sci-chemistry/massxpert/massxpert-1.7.6.ebuild62
-rw-r--r--sci-chemistry/massxpert/massxpert-2.0.5.ebuild13
-rw-r--r--sci-chemistry/massxpert/massxpert-3.4.0.ebuild56
-rw-r--r--sci-chemistry/massxpert/metadata.xml13
7 files changed, 169 insertions, 106 deletions
diff --git a/sci-chemistry/massxpert/ChangeLog b/sci-chemistry/massxpert/ChangeLog
index b1ee9c857c34..b4399613c078 100644
--- a/sci-chemistry/massxpert/ChangeLog
+++ b/sci-chemistry/massxpert/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/massxpert
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/ChangeLog,v 1.13 2013/06/19 04:10:42 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/ChangeLog,v 1.14 2014/01/06 15:24:25 jlec Exp $
+
+*massxpert-3.4.0 (06 Jan 2014)
+
+ 06 Jan 2014; Justin Lecher <jlec@gentoo.org> -massxpert-1.7.6.ebuild,
+ massxpert-2.0.5.ebuild, +massxpert-3.4.0.ebuild,
+ -files/massxpert-1.7.6-gcc43.patch, +files/massxpert-3.4.0-gentoo.patch,
+ metadata.xml:
+ Drop old; punt base.eclass
19 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Changed herd to sci-chemistry
diff --git a/sci-chemistry/massxpert/files/massxpert-1.7.6-gcc43.patch b/sci-chemistry/massxpert/files/massxpert-1.7.6-gcc43.patch
deleted file mode 100644
index 44a46e202adb..000000000000
--- a/sci-chemistry/massxpert/files/massxpert-1.7.6-gcc43.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- lib/userSpec.cpp.orig 2008-07-15 22:01:23.000000000 +0200
-+++ lib/userSpec.cpp 2008-07-15 22:02:22.000000000 +0200
-@@ -41,7 +41,8 @@
-
-
- /////////////////////// Std includes
--//#include <stdlib.h>
-+#include <cstdlib>
-+
-
-
- /////////////////////// Local includes
-
-
---- gui/isotopicPatternCalculationDlg.cpp.orig 2008-07-15 22:09:07.000000000 +0200
-+++ gui/isotopicPatternCalculationDlg.cpp 2008-07-15 22:09:56.000000000 +0200
-@@ -61,8 +61,10 @@
-
-
- /////////////////////// Std includes
--#include <math.h>
-+#include <cmath>
- #include <algorithm>
-+#include <limits>
-+
-
-
- /////////////////////// Local includes
diff --git a/sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch b/sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch
new file mode 100644
index 000000000000..fc0fc4f606cf
--- /dev/null
+++ b/sci-chemistry/massxpert/files/massxpert-3.4.0-gentoo.patch
@@ -0,0 +1,91 @@
+ CMakeLists.txt | 20 ++++----------------
+ gui/configurationSettingsDlg.cpp | 10 ++++------
+ 2 files changed, 8 insertions(+), 22 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fec954b..b87d157 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -24,10 +24,10 @@ SET (CMAKE_VERBOSE_MAKEFILE ON)
+ #############################################################
+ # Enable warnings and treat them as errors, on GNU/Linux only
+ IF (UNIX)
+- SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall -Werror.")
++ SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall.")
+
+ IF (PEDANTIC)
+- ADD_DEFINITIONS (-Wall -Werror)
++ ADD_DEFINITIONS (-Wall)
+ ENDIF (PEDANTIC)
+ ENDIF (UNIX)
+
+@@ -64,12 +64,12 @@ IF (UNIX AND NOT APPLE)
+ # Plugin-specific stuff, some distros set CMAKE_INSTALL_LIBDIR to
+ # /usr/lib64 (Fedora64, for example)
+ IF (NOT CMAKE_INSTALL_LIBDIR)
+- SET (CMAKE_INSTALL_LIBDIR ${CMAKE_INSTALL_PREFIX}/lib)
++ SET (CMAKE_INSTALL_LIBDIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX})
+ ENDIF (NOT CMAKE_INSTALL_LIBDIR)
+ SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_LIBDIR}/massxpert/plugins)
+
+ SET (MASSXPERT_LOCALE_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert/locales)
+- SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert)
++ SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert-${VERSION})
+ SET (MASSXPERT_USERMAN_DIR ${MASSXPERT_DOC_DIR}/usermanual)
+ ENDIF (UNIX AND NOT APPLE)
+
+@@ -144,10 +144,6 @@ IF (${BUILD_PROGRAM})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The desktop file
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert.desktop
+@@ -185,10 +181,6 @@ IF (${BUILD_DATA})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (data)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-data.7
+@@ -219,10 +211,6 @@ IF (${BUILD_USERMANUAL})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (user manual)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-doc.7
+diff --git a/gui/configurationSettingsDlg.cpp b/gui/configurationSettingsDlg.cpp
+index bf595d5..82cad21 100644
+--- a/gui/configurationSettingsDlg.cpp
++++ b/gui/configurationSettingsDlg.cpp
+@@ -309,13 +309,11 @@ namespace massXpert
+ bool
+ ConfigurationSettingsDlg::checkLocalizationDir(const QDir &dir)
+ {
+- // At the moment there is the french translation: massxpert_fr.qm
++ // Gentoo provides optional installing of translations.
++ // If you decide not to have translations, then this check
++ // would fail.
+
+- QString filePath(dir.absolutePath() +
+- QDir::separator() +
+- "massxpert_fr.qm");
+-
+- return QFile::exists(filePath);
++ return true;
+ }
+
+
diff --git a/sci-chemistry/massxpert/massxpert-1.7.6.ebuild b/sci-chemistry/massxpert/massxpert-1.7.6.ebuild
deleted file mode 100644
index 1ca048b8e286..000000000000
--- a/sci-chemistry/massxpert/massxpert-1.7.6.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-1.7.6.ebuild,v 1.7 2013/03/02 23:18:07 hwoarang Exp $
-
-EAPI=2
-
-inherit base eutils flag-o-matic cmake-utils
-
-DESCRIPTION="A software suite to predict/analyze mass spectrometric data on (bio)polymers."
-HOMEPAGE="http://massxpert.org/wiki/"
-SRC_URI="http://download.tuxfamily.org/massxpert/source/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-RDEPEND="
- dev-qt/qtgui:4[accessibility]
- dev-qt/qtsvg:4
- dev-qt/qtxmlpatterns:4
- x11-libs/libSM
- x11-libs/libICE
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXrandr
- x11-libs/libXcursor
- x11-libs/libXext
- x11-libs/libXt
- x11-libs/libXfixes
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-libs/libX11
- sys-libs/zlib
- media-libs/freetype
- media-libs/fontconfig
- media-libs/nas
- media-libs/libpng
- dev-libs/libxml2:2"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}"/"${P}"
-CMAKE_IN_SOURCE_BUILD="true"
-
-PATCHES=( "${FILESDIR}/${P}-gcc43.patch" )
-
-src_compile() {
- sed -i \
- -e "s:/lib/:/$(get_libdir)/:g" \
- -e "s:ADD_DEFINITIONS (-Wall -Werror):ADD_DEFINITIONS (-Wall):" \
- CMakeLists.txt || \
- die "404. File not found while sedding."
-
- tc-export CC CXX LD
- mycmakeargs="-D__LIB=$(get_libdir)"
-
- if use amd64 ; then
- append-flags -fPIC
- fi
-
- cmake-utils_src_compile
-}
diff --git a/sci-chemistry/massxpert/massxpert-2.0.5.ebuild b/sci-chemistry/massxpert/massxpert-2.0.5.ebuild
index 01f2f914a1ea..b0b1b7362cf4 100644
--- a/sci-chemistry/massxpert/massxpert-2.0.5.ebuild
+++ b/sci-chemistry/massxpert/massxpert-2.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-2.0.5.ebuild,v 1.3 2013/03/02 23:18:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-2.0.5.ebuild,v 1.4 2014/01/06 15:24:25 jlec Exp $
EAPI="2"
@@ -40,12 +40,11 @@ src_prepare() {
}
src_configure() {
- append-ldflags $(no-as-needed)
-
- mycmakeargs="
+ local mycmakeargs=(
-DBUILD_PROGRAM=1
- -DBUILD_DATA=1"
- use doc && mycmakeargs="${mycmakeargs} -DBUILD_USERMANUAL=1"
+ -DBUILD_DATA=1
+ )
+ use doc && mycmakeargs+=( -DBUILD_USERMANUAL=1 )
cmake-utils_src_configure
}
diff --git a/sci-chemistry/massxpert/massxpert-3.4.0.ebuild b/sci-chemistry/massxpert/massxpert-3.4.0.ebuild
new file mode 100644
index 000000000000..9fb491e75931
--- /dev/null
+++ b/sci-chemistry/massxpert/massxpert-3.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/massxpert/massxpert-3.4.0.ebuild,v 1.1 2014/01/06 15:24:25 jlec Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Software suite to predict/analyze mass spectrometric data on (bio)polymers"
+HOMEPAGE="http://massxpert.org"
+SRC_URI="http://download.tuxfamily.org/${PN}/source/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-qt/qtsvg:4[debug?]"
+DEPEND="${DEPEND}
+ doc? ( virtual/latex-base )"
+
+MASSXPERT_LANGS="fr"
+
+for L in ${MASSXPERT_LANGS}; do
+ IUSE="${IUSE} linguas_${L}"
+done
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ local langs=
+ for lingua in ${LINGUAS}; do
+ if has ${lingua} ${MASSXPERT_LANGS}; then
+ langs="${langs} ${PN}_${lingua}.qm"
+ fi
+ done
+
+ sed -i -e "s/\(SET (massxpert_TRANSLATIONS \).*/\1${langs})/" \
+ gui/CMakeLists.txt || die "setting up translations failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PROGRAM=1
+ -DBUILD_DATA=1
+ )
+ use doc && mycmakeargs+=( -DBUILD_USERMANUAL=1 )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doicon "gui/images/${PN}-icon-32.xpm"
+ dodoc TODO
+}
diff --git a/sci-chemistry/massxpert/metadata.xml b/sci-chemistry/massxpert/metadata.xml
index 8f2a1a4dac00..a4137981114b 100644
--- a/sci-chemistry/massxpert/metadata.xml
+++ b/sci-chemistry/massxpert/metadata.xml
@@ -1,13 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
-<email>je_fro@gentoo.org</email>
-<name>Jeff Gardner</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>je_fro@gentoo.org</email>
+ <name>Jeff Gardner</name>
+ </maintainer>
+ <longdescription lang="en">
Prediction and analysis of mass spectrometric data for proteomic projects.
</longdescription>
</pkgmetadata>
-