summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2007-01-07 02:21:35 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2007-01-07 02:21:35 +0000
commit0cc00a03a55107738d09ab6e703d549825a0e4eb (patch)
treedd400b20a63735b7ad2791e77abb177e1f6354f1 /sci-chemistry/gromacs/gromacs-3.2.1.ebuild
parentQA: Removed unused versions. (diff)
downloadgentoo-2-0cc00a03a55107738d09ab6e703d549825a0e4eb.tar.gz
gentoo-2-0cc00a03a55107738d09ab6e703d549825a0e4eb.tar.bz2
gentoo-2-0cc00a03a55107738d09ab6e703d549825a0e4eb.zip
QA: Removed unused versions.
(Portage version: 2.1.2_pre2-r1) (Signed Manifest commit)
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-3.2.1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-3.2.1.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/sci-chemistry/gromacs/gromacs-3.2.1.ebuild b/sci-chemistry/gromacs/gromacs-3.2.1.ebuild
deleted file mode 100644
index 6631cbe813d4..000000000000
--- a/sci-chemistry/gromacs/gromacs-3.2.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.2.1.ebuild,v 1.3 2006/06/25 00:28:25 spyderous Exp $
-
-inherit eutils
-
-IUSE="mpi xml"
-
-DESCRIPTION="The ultimate molecular dynamics simulation package"
-SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${P}.tar.gz"
-HOMEPAGE="http://www.gromacs.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 amd64"
-
-#mpi is a local USE flag now
-#May become official when situation with mpich is cleared (now the only mpi implementation awailable is lam-mpi)
-DEPEND="=sci-libs/fftw-2.1*
- mpi? ( >=sys-cluster/lam-mpi-6.5.6 )
- >=sys-devel/binutils-2.10.91.0.2
- app-shells/tcsh
- xml? ( dev-libs/libxml2 )"
-
-src_compile() {
-#!!!Please note!!!
-#for troublesome work gromacs should be compiled with the same mpi setting as fftw.
-#Unfortunately portage cannot trace optional dependencies of dependencies at present.
-#Until this (planned) feature is completed, please try to do corresponding check yourself.
- local myconf
-
- # Enable asm on Alphas
- if [ "${ARCH}" = "alpha" ]
- then
- myconf="${myconf} --enable-axp-asm"
- fi
-
- # static should work but something's broken.
- # gcc spec file may be screwed up.
- # Static linking should try -lgcc instead of -lgcc_s.
- # For more info:
- # http://lists.debian.org/debian-gcc/2002/debian-gcc-200201/msg00150.html
- econf \
- --enable-fortran \
- --datadir=/usr/share/${P} \
- --bindir=/usr/bin \
- --libdir=/usr/lib \
- `use_with xml` \
- `use_enable mpi` \
- ${myconf} || die "configure failed"
-
- # `use_enable static all-static` \
-
- emake || die
-}
-
-src_install () {
- make DESTDIR=${D} install || die
-
- # Install documentation.
- dodoc AUTHORS COPYING INSTALL README
-
- #move html docs under /usr/share/doc
- #and leave examples and templates under /usr/gromacs...
- mv ${D}/usr/share/${P}/html ${D}/usr/share/doc/${PF}
-}