summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-02 05:57:09 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-02 05:57:09 +0000
commit7b94a9fee7666503636afd5a531bd5c9280ae22b (patch)
treefbf73a990cdd8c63d5cbb633e009b09939251a10 /sci-chemistry/ghemical/ghemical-3.0.0.ebuild
parentBump (diff)
downloadgentoo-2-7b94a9fee7666503636afd5a531bd5c9280ae22b.tar.gz
gentoo-2-7b94a9fee7666503636afd5a531bd5c9280ae22b.tar.bz2
gentoo-2-7b94a9fee7666503636afd5a531bd5c9280ae22b.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-chemistry/ghemical/ghemical-3.0.0.ebuild')
-rw-r--r--sci-chemistry/ghemical/ghemical-3.0.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-chemistry/ghemical/ghemical-3.0.0.ebuild b/sci-chemistry/ghemical/ghemical-3.0.0.ebuild
new file mode 100644
index 000000000000..5e2e1220d197
--- /dev/null
+++ b/sci-chemistry/ghemical/ghemical-3.0.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ghemical/ghemical-3.0.0.ebuild,v 1.1 2013/02/02 05:57:09 patrick Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="openbabel seamonkey threads"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ sci-chemistry/mpqc
+ >=sci-libs/libghemical-3.0.0
+ >=x11-libs/liboglappth-1.0.0
+ virtual/opengl
+ x11-libs/pango
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ openbabel? ( sci-chemistry/openbabel )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/2.99.2-docs.patch
+ eautoreconf
+}
+
+src_configure() {
+# With amd64, if you want gamess I recommend adding gamess and gtk-gamess to package.provided for now.
+
+# Change the built-in help browser.
+ if use seamonkey ; then
+ sed -i -e 's|mozilla|seamonkey|g' src/gtk_app.cpp || die "sed failed for seamonkey!"
+ else
+ sed -i -e 's|mozilla|firefox|g' src/gtk_app.cpp || die "sed failed for firefox!"
+ fi
+
+ econf \
+ $(use_enable openbabel) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ make_desktop_entry /usr/bin/ghemical Ghemical /usr/share/ghemical/${PV}/pixmaps/ghemical.png
+}