summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-17 10:53:34 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-17 10:53:34 +0000
commita5077d09ee76d17cad9ce76145e1179d3557568b (patch)
tree8dacb76913f249c50e272a95ef45f4994c4c88b7 /sci-chemistry/coot
parentDon't hardcode libpng12 in flam3.pc wrt #320121 by Diego E. Pettenò. (diff)
downloadgentoo-2-a5077d09ee76d17cad9ce76145e1179d3557568b.tar.gz
gentoo-2-a5077d09ee76d17cad9ce76145e1179d3557568b.tar.bz2
gentoo-2-a5077d09ee76d17cad9ce76145e1179d3557568b.zip
Fix for test, #318605
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/coot')
-rw-r--r--sci-chemistry/coot/ChangeLog6
-rw-r--r--sci-chemistry/coot/coot-0.6.1.ebuild4
-rw-r--r--sci-chemistry/coot/coot-0.6.ebuild4
3 files changed, 11 insertions, 3 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index 48e64b6093fd..38c42bae8e5f 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/coot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.24 2010/05/17 10:30:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/ChangeLog,v 1.25 2010/05/17 10:53:34 jlec Exp $
+
+ 17 May 2010; Justin Lecher <jlec@gentoo.org> coot-0.6.ebuild,
+ coot-0.6.1.ebuild:
+ Fix for test, #318605
*coot-0.6.1 (17 May 2010)
diff --git a/sci-chemistry/coot/coot-0.6.1.ebuild b/sci-chemistry/coot/coot-0.6.1.ebuild
index d1c572cdc20c..8926e68b2c03 100644
--- a/sci-chemistry/coot/coot-0.6.1.ebuild
+++ b/sci-chemistry/coot/coot-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.1.ebuild,v 1.1 2010/05/17 10:30:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.1.ebuild,v 1.2 2010/05/17 10:53:34 jlec Exp $
EAPI="3"
@@ -117,6 +117,7 @@ src_test() {
export PYTHONPATH="${COOT_PYTHON_DIR}:${PYTHONPATH}"
export PYTHONHOME="${EPREFIX}"/usr
export CCP4_SCR="${T}"/coot_test
+ export CLIBD_MON="${EPREFIX}/usr/share/ccp4/data/monomers/"
export COOT_TEST_DATA_DIR="${WORKDIR}"/data/greg-data
@@ -141,6 +142,7 @@ src_test() {
einfo "PYTHONPATH $PYTHONPATH"
einfo "PYTHONHOME $PYTHONHOME"
einfo "CCP4_SCR ${CCP4_SCR}"
+ einfo "CLIBD_MON ${CLIBD_MON}"
"${S}"/src/coot-real --no-graphics --script command-line-greg.scm || die
}
diff --git a/sci-chemistry/coot/coot-0.6.ebuild b/sci-chemistry/coot/coot-0.6.ebuild
index 091c0515dea4..89b36df577ac 100644
--- a/sci-chemistry/coot/coot-0.6.ebuild
+++ b/sci-chemistry/coot/coot-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.ebuild,v 1.4 2010/04/22 22:55:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/coot/coot-0.6.ebuild,v 1.5 2010/05/17 10:53:34 jlec Exp $
EAPI="3"
@@ -117,6 +117,7 @@ src_test() {
export PYTHONPATH="${COOT_PYTHON_DIR}:${PYTHONPATH}"
export PYTHONHOME="${EPREFIX}"/usr
export CCP4_SCR="${T}"/coot_test
+ export CLIBD_MON="${EPREFIX}/usr/share/ccp4/data/monomers/"
export COOT_TEST_DATA_DIR="${WORKDIR}"/data/greg-data
@@ -141,6 +142,7 @@ src_test() {
einfo "PYTHONPATH $PYTHONPATH"
einfo "PYTHONHOME $PYTHONHOME"
einfo "CCP4_SCR ${CCP4_SCR}"
+ einfo "CLIBD_MON ${CLIBD_MON}"
"${S}"/src/coot-real --no-graphics --script command-line-greg.scm || die
}