summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-08-16 06:05:12 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-08-16 06:05:12 +0000
commitd05d54ca97ad372edc5f70605f46e36a9a02758a (patch)
tree5c69b83a27636edde0c6f962b5057066ebe3abfd /sci-chemistry/coot/files
parentRemove vulnerable version. (diff)
downloadgentoo-2-d05d54ca97ad372edc5f70605f46e36a9a02758a.tar.gz
gentoo-2-d05d54ca97ad372edc5f70605f46e36a9a02758a.tar.bz2
gentoo-2-d05d54ca97ad372edc5f70605f46e36a9a02758a.zip
Bump. Reads CNS maps, handles anisotropy better, other bugfixes and features.
(Portage version: 2.1.3.5)
Diffstat (limited to 'sci-chemistry/coot/files')
-rw-r--r--sci-chemistry/coot/files/0.3.3-as-needed.patch464
-rw-r--r--sci-chemistry/coot/files/0.3.3-link-against-guile-gtk-properly.patch15
-rw-r--r--sci-chemistry/coot/files/digest-coot-0.3.33
3 files changed, 482 insertions, 0 deletions
diff --git a/sci-chemistry/coot/files/0.3.3-as-needed.patch b/sci-chemistry/coot/files/0.3.3-as-needed.patch
new file mode 100644
index 000000000000..6dec443dd231
--- /dev/null
+++ b/sci-chemistry/coot/files/0.3.3-as-needed.patch
@@ -0,0 +1,464 @@
+diff -urN coot-0.3.3.orig/analysis/Makefile.am coot-0.3.3/analysis/Makefile.am
+--- coot-0.3.3.orig/analysis/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/analysis/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -9,6 +9,7 @@
+ $(MMDB_CXXFLAGS)
+
+ libcoot_analysis_la_SOURCES = bfkurt.cc
++libcoot_analysis_la_LIBADD = $(top_builddir)/coot-utils/libcoot-coord-utils.la
+
+ bin_PROGRAMS = bfactan
+
+@@ -16,7 +17,6 @@
+
+ bfactan_LDADD = \
+ libcoot-analysis.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(CLIPPER_LIBS) \
+diff -urN coot-0.3.3.orig/coords/Makefile.am coot-0.3.3/coords/Makefile.am
+--- coot-0.3.3.orig/coords/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/coords/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -37,4 +37,6 @@
+ libcoot_coords_la_SOURCES = Bond_lines.cc Cartesian.cc cos-sin.cc \
+ mmdb-extras.cc utils.cc mmdb.cc mmdb-crystal.cc \
+ Bond_lines_ext.cc coot-close.cc
+-
++libcoot_coords_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/mini-mol/libcoot-mini-mol.la
+diff -urN coot-0.3.3.orig/coot-surface/Makefile.am coot-0.3.3/coot-surface/Makefile.am
+--- coot-0.3.3.orig/coot-surface/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/coot-surface/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -25,3 +25,4 @@
+
+ libcoot_surface_la_SOURCES = \
+ coot-surface.cc coot-surface.hh rgbreps.cc rgbreps.h
++libcoot_surface_la_LIBADD = $(top_builddir)/surface/libccp4mg-surface.la
+diff -urN coot-0.3.3.orig/coot-utils/Makefile.am coot-0.3.3/coot-utils/Makefile.am
+--- coot-0.3.3.orig/coot-utils/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/coot-utils/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -39,9 +39,11 @@
+
+ # for pure coordinates (mmdb) things
+ libcoot_coord_utils_la_SOURCES = coot-coord-utils.cc
++libcoot_coord_utils_la_LIBADD = $(CLIPPER_LIBS) libcoot-utils.la
+
+ # shelx
+ libcoot_shelx_la_SOURCES = coot-shelx-ins.cc
++libcoot_shelx_la_LIBADD = $(MMDB_LIBS) libcoot-coord-utils.la
+
+ # for non-simple coordinates things
+ libcoot_coord_extras_la_SOURCES = coot-coord-extras.cc coot-coord-lsq.cc
+@@ -51,21 +53,20 @@
+
+ # for map things that need mmdb, clipper, gsl and other things
+ libcoot_map_heavy_la_SOURCES = coot-map-heavy.cc coot-fffear.cc
++libcoot_map_heavy_la_LIBADD = $(GSL_LIBS)
+
+ noinst_PROGRAMS = testshelxreader testcootutils
+
+ testshelxreader_SOURCES = test-shelx-reader.cc
+ testshelxreader_LDADD = \
+ ./libcoot-shelx.la \
+- ./libcoot-coord-utils.la \
+- ./libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ ./libcoot-utils.la
+
+ testcootutils_SOURCES = test-utils.cc
+ testcootutils_LDADD = \
+ ./libcoot-shelx.la \
+ ./libcoot-coord-utils.la \
+ ./libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+
+
+diff -urN coot-0.3.3.orig/geometry/Makefile.am coot-0.3.3/geometry/Makefile.am
+--- coot-0.3.3.orig/geometry/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/geometry/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -34,6 +34,9 @@
+ libcoot_geometry_a_sources = protein-geometry.cc protein-geometry-mmdb.cc
+
+ libcoot_geometry_la_SOURCES = $(libcoot_geometry_a_sources)
++libcoot_geometry_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-utils.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ # libcoot_geometry_la_CXXFLAGS = -g -O1
+
+@@ -41,6 +44,4 @@
+
+ test_geometry_SOURCES = test-geometry.cc
+
+-test_geometry_LDADD = ./libcoot-geometry.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++test_geometry_LDADD = ./libcoot-geometry.la
+diff -urN coot-0.3.3.orig/high-res/Makefile.am coot-0.3.3/high-res/Makefile.am
+--- coot-0.3.3.orig/high-res/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/high-res/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -39,13 +39,16 @@
+
+ libcoot_high_res_la_SOURCES = high-res.cc coot-atom-graph.cc residue-distortions.cc \
+ sequence-assignment.cc
++libcoot_high_res_la_LIBADD = \
++ $(top_builddir)/ligand/libcoot-ligand.la \
++ $(top_builddir)/coot-utils/libcoot-map-utils.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ noinst_PROGRAMS = testatomgraph tracehighres testseqalign testseqassignment globularize_protein
+
+ testatomgraph_SOURCES = test-atom-graph.cc
+
+ testatomgraph_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+@@ -53,90 +56,73 @@
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
++ $(GSL_LIBS)
+
+ testseqassignment_SOURCES = testseqassignment.cc
+ testseqassignment_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
++ $(GSL_LIBS)
+
+ # tracehighres_LDFLAGS = -static
+ tracehighres_SOURCES = trace-high-res.cc
+ tracehighres_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
+-
++ $(GSL_LIBS)
+
+ testseqalign_SOURCES = testseqalign.cc
+
+ # why do we need to link with all this (junk)?
+ testseqalign_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
+-
++ $(GSL_LIBS)
+
+ globularize_protein_SOURCES = globularize.cc
+
+ globularize_protein_LDADD = libcoot-high-res.la \
+- $(top_builddir)/ligand/libcoot-ligand.la \
+ $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+- $(GSL_LIBS) \
+- $(CLIPPER_LIBS)
+-
++ $(GSL_LIBS)
+
+diff -urN coot-0.3.3.orig/ideal/Makefile.am coot-0.3.3/ideal/Makefile.am
+--- coot-0.3.3.orig/ideal/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/ideal/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -43,6 +43,12 @@
+ AM_CXXFLAGS = $(COOT_GSL_FLAGS) $(GSL_CFLAGS)
+
+ libcoot_ideal_la_SOURCES = simple-restraint.cc pepflip.cc regularize-minimol.cc
++libcoot_ideal_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-utils.la \
++ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
++ $(GSL_LIBS)
+
+ noinst_PROGRAMS = test-indexing with-geometry with-map
+ # bin_PROGRAMS =
+@@ -60,31 +66,20 @@
+ with_geometry_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ with_map_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+ test_indexing_LDADD = \
+ ./libcoot-ideal.la \
+ $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
++ $(CLIPPER_LIBS) $(MMDB_LIBS)
+
+diff -urN coot-0.3.3.orig/ligand/Makefile.am coot-0.3.3/ligand/Makefile.am
+--- coot-0.3.3.orig/ligand/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/ligand/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -42,6 +42,16 @@
+ libcoot_ligand_la_SOURCES = ligand.cc ligand-extras.cc residue_by_phi_psi.cc \
+ wiggly-ligand.cc monomer-utils.cc dunbrack.cc chi-angles-autogen.cc \
+ chi-angles.cc helix-placement.cc rigid-body.cc ideal-rna.cc
++libcoot_ligand_la_LIBADD = \
++ $(top_builddir)/ideal/libcoot-ideal.la \
++ $(top_builddir)/coords/libcoot-coords.la \
++ $(top_builddir)/coot-utils/libcoot-coord-extras.la \
++ $(top_builddir)/coot-utils/libcoot-map-utils.la \
++ $(top_builddir)/db-main/libcoot-db-main.la \
++ $(top_builddir)/coot-utils/libcoot-shelx.la \
++ $(top_builddir)/geometry/libcoot-geometry.la \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la
+
+ AM_CXXFLAGS = \
+ -DPKGDATADIR='"$(pkgdatadir)"' \
+@@ -59,35 +69,17 @@
+ test_random_SOURCES = test-random.cc
+ test_random_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ test_helix_placement_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+@@ -95,19 +87,10 @@
+
+ test_fffear_in_coot_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+ $(top_builddir)/coot-utils/libcoot-map-heavy.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+@@ -119,33 +102,15 @@
+
+ findligand_real_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ findwaters_real_LDADD = \
+ ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(top_builddir)/compat/libcoot-compat.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+@@ -166,17 +131,8 @@
+ testdunbrack_SOURCES = testdunbrack.cc
+
+ testdunbrack_LDADD = ./libcoot-ligand.la \
+- $(top_builddir)/ideal/libcoot-ideal.la \
+ $(top_builddir)/mini-mol/libcoot-mini-mol.la \
+- $(top_builddir)/geometry/libcoot-geometry.la \
+- $(top_builddir)/coords/libcoot-coords.la \
+- $(top_builddir)/ccp4mg-utils/libccp4mg-utils.la \
+- $(top_builddir)/coot-utils/libcoot-map-utils.la \
+- $(top_builddir)/db-main/libcoot-db-main.la \
+- $(top_builddir)/coot-utils/libcoot-coord-extras.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+ $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(top_builddir)/coot-utils/libcoot-shelx.la \
+ $(CLIPPER_LIBS) $(MMDB_LIBS) $(GSL_LIBS)
+
+ # lib coot-coords depends on mmdb, even though Cartesian doesn't
+diff -urN coot-0.3.3.orig/Makefile.am coot-0.3.3/Makefile.am
+--- coot-0.3.3.orig/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/Makefile.am 2007-08-15 21:09:11.000000000 -0700
+@@ -25,10 +25,10 @@
+
+ # see configure.in for po intl
+ SUBDIRS = auxil scheme python macros compat coot-utils surface coot-surface \
+- skeleton ccp4mg-utils density-contour coords angles \
+- mini-mol db-main geometry \
++ atom-utils skeleton ccp4mg-utils density-contour mini-mol coords angles \
++ db-main geometry \
+ ideal ligand high-res build \
+- analysis sequence-view tw atom-utils src doc
++ analysis sequence-view tw src doc
+
+ # po, no po today.
+
+diff -urN coot-0.3.3.orig/mini-mol/Makefile.am coot-0.3.3/mini-mol/Makefile.am
+--- coot-0.3.3.orig/mini-mol/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/mini-mol/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -32,8 +32,9 @@
+ testminimol_SOURCES = testminimol.cc
+
+ libcoot_mini_mol_la_SOURCES = mini-mol.cc mini-mol-utils.cc
++libcoot_mini_mol_la_LIBADD = \
++ $(top_builddir)/coot-utils/libcoot-coord-utils.la \
++ $(CLIPPER_LIBS)
+
+ testminimol_LDADD = libcoot-mini-mol.la \
+- $(top_builddir)/coot-utils/libcoot-coord-utils.la \
+- $(top_builddir)/coot-utils/libcoot-utils.la \
+- $(CLIPPER_LIBS) $(MMDB_LIBS)
++ $(MMDB_LIBS)
+diff -urN coot-0.3.3.orig/skeleton/Makefile.am coot-0.3.3/skeleton/Makefile.am
+--- coot-0.3.3.orig/skeleton/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/skeleton/Makefile.am 2007-08-15 17:20:44.000000000 -0700
+@@ -36,7 +36,7 @@
+
+
+ libcoot_skeleton_la_SOURCES = $(libskeleton_a_sources)
+-
++libcoot_skeleton_la_LIBADD = ../atom-utils/libcoot-atomutils.la
+
+ # bin_PROGRAMS = ncssearch test_various test_torsion test_theta_2
+
+diff -urN coot-0.3.3.orig/tw/Makefile.am coot-0.3.3/tw/Makefile.am
+--- coot-0.3.3.orig/tw/Makefile.am 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/tw/Makefile.am 2007-08-15 12:21:22.000000000 -0700
+@@ -39,15 +39,15 @@
+ include_HEADERS = coot-tw.hh
+
+ libcoot_tw_la_SOURCES = tw.cc
++libcoot_tw_la_LIBADD = \
++ $(GTKCANVAS_LIBS) \
++ @GTK_LIBS@
+
+ noinst_PROGRAMS = coot-tiddly
+
+ coot_tiddly_SOURCES = tiddly.cc
+
+-coot_tiddly_LDADD = libcoot-tw.la \
+- $(GTKCANVAS_LIBS) \
+- @GTK_LIBS@
+-
++coot_tiddly_LDADD = libcoot-tw.la
+
+ # cootsound_LDADD = -L/sw/lib -lvorbisfile -logg -lao
+
diff --git a/sci-chemistry/coot/files/0.3.3-link-against-guile-gtk-properly.patch b/sci-chemistry/coot/files/0.3.3-link-against-guile-gtk-properly.patch
new file mode 100644
index 000000000000..d0f57b287426
--- /dev/null
+++ b/sci-chemistry/coot/files/0.3.3-link-against-guile-gtk-properly.patch
@@ -0,0 +1,15 @@
+diff -urN coot-0.3.3.orig/macros/guile-gtk.m4 coot-0.3.3/macros/guile-gtk.m4
+--- coot-0.3.3.orig/macros/guile-gtk.m4 2007-08-15 12:20:04.000000000 -0700
++++ coot-0.3.3/macros/guile-gtk.m4 2007-08-15 12:20:32.000000000 -0700
+@@ -66,9 +66,9 @@
+ # we have the variable coot_gtk2 in configure.in, which is either TRUE or FALSE
+ # Let's use that here. Perhaps there is a better (set by gtk macro?) variable?
+ if test $coot_gtk2 = TRUE ; then
+- GUILE_GTK_LIBS=$guile_gtk_prefix/lib/libguilegtk-2.0.la
++ GUILE_GTK_LIBS="-L$guile_gtk_prefix/lib -lguilegtk-2.0"
+ else
+- GUILE_GTK_LIBS=$guile_gtk_prefix/lib/libguilegtk-1.2.la
++ GUILE_GTK_LIBS="-L$guile_gtk_prefix/lib -lguilegtk-1.2"
+ fi
+ # do we need to set this in fact?
+ GUILE_GTK_CFLAGS="-I$guile_gtk_prefix/include"
diff --git a/sci-chemistry/coot/files/digest-coot-0.3.3 b/sci-chemistry/coot/files/digest-coot-0.3.3
new file mode 100644
index 000000000000..4646e842f696
--- /dev/null
+++ b/sci-chemistry/coot/files/digest-coot-0.3.3
@@ -0,0 +1,3 @@
+MD5 e4c5c250d7c14124bc6a835d4532df40 coot-0.3.3.tar.gz 3870046
+RMD160 b23ca227894a469456c5af0284d0bb8530c855b5 coot-0.3.3.tar.gz 3870046
+SHA256 f3a7d6f789846b1f7670d4dc3e61a430cbab811f2f22349b84f49e10aaa4a41c coot-0.3.3.tar.gz 3870046