summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-24 13:03:51 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-24 13:03:51 +0000
commit8fd3ec5305f52732fe310d6376bcbf9540a34075 (patch)
treec07b1b18273942896feff845ed350bd2bbcf8c5c /sci-calculators
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8fd3ec5305f52732fe310d6376bcbf9540a34075.tar.gz
gentoo-2-8fd3ec5305f52732fe310d6376bcbf9540a34075.tar.bz2
gentoo-2-8fd3ec5305f52732fe310d6376bcbf9540a34075.zip
Revision bump fixing gcc-4.3 issues (see bug #243784).
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-SENTINEL-3 i686)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/kunit/ChangeLog10
-rw-r--r--sci-calculators/kunit/files/kunit-0.5-gcc4.3.patch31
-rw-r--r--sci-calculators/kunit/kunit-0.5-r1.ebuild35
-rw-r--r--sci-calculators/kunit/kunit-0.5.ebuild6
4 files changed, 77 insertions, 5 deletions
diff --git a/sci-calculators/kunit/ChangeLog b/sci-calculators/kunit/ChangeLog
index 86af42120f01..853497e21b25 100644
--- a/sci-calculators/kunit/ChangeLog
+++ b/sci-calculators/kunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/kunit
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/kunit/ChangeLog,v 1.7 2007/02/09 05:20:58 flameeyes Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/kunit/ChangeLog,v 1.8 2008/10/24 13:03:51 markusle Exp $
+
+*kunit-0.5-r1 (24 Oct 2008)
+
+ 24 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/kunit-0.5-gcc4.3.patch, +kunit-0.5-r1.ebuild:
+ Revision bump fixing gcc-4.3 issues (see bug #243784).
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sci-calculators/kunit/files/kunit-0.5-gcc4.3.patch b/sci-calculators/kunit/files/kunit-0.5-gcc4.3.patch
new file mode 100644
index 000000000000..9c968581b518
--- /dev/null
+++ b/sci-calculators/kunit/files/kunit-0.5-gcc4.3.patch
@@ -0,0 +1,31 @@
+diff -Naur kunit-0.5/kunit/main.cpp kunit-0.5.new/kunit/main.cpp
+--- kunit-0.5/kunit/main.cpp 2001-05-29 22:45:30.000000000 -0400
++++ kunit-0.5.new/kunit/main.cpp 2008-10-24 08:49:14.000000000 -0400
+@@ -17,10 +17,14 @@
+
+ #include "main_widget.h"
+
+-#include <iostream.h>
++#include <iostream>
++#include <cstdlib>
+ #include <X11/Xlib.h>
+ #include <X11/Xutil.h>
+
++using std::cout;
++using std::endl;
++
+ int
+ main(int argc, char **argv)
+ {
+diff -Naur kunit-0.5/kunit/main_widgetdata.cpp kunit-0.5.new/kunit/main_widgetdata.cpp
+--- kunit-0.5/kunit/main_widgetdata.cpp 2001-05-29 22:52:30.000000000 -0400
++++ kunit-0.5.new/kunit/main_widgetdata.cpp 2008-10-24 08:49:26.000000000 -0400
+@@ -18,7 +18,7 @@
+ #include <qapp.h>
+ #include "main_widget.h"
+
+-#include <iostream.h>
++#include <iostream>
+
+ void main_widget::initDialog()
+ {
diff --git a/sci-calculators/kunit/kunit-0.5-r1.ebuild b/sci-calculators/kunit/kunit-0.5-r1.ebuild
new file mode 100644
index 000000000000..984e9480d497
--- /dev/null
+++ b/sci-calculators/kunit/kunit-0.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/kunit/kunit-0.5-r1.ebuild,v 1.1 2008/10/24 13:03:51 markusle Exp $
+
+inherit eutils
+
+DESCRIPTION="An excellent qt-based unit conversion tool"
+SRC_URI="http://www.netmeister.org/apps/${P}.tar.gz"
+HOMEPAGE="http://www.netmeister.org/apps/kunit/"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="=x11-libs/qt-3*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+}
+
+src_compile() {
+ cd kunit
+ emake LFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin kunit/kunit
+ dodoc AUTHORS README
+ dohtml kunit/docs/*
+ make_desktop_entry kunit KUnit kunit Utility
+}
diff --git a/sci-calculators/kunit/kunit-0.5.ebuild b/sci-calculators/kunit/kunit-0.5.ebuild
index ed864ba77b68..e213e05478cb 100644
--- a/sci-calculators/kunit/kunit-0.5.ebuild
+++ b/sci-calculators/kunit/kunit-0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/kunit/kunit-0.5.ebuild,v 1.4 2006/01/19 00:00:45 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/kunit/kunit-0.5.ebuild,v 1.5 2008/10/24 13:03:51 markusle Exp $
inherit eutils
@@ -22,7 +22,7 @@ src_compile() {
src_install() {
dobin kunit/kunit
- dodoc AUTHORS COPYING README
+ dodoc AUTHORS README
dohtml kunit/docs/*
make_desktop_entry kunit KUnit kunit Utility
}