summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-29 12:28:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-29 12:28:04 +0000
commit2cbb52d442dcc28ab05cd4683b63d3d36223cbe5 (patch)
tree8836e973043fe1bd8929b1cf9ba7abbd8467f27d /sci-calculators
parentLink to libcrypto instead of libssl for required symbols. Keyword ~amd64 wrt ... (diff)
downloadgentoo-2-2cbb52d442dcc28ab05cd4683b63d3d36223cbe5.tar.gz
gentoo-2-2cbb52d442dcc28ab05cd4683b63d3d36223cbe5.tar.bz2
gentoo-2-2cbb52d442dcc28ab05cd4683b63d3d36223cbe5.zip
Version bump, closing bug #191893
(Portage version: 2.1.4)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/wcalc/ChangeLog8
-rw-r--r--sci-calculators/wcalc/files/digest-wcalc-2.33
-rw-r--r--sci-calculators/wcalc/metadata.xml20
-rw-r--r--sci-calculators/wcalc/wcalc-2.3.ebuild35
4 files changed, 55 insertions, 11 deletions
diff --git a/sci-calculators/wcalc/ChangeLog b/sci-calculators/wcalc/ChangeLog
index 365f906601ab..4f9ff6f6958a 100644
--- a/sci-calculators/wcalc/ChangeLog
+++ b/sci-calculators/wcalc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/wcalc
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/wcalc/ChangeLog,v 1.7 2008/01/27 15:41:02 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/wcalc/ChangeLog,v 1.8 2008/01/29 12:28:04 bicatali Exp $
+
+*wcalc-2.3 (29 Jan 2008)
+
+ 29 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +wcalc-2.3.ebuild:
+ Version bump, closing bug #191893
27 Jan 2008; Fabian Groffen <grobian@gentoo.org> wcalc-2.2.1.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/sci-calculators/wcalc/files/digest-wcalc-2.3 b/sci-calculators/wcalc/files/digest-wcalc-2.3
new file mode 100644
index 000000000000..1765e657b8c7
--- /dev/null
+++ b/sci-calculators/wcalc/files/digest-wcalc-2.3
@@ -0,0 +1,3 @@
+MD5 867d370533e0409c2216b588bbb31e2f Wcalc-2.3.tar.bz2 272188
+RMD160 d0c246cda018a7ea1fdf19a9a5cb0f669943b110 Wcalc-2.3.tar.bz2 272188
+SHA256 269ba72a94fb0e204ae1c66bc3dad23f8697469bca6a6588ebd0afdea9d799fb Wcalc-2.3.tar.bz2 272188
diff --git a/sci-calculators/wcalc/metadata.xml b/sci-calculators/wcalc/metadata.xml
index cc986379d48e..427518fa5507 100644
--- a/sci-calculators/wcalc/metadata.xml
+++ b/sci-calculators/wcalc/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
- Wcalc is a very capable calculator. It has standard functions (sin,
- asin, and sinh for example, in either radians or degrees), many
- pre-defined constants (pi, e, c, etc.), support for using variables,
- "active" variables, a command history, hex/octal/binary input and
- output, unit conversions, embedded comments, and an expandable
- expression entry field. It evaluates expressions using the standard
- order of operations.
- </longdescription>
+<herd>sci</herd>
+<longdescription lang="en">
+ Wcalc is a very capable calculator. It has standard functions (sin,
+ asin, and sinh for example, in either radians or degrees), many
+ pre-defined constants (pi, e, c, etc.), support for using variables,
+ "active" variables, a command history, hex/octal/binary input and
+ output, unit conversions, embedded comments, and an expandable
+ expression entry field. It evaluates expressions using the standard
+ order of operations.
+</longdescription>
</pkgmetadata>
diff --git a/sci-calculators/wcalc/wcalc-2.3.ebuild b/sci-calculators/wcalc/wcalc-2.3.ebuild
new file mode 100644
index 000000000000..e150f76f5ea6
--- /dev/null
+++ b/sci-calculators/wcalc/wcalc-2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/wcalc/wcalc-2.3.ebuild,v 1.1 2008/01/29 12:28:04 bicatali Exp $
+
+inherit eutils
+
+MYP="Wcalc-${PV}"
+DESCRIPTION="A flexible command-line scientific calculator"
+HOMEPAGE="http://w-calc.sourceforge.net"
+SRC_URI="mirror://sourceforge/w-calc/${MYP}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="readline"
+
+DEPEND="readline? ( sys-libs/readline )
+ dev-libs/mpfr
+ dev-libs/gmp"
+
+S="${WORKDIR}"/${MYP}
+
+src_compile() {
+ econf $(use_with readline) || die "econf failed."
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ # Wcalc icons
+ newicon w.png wcalc.png || die
+ newicon Wred.png wcalc-red.png || die
+}