summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-12-26 05:27:12 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-12-26 05:27:12 +0000
commitffb36574df03486035812e0a7ee5f9ec05f65aab (patch)
tree40db384a64d11ef110d1e5c7e480a0f3ce0bbf4a /sci-biology
parentVersion bump (diff)
downloadgentoo-2-ffb36574df03486035812e0a7ee5f9ec05f65aab.tar.gz
gentoo-2-ffb36574df03486035812e0a7ee5f9ec05f65aab.tar.bz2
gentoo-2-ffb36574df03486035812e0a7ee5f9ec05f65aab.zip
Version bump
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/GBrowse/ChangeLog7
-rw-r--r--sci-biology/GBrowse/GBrowse-2.44.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/sci-biology/GBrowse/ChangeLog b/sci-biology/GBrowse/ChangeLog
index 962c42fadde1..afd3e0887786 100644
--- a/sci-biology/GBrowse/ChangeLog
+++ b/sci-biology/GBrowse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/GBrowse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/ChangeLog,v 1.1 2011/07/20 00:56:03 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/ChangeLog,v 1.2 2011/12/26 05:27:12 weaver Exp $
+
+*GBrowse-2.44 (26 Dec 2011)
+
+ 26 Dec 2011; Andrey Kislyuk <weaver@gentoo.org> +GBrowse-2.44.ebuild:
+ Version bump
*GBrowse-2.39 (20 Jul 2011)
diff --git a/sci-biology/GBrowse/GBrowse-2.44.ebuild b/sci-biology/GBrowse/GBrowse-2.44.ebuild
new file mode 100644
index 000000000000..a8c3828f29c4
--- /dev/null
+++ b/sci-biology/GBrowse/GBrowse-2.44.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/GBrowse/GBrowse-2.44.ebuild,v 1.1 2011/12/26 05:27:12 weaver Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=LDS
+inherit perl-module webapp
+
+DESCRIPTION="Generic Model Organism Database Project - The Generic Genome Browser"
+HOMEPAGE="http://gmod.org/wiki/GBrowse"
+KEYWORDS="~amd64 ~x86"
+IUSE="-minimal mysql postgres +sqlite"
+
+CDEPEND=">=sci-biology/bioperl-1.6.9
+ >=dev-perl/Bio-Graphics-2.09
+ >=dev-perl/GD-2.07
+ >=dev-perl/CGI-Session-4.02
+ dev-perl/IO-String
+ dev-perl/JSON
+ dev-perl/libwww-perl
+ dev-perl/Statistics-Descriptive
+ !minimal? (
+ dev-perl/Bio-Das
+ >=dev-perl/Bio-SamTools-1.20
+ dev-perl/Crypt-SSLeay
+ dev-perl/DB_File-Lock
+ dev-perl/DBI
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ sqlite? ( dev-perl/DBD-SQLite )
+ dev-perl/FCGI
+ dev-perl/File-NFSLock
+ dev-perl/GD-SVG
+ dev-perl/Net-OpenID-Consumer
+ dev-perl/Net-SMTP-SSL
+ )"
+# >=dev-perl/Bio-DB-BigFile-1.00 - requires jklib to compile
+DEPEND="virtual/perl-Module-Build
+ dev-perl/Capture-Tiny
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}"/GBrowseInstall.pm-2.39.patch )
+
+src_configure() {
+ webapp_src_preinst
+
+# myconf="--install_base=${D}/usr" or "--install_base=/opt/gbrowse"
+ myconf="--conf=/etc/gbrowse2"
+ myconf="${myconf} --htdocs=${MY_HTDOCSDIR}"
+ myconf="${myconf} --cgibin=${MY_CGIBINDIR}"
+ myconf="${myconf} --tmp=/var/tmp/gbrowse2"
+ myconf="${myconf} --persistent=/var/db/gbrowse2"
+ myconf="${myconf} --databases=/var/db/gbrowse2/databases"
+ myconf="${myconf} --installconf=no"
+ myconf="${myconf} --installetc=no"
+ perl-module_src_configure
+}
+
+src_install() {
+ dodir /var/tmp/gbrowse2
+ dodir /var/db/gbrowse2/sessions
+ dodir /var/db/gbrowse2/userdata
+ webapp_serverowned -R /var/tmp/gbrowse2 /var/db/gbrowse2
+ perl-module_src_install
+ webapp_src_install
+}