summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-02 08:01:05 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-02 08:01:05 +0000
commitb53ea2c51a2b34eee3e5b4b7d42a629d78aba859 (patch)
tree80351ca9290b53e6f3a8c9724d97071a1df937a5 /sci-biology
parentnet-analyzer/openvas: Enable pdf report by default (diff)
downloadgentoo-2-b53ea2c51a2b34eee3e5b4b7d42a629d78aba859.tar.gz
gentoo-2-b53ea2c51a2b34eee3e5b4b7d42a629d78aba859.tar.bz2
gentoo-2-b53ea2c51a2b34eee3e5b4b7d42a629d78aba859.zip
sci-biology/cufflinks: Drop debugging flags, fix compatibility with newer samtools, #524252
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/cufflinks/ChangeLog8
-rw-r--r--sci-biology/cufflinks/cufflinks-2.2.1-r1.ebuild51
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch28
-rw-r--r--sci-biology/cufflinks/files/cufflinks-2.2.1-hts.patch16
4 files changed, 102 insertions, 1 deletions
diff --git a/sci-biology/cufflinks/ChangeLog b/sci-biology/cufflinks/ChangeLog
index 7a6426be6048..044b1c730a93 100644
--- a/sci-biology/cufflinks/ChangeLog
+++ b/sci-biology/cufflinks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/cufflinks
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/cufflinks/ChangeLog,v 1.8 2014/09/25 16:11:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cufflinks/ChangeLog,v 1.9 2014/10/02 08:01:05 jlec Exp $
+
+*cufflinks-2.2.1-r1 (02 Oct 2014)
+
+ 02 Oct 2014; Justin Lecher <jlec@gentoo.org> +cufflinks-2.2.1-r1.ebuild,
+ +files/cufflinks-2.2.1-flags.patch, +files/cufflinks-2.2.1-hts.patch:
+ Drop debugging flags, fix compatibility with newer samtools, #524252
*cufflinks-2.2.1 (25 Sep 2014)
diff --git a/sci-biology/cufflinks/cufflinks-2.2.1-r1.ebuild b/sci-biology/cufflinks/cufflinks-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..e6e79a3c9df0
--- /dev/null
+++ b/sci-biology/cufflinks/cufflinks-2.2.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/cufflinks/cufflinks-2.2.1-r1.ebuild,v 1.1 2014/10/02 08:01:05 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Transcript assembly, differential expression, and differential regulation for RNA-Seq"
+HOMEPAGE="http://cufflinks.cbcb.umd.edu/"
+SRC_URI="http://cufflinks.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+IUSE="debug"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ || (
+ (
+ >=sci-biology/samtools-0.1.18
+ sci-libs/htslib
+ )
+ <sci-biology/samtools-1
+ )
+ >=dev-libs/boost-1.47.0:=
+ dev-cpp/eigen:3
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hts.patch
+ "${FILESDIR}"/${P}-flags.patch
+ )
+
+src_prepare() {
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags eigen3)
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optim
+ --with-boost-libdir="${EPREFIX}/usr/$(get_libdir)/"
+ --with-bam="${EPREFIX}/usr/"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch
new file mode 100644
index 000000000000..47784088fab9
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-flags.patch
@@ -0,0 +1,28 @@
+ configure.ac | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96ffbac..e88b8e4 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -61,7 +61,8 @@ AC_CANONICAL_HOST
+
+ # set CFLAGS and CXXFLAGS
+ user_CFLAGS=${CFLAGS}
+-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wunused -Wuninitialized -ftemplate-depth-1024"
++generic_CFLAGS="-Wall -Wno-strict-aliasing -Wunused -Wuninitialized"
++generic_CXXFLAGS="-Wall -Wno-strict-aliasing -Wunused -Wuninitialized -ftemplate-depth-1024"
+ ext_CFLAGS=""
+ debug_CFLAGS=""
+ #echo "${host_cpu}-${host_os}"
+@@ -106,8 +107,8 @@ AC_ARG_ENABLE(profiling, [ --enable-profiling enable profiling with
+ [ext_LDFLAGS="-lprofiler -ltcmalloc"], [])
+
+ CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS} ${OPENMP_CFLAGS}"
+-CXXFLAGS="$CFLAGS"
+-CXXFLAGS="${CXXFLAGS} ${BOOST_CPPFLAGS} ${BAM_CPPFLAGS} ${EIGEN_CPPFLAGS}"
++CXXFLAGS="${generic_CFLAGS} ${CXXFLAGS}"
++CPPFLAGS="${CPPFLAGS} ${BOOST_CPPFLAGS} ${BAM_CPPFLAGS} ${EIGEN_CPPFLAGS}"
+ user_LDFLAGS="$LDFLAGS"
+ LDFLAGS="${ext_LDFLAGS} ${user_LDFLAGS}"
+
diff --git a/sci-biology/cufflinks/files/cufflinks-2.2.1-hts.patch b/sci-biology/cufflinks/files/cufflinks-2.2.1-hts.patch
new file mode 100644
index 000000000000..3b9abd812680
--- /dev/null
+++ b/sci-biology/cufflinks/files/cufflinks-2.2.1-hts.patch
@@ -0,0 +1,16 @@
+ ax_bam.m4 | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ax_bam.m4 b/ax_bam.m4
+index 7d463b7..95f1bed 100644
+--- a/ax_bam.m4
++++ b/ax_bam.m4
+@@ -189,7 +189,7 @@ if test "x$want_bam" = "xyes"; then
+ AC_MSG_NOTICE([Your bam libraries seem too old (version $_version).])
+ fi
+ else
+- BAM_LIB="-lbam"
++ BAM_LIB="-lbam -lhts"
+ AC_SUBST(BAM_CPPFLAGS)
+ AC_SUBST(BAM_LDFLAGS)
+ AC_SUBST(BAM_LIB)