summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-19 14:13:36 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-19 14:13:36 +0000
commit850905acd1f495974ec742ce6d2fffa8908bb2e4 (patch)
tree7a836cc4486808f413e0a9c06421825f0e0c5da4 /sci-biology
parentMajor regression fix (diff)
downloadgentoo-2-850905acd1f495974ec742ce6d2fffa8908bb2e4.tar.gz
gentoo-2-850905acd1f495974ec742ce6d2fffa8908bb2e4.tar.bz2
gentoo-2-850905acd1f495974ec742ce6d2fffa8908bb2e4.zip
sci-biology/plink: Version BUmp, #510716
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/plink/ChangeLog10
-rw-r--r--sci-biology/plink/plink-1.07.ebuild32
-rw-r--r--sci-biology/plink/plink-1.90_pre140514.ebuild56
3 files changed, 64 insertions, 34 deletions
diff --git a/sci-biology/plink/ChangeLog b/sci-biology/plink/ChangeLog
index e30718097355..0b36a02ac637 100644
--- a/sci-biology/plink/ChangeLog
+++ b/sci-biology/plink/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/plink
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/ChangeLog,v 1.14 2013/03/11 16:47:09 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/ChangeLog,v 1.15 2014/05/19 14:13:36 jlec Exp $
+
+*plink-1.90_pre140514 (19 May 2014)
+
+ 19 May 2014; Justin Lecher <jlec@gentoo.org> -plink-1.07.ebuild,
+ +plink-1.90_pre140514.ebuild:
+ Version BUmp, #510716
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
diff --git a/sci-biology/plink/plink-1.07.ebuild b/sci-biology/plink/plink-1.07.ebuild
deleted file mode 100644
index 30fe6ae83437..000000000000
--- a/sci-biology/plink/plink-1.07.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/plink-1.07.ebuild,v 1.3 2010/04/05 12:13:23 phajdan.jr Exp $
-
-EAPI="2"
-
-DESCRIPTION="Whole genome association analysis toolset"
-HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
-SRC_URI="http://pngu.mgh.harvard.edu/~purcell/plink/dist/${P}-src.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="-webcheck"
-KEYWORDS="amd64 x86"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S="${WORKDIR}/${P}-src"
-
-# Package collides with net-misc/putty. Renamed to p-link following discussion with Debian.
-# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
-
-src_prepare() {
- sed -i -e '/CXXFLAGS =/ s/^/#/' -e 's/-static//' "${S}/Makefile" || die
- use webcheck || sed -i '/WITH_WEBCHECK =/ s/^/#/' "${S}/Makefile" || die
-}
-
-src_install() {
- newbin plink p-link || die
- dodoc README.txt
-}
diff --git a/sci-biology/plink/plink-1.90_pre140514.ebuild b/sci-biology/plink/plink-1.90_pre140514.ebuild
new file mode 100644
index 000000000000..8c959627996c
--- /dev/null
+++ b/sci-biology/plink/plink-1.90_pre140514.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/plink/plink-1.90_pre140514.ebuild,v 1.1 2014/05/19 14:13:36 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Whole genome association analysis toolset"
+HOMEPAGE="http://pngu.mgh.harvard.edu/~purcell/plink/"
+SRC_URI="http://pngu.mgh.harvard.edu/~purcell/static/bin/plink140514/plink_src.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="lapack"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-arch/unzip
+ virtual/pkgconfig"
+RDEPEND="
+ sys-libs/zlib
+ lapack? ( virtual/lapack )"
+
+S="${WORKDIR}/"
+
+# Package collides with net-misc/putty. Renamed to p-link following discussion with Debian.
+# Package contains bytecode-only jar gPLINK.jar. Ignored, notified upstream.
+
+src_prepare() {
+ use lapack || sed -i '/NO_LAPACK =/s/$/1/' "${S}/Makefile" || die
+
+ sed \
+ -e 's:zlib-1.2.8/zlib.h:zlib.h:g' \
+ -i *.{c,h} || die
+
+ sed \
+ -e 's:g++:$(CXX):g' \
+ -e 's:gcc:$(CC):g' \
+ -e 's:gfortran:$(FC):g' \
+ -i Makefile || die
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ local blas
+ emake \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS}" \
+ ZLIB="$($(tc-getPKG_CONFIG) --libs zlib)" \
+ BLASFLAGS="$(usex lapack "" "$($(tc-getPKG_CONFIG) --libs lapack)")"
+}
+
+src_install() {
+ newbin plink p-link
+}