summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-09-12 14:06:53 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-09-12 14:06:53 +0000
commit0fdf305ec330f40eaf2ef4f72fcf6e56bfc03a9f (patch)
treea9de118de9fbbd63a60363f5d8c2fb3f95d99918 /sci-biology
parentremoved old version. (diff)
downloadgentoo-2-0fdf305ec330f40eaf2ef4f72fcf6e56bfc03a9f.tar.gz
gentoo-2-0fdf305ec330f40eaf2ef4f72fcf6e56bfc03a9f.tar.bz2
gentoo-2-0fdf305ec330f40eaf2ef4f72fcf6e56bfc03a9f.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/meme/ChangeLog7
-rw-r--r--sci-biology/meme/meme-3.5.7.ebuild96
2 files changed, 102 insertions, 1 deletions
diff --git a/sci-biology/meme/ChangeLog b/sci-biology/meme/ChangeLog
index 3a2bd73cd55e..c68755fbb494 100644
--- a/sci-biology/meme/ChangeLog
+++ b/sci-biology/meme/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/meme
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.7 2008/06/14 12:34:50 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.8 2008/09/12 14:06:53 markusle Exp $
+
+*meme-3.5.7 (12 Sep 2008)
+
+ 12 Sep 2008; Markus Dittrich <markusle@gentoo.org> +meme-3.5.7.ebuild:
+ Version bump.
14 Jun 2008; Markus Dittrich <markusle@gentoo.org> -meme-3.5.4.ebuild:
Removed old ebuild with bad autotools usage (fixes bug #226609).
diff --git a/sci-biology/meme/meme-3.5.7.ebuild b/sci-biology/meme/meme-3.5.7.ebuild
new file mode 100644
index 000000000000..4ab0643740ca
--- /dev/null
+++ b/sci-biology/meme/meme-3.5.7.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/meme-3.5.7.ebuild,v 1.1 2008/09/12 14:06:53 markusle Exp $
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="The MEME/MAST system - Motif discovery and search"
+HOMEPAGE="http://meme.sdsc.edu/meme"
+SRC_URI="http://meme.nbcr.net/downloads/${PN}_${PV}.tar.gz"
+LICENSE="meme"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+# Other possible USE flags include "debug", "client", "server", "web",
+# "queue". Other variables must be set at compile time, but only when
+# the Web server is built. Right now, Web server and client are disabled.
+IUSE="mpi"
+
+# Works only with LAM-MPI.
+DEPEND=">=dev-lang/perl-5.6.1
+ mpi? ( sys-cluster/lam-mpi )"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+pkg_setup() {
+ # generate meme group to restrict logging to
+ # /var/log/meme
+ enewgroup meme
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.5.4-Makefile.am.patch"
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
+src_compile() {
+ local EXTRA_CONF
+ # Build system is too bugy to make the programs use standard locations.
+ # Put everything in "/opt" instead.
+ EXTRA_CONF="${EXTRA_CONF} --prefix=/opt/${PN}"
+ EXTRA_CONF="${EXTRA_CONF} --with-logs=/var/log/${PN}"
+ # Connect hyperlinks to official Web site.
+ EXTRA_CONF="${EXTRA_CONF} --with-url=http://meme.nbcr.net/meme"
+ # Disable Web server, client and Web site.
+ EXTRA_CONF="${EXTRA_CONF} --disable-server --disable-client --disable-web"
+ # Parallel implementation
+ if ! use mpi; then
+ EXTRA_CONF="${EXTRA_CONF} --enable-serial"
+ fi
+
+ ./configure ${EXTRA_CONF} || die "Configure failed."
+ CC="$(tc-getCC)" ac_cc_opt="${CFLAGS}" make -e || die "Make failed."
+
+# Install parallel files only on x86, otherwise the install fails with the error:
+# i386 architecture of input file `mp.o' is incompatible with i386:x86-64 output
+ if [[ "${ARCH}" == "x86" ]] ; then
+ if use mpi; then
+ cd src/parallel
+ make || die "Parallel make failed."
+ fi
+ fi
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Failed to install program files."
+ exeinto "/opt/${PN}/bin"
+ if [[ "${ARCH}" == "x86" ]] ; then
+ if use mpi; then
+ doexe "${S}/src/parallel/${PN}_p" || \
+ die "Failed to install parallel MEME implementation."
+ fi
+ fi
+
+ # allow logging only for members of meme group
+ diropts -m 0770 -g meme -o root
+ keepdir "/var/log/${PN}"
+}
+
+pkg_postinst() {
+ echo
+ einfo 'Prior to using MEME/MAST, you should source "/opt/meme/etc/meme.sh"'
+ einfo '(or "/opt/meme/etc/meme.csh" if you use a csh-style shell). To do'
+ einfo 'this automatically with bash, add the following statement to your'
+ einfo '"~/.bashrc" file (without the quotes): "source /opt/meme/etc/meme.sh".'
+ echo
+ einfo 'Log files are produced in the "/var/log/meme" directory. Users'
+ einfo 'need to be part of the meme group to use this facility.'
+ echo
+}
+
+src_test() {
+ make test || die "Regression tests failed."
+}