summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:14:50 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-02-23 04:14:50 +0000
commit1ee8a2924a2b6921a64491d7a1719e05bff8133f (patch)
treeacf41d1ec92d57dc737e6fbe7fee26e24c83eaea /sci-biology/rebase
parentAdded support for the "emboss" and "minimal" "USE" flags. (diff)
downloadgentoo-2-1ee8a2924a2b6921a64491d7a1719e05bff8133f.tar.gz
gentoo-2-1ee8a2924a2b6921a64491d7a1719e05bff8133f.tar.bz2
gentoo-2-1ee8a2924a2b6921a64491d7a1719e05bff8133f.zip
Added support for the "emboss" and "minimal" "USE" flags.
(Portage version: 2.0.51.16)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog5
-rw-r--r--sci-biology/rebase/rebase-502.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index 7b9ef70b1ec7..092debdb5409 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/rebase
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.7 2005/02/11 23:49:52 j4rg0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.8 2005/02/23 04:14:50 ribosome Exp $
+
+ 22 Feb 2005; Olivier Fisette <ribosome@gentoo.org> rebase-502.ebuild:
+ Added support for the "emboss" and "minimal" "USE" flags.
11 Feb 2005; Lina Pezzella <j4rg0n@gentoo.org> rebase-501.ebuild:
Stable ppc-macos
diff --git a/sci-biology/rebase/rebase-502.ebuild b/sci-biology/rebase/rebase-502.ebuild
index eaa3e7a3de8e..760cb03bae6b 100644
--- a/sci-biology/rebase/rebase-502.ebuild
+++ b/sci-biology/rebase/rebase-502.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-502.ebuild,v 1.1 2005/02/03 00:37:49 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-502.ebuild,v 1.2 2005/02/23 04:14:50 ribosome Exp $
DESCRIPTION="A restriction enzyme database"
HOMEPAGE="http://rebase.neb.com"
@@ -9,26 +9,28 @@ LICENSE="public-domain"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64 ~ppc-macos"
-IUSE="no-emboss no-rawdb"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
src_compile() {
- # Index the database for use with emboss if emboss is installed and
- # the user did not explicitly request not to index the database.
- if [ -e /usr/bin/rebaseextract ] && ! use no-emboss; then
+ if use emboss; then
+ echo
einfo "Indexing ${PN} for usage with EMBOSS."
mkdir REBASE
EMBOSS_DATA=. rebaseextract -auto -infile withrefm.${PV} \
-protofile proto.${PV} || die "Indexing ${PN} failed."
+ echo
fi
}
src_install() {
- if ! use no-rawdb; then
+ if ! use minimal; then
insinto /usr/share/${PN}
doins withrefm.${PV} proto.${PV}
fi
newdoc REBASE.DOC README
- if [ -e /usr/bin/rebaseextract ] && ! use no-emboss; then
+ if use emboss; then
insinto /usr/share/EMBOSS/data/REBASE
doins REBASE/{embossre.enz,embossre.ref,embossre.sup}
fi