summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-04 17:22:15 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-04 17:22:15 +0000
commit11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808 (patch)
treef4a35f8e85de489b29e338dd4c4afb91d42faf14 /sci-biology/njplot/njplot-2.3.ebuild
parentamd64 stable, security bug 283624. (diff)
downloadgentoo-2-11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808.tar.gz
gentoo-2-11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808.tar.bz2
gentoo-2-11f1a6d8ce9f6e7ae9b9537a1fc51e973bc78808.zip
Version bump, clean up, fix bug 248338, take maintainership
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/njplot/njplot-2.3.ebuild')
-rw-r--r--sci-biology/njplot/njplot-2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/njplot/njplot-2.3.ebuild b/sci-biology/njplot/njplot-2.3.ebuild
new file mode 100644
index 000000000000..147592cd5c05
--- /dev/null
+++ b/sci-biology/njplot/njplot-2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/njplot/njplot-2.3.ebuild,v 1.1 2009/09/04 17:22:15 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A phylogenetic tree drawing program which supports tree rooting"
+HOMEPAGE="http://pbil.univ-lyon1.fr/software/njplot.html"
+SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/njplot/archive/njplot-${PV}.tar.gz"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXmu"
+DEPEND="sci-biology/ncbi-tools[X]
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's|/banques0/ncbiJun04|/usr/include/ncbi|' \
+ -e 's/CC = gcc/CC='$(tc-getCC)'/' -e 's/CFLAGS =/CFLAGS +=/' \
+ makefile || die
+ sed -i -e "s%njplot.help%/usr/share/doc/${PF}/njplot.help%" njplot-vib.c || die
+}
+
+src_install() {
+ dobin newicktops newicktotxt njplot unrooted || die
+ doman *.1 || die
+ dodoc README njplot.help
+}