summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-23 18:31:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-23 18:31:04 +0000
commitdfede577a4eba86b03b1d43868e3650b11b29196 (patch)
tree920511ec5a09a1af6214914f3309d3d1f7229c4a /sci-astronomy
parentMarking ruby-1.8.6_p287-r5 ppc64 for bug 260006 (diff)
downloadgentoo-2-dfede577a4eba86b03b1d43868e3650b11b29196.tar.gz
gentoo-2-dfede577a4eba86b03b1d43868e3650b11b29196.tar.bz2
gentoo-2-dfede577a4eba86b03b1d43868e3650b11b29196.zip
Now propagate LDFLAGS, respect as-needed, and simplified/modernized ebuild
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/predict/ChangeLog7
-rw-r--r--sci-astronomy/predict/predict-2.2.3.ebuild121
2 files changed, 57 insertions, 71 deletions
diff --git a/sci-astronomy/predict/ChangeLog b/sci-astronomy/predict/ChangeLog
index 790b9c289adb..9ac7bb031f77 100644
--- a/sci-astronomy/predict/ChangeLog
+++ b/sci-astronomy/predict/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/predict
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.11 2008/08/06 13:05:40 ulm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/ChangeLog,v 1.12 2009/02/23 18:31:04 bicatali Exp $
+
+ 23 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> predict-2.2.3.ebuild:
+ Now propagate LDFLAGS, respect as-needed, and simplified/modernized ebuild
06 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/sci-astronomy/predict/predict-2.2.3.ebuild b/sci-astronomy/predict/predict-2.2.3.ebuild
index fb731b217616..9f24708adcda 100644
--- a/sci-astronomy/predict/predict-2.2.3.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3.ebuild,v 1.4 2007/09/11 15:06:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3.ebuild,v 1.5 2009/02/23 18:31:04 bicatali Exp $
inherit toolchain-funcs eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.amsat.org/amsat/ftp/software/Linux/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE="xforms xplanet gtk nls"
+IUSE="doc gtk nls xforms xplanet"
KEYWORDS="amd64 ~ppc x86"
DEPEND="sys-libs/ncurses
@@ -27,121 +27,105 @@ src_unpack() {
src_compile() {
# predict uses a ncurses based configure script
# this is what it does if it was bash based ;)
+ COMPILER="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
- # set compiler string to a var so if compiler checks
- # can be added at a later date
- COMPILER="$(tc-getCC) ${CFLAGS}"
-
- # write predict.h
+ einfo "Compiling predict"
echo "char *predictpath=\"/usr/share/predict/\";" > predict.h
echo "char soundcard=1;" >> predict.h
echo "char *version=\"${PV}\";" >> predict.h
+ ${COMPILER} \
+ predict.c -o predict \
+ -L/$(get_libdir) -lm -lncurses -lpthread \
+ || die "Failed compiling predict"
- # compile predict
- einfo "compiling predict"
- ${COMPILER} -L/$(get_libdir) -lm -lncurses -lpthread predict.c -o predict || \
- die "Failed compiling predict"
-
- # write vocalizer.h
+ einfo "Compiling vocalizer"
cd vocalizer
echo "char *path={\"/usr/share/predict/vocalizer/\"};" > vocalizer.h
+ ${COMPILER} vocalizer.c -o vocalizer \
+ || die "Failed compiling vocalizer"
- # compile vocalizer
- einfo "compiling vocalizer"
- ${COMPILER} vocalizer.c -o vocalizer || \
- die "Failed compiling vocalizer"
-
- einfo "compiling clients"
-
- # earthtrack
if use xplanet; then
- einfo "compiling earthtrack"
+ einfo "Compiling earthtrack"
cd "${S}"/clients/earthtrack
# fix include path
- sed -e "s:/usr/local/share/xplanet:/usr/share/xplanet:" \
- -i earthtrack.c || die "Failed to fix xplanet paths"
- ${COMPILER} -lm earthtrack.c -o earthtrack || \
- die "Failed compiling earthtrack"
+ sed -i \
+ -e "s:/usr/local/share/xplanet:/usr/share/xplanet:" \
+ earthtrack.c || die "Failed to fix xplanet paths"
+ ${COMPILER} earthtrack.c -o earthtrack -lm \
+ || die "Failed compiling earthtrack"
fi
# kep_reload
- einfo "compiling kep_reload"
+ einfo "Compiling kep_reload"
cd "${S}"/clients/kep_reload
${COMPILER} kep_reload.c -o kep_reload || \
die "Failed compiling kep_reload"
# map
if use xforms; then
- einfo "compiling map"
+ einfo "Compiling map"
cd "${S}"/clients/map
- TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/$(get_libdir) -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
- ${TCOMP} || die "Failed compiling map"
+ ${COMPILER} -I/usr/X11R6/include \
+ map.c map_cb.c map_main.c \
+ -L/usr/X11R6/$(get_libdir) -lforms -lX11 -lm \
+ -o map || die "Failed compiling map"
fi
# gsat
if use gtk; then
- # note there are plugins for gsat but they are missing header files and wont compile
- use nls || myconf="--disable-nls"
- einfo "compiling gsat"
+ # note there are plugins for gsat but they are missing
+ ## header files and wont compile
+ einfo "Compiling gsat"
cd "${S}"/clients/gsat-*
- ./configure --prefix=/usr ${myconf}
+ econf $(use_enable nls)
cd src
- sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/$(get_libdir)/gsat/plugins/\":" -i globals.h
- sed -e 's:int errno;::' -i globals.h
+ sed -i \
+ -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/$(get_libdir)/gsat/plugins/\":" \
+ -e 's:int errno;::' \
+ globals.h || die
cd ..
emake || die "Failed compiling gsat"
fi
}
src_install() {
- # install predict
- cd "${S}"
- dobin predict "${FILESDIR}"/predict-update
+ dobin predict "${FILESDIR}"/predict-update || die
dodoc CHANGES CREDITS HISTORY README NEWS
- dodoc docs/pdf/predict.pdf
- dodoc docs/postscript/predict.ps
doman docs/man/predict.1
-
insinto /usr/share/${PN}/default
- doins default/predict.*
+ doins default/predict.* || die
+ if use doc; then
+ dodoc docs/postscript/predict.ps || die
+ insinto /usr/share/doc/${PF}
+ doins docs/pdf/predict.pdf || die
+ fi
- #install vocalizer
exeinto /usr/bin
cd vocalizer
- doexe vocalizer
- dodir /usr/share/predict/vocalizer
- insinto /usr/share/predict/vocalizer
+ doexe vocalizer || die
dosym /usr/bin/vocalizer /usr/share/predict/vocalizer/vocalizer
+ insinto /usr/share/${PN}/vocalizer
doins *.wav || die "Failed to install vocalizer *.wav files"
- # install clients
-
# earthtrack
if use xplanet; then
cd "${S}"/clients/earthtrack
ln -s earthtrack earthtrack2
- dobin earthtrack earthtrack2
- mv README README.earthtrack && \
- dodoc README.earthtrack || \
- die "Failed to install earthtrack docs"
+ dobin earthtrack earthtrack2 || die
+ newdoc README README.earthtrack
fi
# kep_reload
cd "${S}"/clients/kep_reload
dobin kep_reload
- mv INSTALL INSTALL.kep_reload && \
- mv README README.kep_reload && \
- dodoc INSTALL.kep_reload README.kep_reload || \
- die "Failed to install kep_reload docs"
+ newdoc README README.kep_reload
# map
if use xforms; then
cd "${S}"/clients/map
- dobin map
- for i in CHANGES README; do
- mv ${i} ${i}.map && dodoc ${i}.map || \
- die "Failed to install xforms docs"
- done
+ dobin map || die
+ newdoc CHANGES CHANGES.map
+ newdoc README README.map
fi
# gsat
@@ -153,22 +137,21 @@ src_install() {
cd src
dobin gsat
cd ..
- for i in AUTHORS ABOUT-NLS ChangeLog INSTALL NEWS README Plugin_API; do
- mv ${i} ${i}.gsat && dodoc ${i}.gsat || \
- die "Failed to install gsat docs"
+ for i in AUTHORS ABOUT-NLS ChangeLog NEWS README Plugin_API; do
+ newdoc ${i} ${i}.gsat
done
fi
}
pkg_postinst() {
- einfo "to use the clients the following line will"
+ einfo "To use the clients the following line will"
einfo "have to be inserted into /etc/services"
einfo "predict 1210/udp"
- einfo "the port can be changed to anything"
+ einfo "The port can be changed to anything"
einfo "the name predict is what is needed to work"
einfo "after that is set run 'predict -s'"
einfo ""
- einfo "to get list of satellites run 'predict-update'"
+ einfo "To get list of satellites run 'predict-update'"
einfo "before running predict this script will also update"
einfo "the list of satellites so they are up to date."
}