summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2006-07-28 14:56:59 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2006-07-28 14:56:59 +0000
commit0361b735fa81cbb2e5a31ad0291124fcfa387a47 (patch)
tree29bdf9eb65fe58159dc49b3294da1cadccbb4c7d /sci-astronomy/xephem
parentStable on IA64; fix bug #141681. (diff)
downloadgentoo-2-0361b735fa81cbb2e5a31ad0291124fcfa387a47.tar.gz
gentoo-2-0361b735fa81cbb2e5a31ad0291124fcfa387a47.tar.bz2
gentoo-2-0361b735fa81cbb2e5a31ad0291124fcfa387a47.zip
Version bump. Stops installing garbage and starts installing tools.
(Portage version: 2.1)
Diffstat (limited to 'sci-astronomy/xephem')
-rw-r--r--sci-astronomy/xephem/ChangeLog8
-rw-r--r--sci-astronomy/xephem/files/digest-xephem-3.72
-rw-r--r--sci-astronomy/xephem/files/digest-xephem-3.7.13
-rw-r--r--sci-astronomy/xephem/xephem-3.7.1.ebuild68
4 files changed, 80 insertions, 1 deletions
diff --git a/sci-astronomy/xephem/ChangeLog b/sci-astronomy/xephem/ChangeLog
index e8808ad81f0f..b2abceebb22b 100644
--- a/sci-astronomy/xephem/ChangeLog
+++ b/sci-astronomy/xephem/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/xephem
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.10 2006/03/15 17:06:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/ChangeLog,v 1.11 2006/07/28 14:56:59 phosphan Exp $
+
+*xephem-3.7.1 (28 Jul 2006)
+
+ 28 Jul 2006; Patrick Kursawe <phosphan@gentoo.org> -xephem-3.6.2.ebuild,
+ -xephem-3.6.2-r1.ebuild, +xephem-3.7.1.ebuild:
+ Version bump. Stops installing garbage and starts installing tools.
15 Mar 2006; Markus Rothe <corsair@gentoo.org> xephem-3.7.ebuild:
Added ~ppc64; bug #126250
diff --git a/sci-astronomy/xephem/files/digest-xephem-3.7 b/sci-astronomy/xephem/files/digest-xephem-3.7
index 79111910f232..6c760f99b1d3 100644
--- a/sci-astronomy/xephem/files/digest-xephem-3.7
+++ b/sci-astronomy/xephem/files/digest-xephem-3.7
@@ -1 +1,3 @@
MD5 30d253d086580895df73d17e47b1a5fa xephem-3.7.tar.gz 11058376
+RMD160 6df2c7a81f493e0a3846a8d15acbc0f79e2c5a3a xephem-3.7.tar.gz 11058376
+SHA256 efa6e706a06414c1f8a960275f3482f70338e6ef6fb41ea67ce7dfa425a18087 xephem-3.7.tar.gz 11058376
diff --git a/sci-astronomy/xephem/files/digest-xephem-3.7.1 b/sci-astronomy/xephem/files/digest-xephem-3.7.1
new file mode 100644
index 000000000000..adcc3e43c1a0
--- /dev/null
+++ b/sci-astronomy/xephem/files/digest-xephem-3.7.1
@@ -0,0 +1,3 @@
+MD5 a7a89469f1c0681d186344ef96941b8d xephem-3.7.1.tar.gz 12986819
+RMD160 7debeb25b9e76b3e796ae5349d84d6b36ae04e54 xephem-3.7.1.tar.gz 12986819
+SHA256 f818c54b9533502734402578424a3546d34df91a145dea9f88930293aa348a1a xephem-3.7.1.tar.gz 12986819
diff --git a/sci-astronomy/xephem/xephem-3.7.1.ebuild b/sci-astronomy/xephem/xephem-3.7.1.ebuild
new file mode 100644
index 000000000000..e67a5a68effb
--- /dev/null
+++ b/sci-astronomy/xephem/xephem-3.7.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/xephem/xephem-3.7.1.ebuild,v 1.1 2006/07/28 14:56:59 phosphan Exp $
+
+DESCRIPTION="XEphem is the X Windows Ephemeris, and provides a scientific-grade solar system model, star charts, sky views, plus a whole lot more."
+SRC_URI="http://www.clearskyinstitute.com/xephem/${P}.tar.gz"
+HOMEPAGE="http://www.clearskyinstitute.com/xephem"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+SLOT="0"
+LICENSE="as-is"
+DEPEND="virtual/motif"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ for i in libastro/Makefile libip/Makefile libjpegd/Makefile \
+ liblilxml/Makefile GUI/xephem/Makefile GUI/xephem/tools/*/Makefile ; do
+ einfo "Fixing CFLAGS in ${i}"
+ sed -e "s~^CFLAGS[ ]*=\(.*\)-O2\(.*\)~CFLAGS= \1 \2 ${CFLAGS}~" -i ${i} \
+ || die "sed failed"
+ done
+ sed -e 's~^CFLAGS[ ]*=\(.*\)$(CLDFLAGS)\(.*\)~CFLAGS=\1 \2~' \
+ -i GUI/xephem/Makefile
+}
+
+src_compile() {
+
+ cd libastro
+ emake || die
+ local myldflags
+ cd ${S}
+ for dir in libip liblilxml libjpegd GUI/xephem/tools/* GUI/xephem; do
+ echo "going into ${dir}"
+ cd ${S}/${dir}
+ if [ ${dir:0:3} = "lib" ]; then
+ myldflags=""
+ else
+ myldflags="${CLDFLAGS}"
+ fi
+ emake CLDFLAGS="${myldflags}" || die
+ done
+}
+
+src_install() {
+
+ into /usr
+ cd ${S}/GUI/xephem
+ dobin xephem
+ for file in tools/indi/{evalINDI,getINDI,setINDI,tmount,ota,wx,cam,security,indiserver} \
+ tools/{lx200xed/lx200xed,xedb/xedb,xephemdbd/xephemdbd}; do
+ dobin ${file}
+ done
+ doman xephem.1 tools/*/*.1
+ mv tools .. # do not install tool sources into share directory
+ for i in $(find . -type d -mindepth 1); do
+ insinto /usr/share/${PN}/${i}
+ doins ${i}/*
+ done
+
+ echo > ${S}/XEphem "XEphem.ShareDir: /usr/share/${PN}"
+ insinto /usr/lib/X11/app-defaults/
+ doins ${S}/XEphem
+
+ cd ${S}
+ dodoc Copyright README INSTALL
+}