summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-24 17:57:42 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-24 17:57:42 +0000
commitb2eb75e5751b22074a74043452565581adc0ea26 (patch)
tree9b6f6b6b6b7f7119eb383864562a6f5c8d3a33b9 /sci-astronomy/gasgano
parentUnmask =dev-libs/libevent-2* (bug #333077). (diff)
downloadgentoo-2-b2eb75e5751b22074a74043452565581adc0ea26.tar.gz
gentoo-2-b2eb75e5751b22074a74043452565581adc0ea26.tar.bz2
gentoo-2-b2eb75e5751b22074a74043452565581adc0ea26.zip
Bump, switched to EAPI3
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/gasgano')
-rw-r--r--sci-astronomy/gasgano/ChangeLog9
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.0.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/sci-astronomy/gasgano/ChangeLog b/sci-astronomy/gasgano/ChangeLog
index f742983d5276..76b94e5783f6 100644
--- a/sci-astronomy/gasgano/ChangeLog
+++ b/sci-astronomy/gasgano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/gasgano
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/ChangeLog,v 1.1 2010/05/26 18:46:35 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/ChangeLog,v 1.2 2011/02/24 17:57:42 bicatali Exp $
+
+*gasgano-2.4.0 (24 Feb 2011)
+
+ 24 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +gasgano-2.4.0.ebuild:
+ Bump, switched to EAPI3
*gasgano-2.3.0 (26 May 2010)
diff --git a/sci-astronomy/gasgano/gasgano-2.4.0.ebuild b/sci-astronomy/gasgano/gasgano-2.4.0.ebuild
new file mode 100644
index 000000000000..d3f3cc1eafb8
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/gasgano/gasgano-2.4.0.ebuild,v 1.1 2011/02/24 17:57:42 bicatali Exp $
+
+EAPI=3
+inherit java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( ${HOMEPAGE}/${PDOC}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6
+ dev-java/gnu-regexp
+ dev-java/junit
+ dev-java/jal"
+
+src_prepare() {
+ sed -i \
+ -e "s:BASE.*=.*:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e "s:/share/:/lib/:g" \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/* || die
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config || die
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ newins "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+ fi
+}