summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-23 17:31:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-23 17:31:46 +0000
commitaed324fb85cbcc1f954d0644df4d4e84e4e62c27 (patch)
tree9c7ec376f1c53bc90ee9dc8c67a4c1f18cdb4b73 /sci-astronomy/ast
parentAdded ~ppc, thanks to Pierre Martin. (diff)
downloadgentoo-2-aed324fb85cbcc1f954d0644df4d4e84e4e62c27.tar.gz
gentoo-2-aed324fb85cbcc1f954d0644df4d4e84e4e62c27.tar.bz2
gentoo-2-aed324fb85cbcc1f954d0644df4d4e84e4e62c27.zip
Added pgplot as a dependency, since libast_pgplot is only an option in ast_link
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/ast')
-rw-r--r--sci-astronomy/ast/ChangeLog8
-rw-r--r--sci-astronomy/ast/ast-4.6.2-r2.ebuild40
-rw-r--r--sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch30
3 files changed, 67 insertions, 11 deletions
diff --git a/sci-astronomy/ast/ChangeLog b/sci-astronomy/ast/ChangeLog
index e9ff541cc2c4..04700e3910de 100644
--- a/sci-astronomy/ast/ChangeLog
+++ b/sci-astronomy/ast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-astronomy/ast
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.5 2009/02/17 20:20:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.6 2009/02/23 17:31:45 bicatali Exp $
+
+*ast-4.6.2-r2 (23 Feb 2009)
+
+ 23 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ files/ast-4.6.2-makefile.in.patch, +ast-4.6.2-r2.ebuild:
+ Added pgplot as a dependency, libast_pgplot is only an option in ast_link
17 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+files/ast-4.6.2-makefile.in.patch, ast-4.6.2-r1.ebuild:
diff --git a/sci-astronomy/ast/ast-4.6.2-r2.ebuild b/sci-astronomy/ast/ast-4.6.2-r2.ebuild
new file mode 100644
index 000000000000..b9416efa7088
--- /dev/null
+++ b/sci-astronomy/ast/ast-4.6.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ast-4.6.2-r2.ebuild,v 1.1 2009/02/23 17:31:45 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator
+
+MYP="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="Library for handling World Coordinate Systems in astronomy"
+HOMEPAGE="http://www.starlink.ac.uk/~dsb/ast/ast.html"
+SRC_URI="http://www.starlink.ac.uk/~dsb/${PN}/${MYP}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND="sci-libs/pgplot"
+DEPEND="${RDEPEND}"
+
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # dont patch/sed Makefile.am because it requires special upstream automake
+ # not shipped
+ epatch "${FILESDIR}"/${P}-makefile.in.patch
+}
+
+src_configure() {
+ PATH=".:${PATH}" econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # remove the empty starlink dirs
+ rm -rf "${D}"usr/{docs,help,manifests,news,share} || die
+ dodoc ast.news fac_1521_err
+ if use doc; then
+ dodoc *.ps || die "doc install failed"
+ fi
+}
diff --git a/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch b/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch
index d65dcd07eaac..2a26aa66e808 100644
--- a/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch
+++ b/sci-astronomy/ast/files/ast-4.6.2-makefile.in.patch
@@ -1,25 +1,35 @@
---- Makefile.in.orig 2009-02-17 17:47:41.139829207 +0000
-+++ Makefile.in 2009-02-17 20:13:20.388249934 +0000
-@@ -76,7 +76,17 @@
+--- Makefile.in.orig 2008-09-10 11:59:21.000000000 +0100
++++ Makefile.in 2009-02-23 17:01:16.196714977 +0000
+@@ -76,7 +76,14 @@
"$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"
libLTLIBRARIES_INSTALL = $(INSTALL)
LTLIBRARIES = $(lib_LTLIBRARIES)
-libast_la_LIBADD =
+libast_la_LIBADD = \
+ libast_err.la \
-+ libast_ems.la \
+ libast_grf3d.la \
+ libast_grf_2.0.la \
+ libast_grf_3.2.la \
-+ libast_pgplot.la \
-+ libast_pgplot3d.la \
+ libast_pal.la \
+ libast_wcslib.la
+
am__objects_1 = libast_la-axis.lo libast_la-box.lo libast_la-c2f77.lo \
libast_la-channel.lo libast_la-circle.lo libast_la-cmpframe.lo \
libast_la-cmpmap.lo libast_la-cmpregion.lo \
-@@ -670,7 +680,6 @@
+@@ -158,10 +165,10 @@
+ libast_pal_la_LIBADD =
+ am_libast_pal_la_OBJECTS = libast_pal_la-pal.lo
+ libast_pal_la_OBJECTS = $(am_libast_pal_la_OBJECTS)
+-libast_pgplot_la_LIBADD =
++libast_pgplot_la_LIBADD = -lpgplot
+ am_libast_pgplot_la_OBJECTS = libast_pgplot_la-grf_pgplot.lo
+ libast_pgplot_la_OBJECTS = $(am_libast_pgplot_la_OBJECTS)
+-libast_pgplot3d_la_LIBADD =
++libast_pgplot3d_la_LIBADD = -lpgplot
+ am_libast_pgplot3d_la_OBJECTS = libast_pgplot3d_la-grf3d_pgplot.lo
+ libast_pgplot3d_la_OBJECTS = $(am_libast_pgplot3d_la_OBJECTS)
+ libast_wcslib_la_LIBADD =
+@@ -670,7 +677,6 @@
nodist_include_HEADERS = ast.h AST_PAR
include_MESSAGES = AST_ERR ast_err.h
lib_LTLIBRARIES = \
@@ -27,7 +37,7 @@
libast_err.la \
libast_ems.la \
libast_grf3d.la \
-@@ -679,11 +688,12 @@
+@@ -679,11 +685,12 @@
libast_pgplot.la \
libast_pgplot3d.la \
libast_pal.la \
@@ -44,7 +54,7 @@
# Make all library code position independent by default. This is handy for
# creating shareable libraries from the static ones (Java JNI libraries).
-@@ -791,7 +801,7 @@
+@@ -791,7 +798,7 @@
#ast_test_LDADD = `ast_link`
# Expand ast_link to avoid libast_pass2, which causes problems for Solaris
ast_test_LDADD = libast.la libast_pal.la libast_grf_3.2.la libast_wcslib.la libast_grf_2.0.la libast_grf3d.la libast_err.la -lm
@@ -53,7 +63,7 @@
all: $(BUILT_SOURCES) config.h
$(MAKE) $(AM_MAKEFLAGS) all-am
-@@ -2566,7 +2576,6 @@
+@@ -2566,7 +2573,6 @@
echo "</files>"; \
echo "</manifest>"; \
) >$$MF; \