summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-07-10 15:29:44 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-07-10 15:29:44 +0000
commit1670864bcea1743b0f220fbb257156faa4f3e010 (patch)
treeebd7382fa76c208dd4c40f71199784a84c72e627 /rox-base
parentsmall fix (diff)
downloadgentoo-2-1670864bcea1743b0f220fbb257156faa4f3e010.tar.gz
gentoo-2-1670864bcea1743b0f220fbb257156faa4f3e010.tar.bz2
gentoo-2-1670864bcea1743b0f220fbb257156faa4f3e010.zip
gcc4 fix
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/rox/ChangeLog6
-rw-r--r--rox-base/rox/Manifest11
-rw-r--r--rox-base/rox/files/rox-2.2.0-gcc4.patch20
-rw-r--r--rox-base/rox/rox-2.2.0.ebuild10
4 files changed, 40 insertions, 7 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index 93eb57761c88..29fd20476cbd 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.12 2005/04/07 16:53:51 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.13 2005/07/10 15:29:44 lanius Exp $
+
+ 10 Jul 2005; Heinrich Wendel <lanius@gentoo.org>
+ +files/rox-2.2.0-gcc4.patch, rox-2.2.0.ebuild:
+ gcc4 fix
07 Apr 2005; Simon Stelling <blubb@gentoo.org> rox-2.2.0.ebuild:
stable on amd64
diff --git a/rox-base/rox/Manifest b/rox-base/rox/Manifest
index bfdb2713f260..6b10d1a33e3b 100644
--- a/rox-base/rox/Manifest
+++ b/rox-base/rox/Manifest
@@ -1,11 +1,12 @@
+MD5 d199bff10c128f6ed3f508320225f54e rox-2.1.5.ebuild 1654
+MD5 64ea973e9484af521b0911eda03ae231 rox-2.2.0.ebuild 1740
+MD5 e6bfd1872018b9fe59555171994a71bc rox-2.1.4.ebuild 1653
+MD5 b57d6ce63d5ba32c8ff37e77e8ae673f rox-2.1.3.ebuild 1650
MD5 e8fff8df5e6e565961d8a6fe51e0b5ee ChangeLog 6528
MD5 503ccb1138f9c49f0855884d830988a6 metadata.xml 253
-MD5 b57d6ce63d5ba32c8ff37e77e8ae673f rox-2.1.3.ebuild 1650
-MD5 e6bfd1872018b9fe59555171994a71bc rox-2.1.4.ebuild 1653
-MD5 d199bff10c128f6ed3f508320225f54e rox-2.1.5.ebuild 1654
-MD5 915b6e17ccb080be2bd011998bb3d372 rox-2.2.0.ebuild 1648
-MD5 16ef34ea63806f156b1cf68e34055f12 files/2.1.2-crash-save-display-settings.patch.bz2 1910
+MD5 6582a6fac3d7f42181413ef84b8ef834 files/rox-2.2.0-gcc4.patch 746
MD5 41ab2c5f1d5e3be857ddbad7ba6a7d2a files/digest-rox-2.1.3 59
MD5 d7f3344d55ed0b3c386ef215755c31cf files/digest-rox-2.1.4 59
MD5 b7b99c9a9584fa68610e637fabb7b95e files/digest-rox-2.1.5 59
MD5 93f2d819182714fd4bd786848bb6e9a6 files/digest-rox-2.2.0 59
+MD5 16ef34ea63806f156b1cf68e34055f12 files/2.1.2-crash-save-display-settings.patch.bz2 1910
diff --git a/rox-base/rox/files/rox-2.2.0-gcc4.patch b/rox-base/rox/files/rox-2.2.0-gcc4.patch
new file mode 100644
index 000000000000..9d538293294b
--- /dev/null
+++ b/rox-base/rox/files/rox-2.2.0-gcc4.patch
@@ -0,0 +1,20 @@
+diff -Nur rox-2.2.0-orig/ROX-Filer/src/toolbar.c rox-2.2.0/ROX-Filer/src/toolbar.c
+--- rox-2.2.0-orig/ROX-Filer/src/toolbar.c 2005-06-19 15:34:28.000000000 -0600
++++ rox-2.2.0/ROX-Filer/src/toolbar.c 2005-06-19 15:35:36.000000000 -0600
+@@ -61,7 +61,6 @@
+ Option o_toolbar, o_toolbar_info, o_toolbar_disable;
+ Option o_toolbar_min_width;
+
+-static GtkTooltips *tooltips = NULL;
+ static FilerWindow *filer_window_being_counted;
+
+ /* TRUE if the button presses (or released) should open a new window,
+@@ -175,8 +174,6 @@
+ GTK_STOCK_CLOSE);
+ option_add_int(&o_toolbar_min_width, "toolbar_min_width", 1);
+ option_add_notify(option_notify);
+-
+- tooltips = gtk_tooltips_new();
+
+ option_register_widget("tool-options", build_tool_options);
+ }
diff --git a/rox-base/rox/rox-2.2.0.ebuild b/rox-base/rox/rox-2.2.0.ebuild
index 9753b4ed44f4..6002ddd7a548 100644
--- a/rox-base/rox/rox-2.2.0.ebuild
+++ b/rox-base/rox/rox-2.2.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.2.0.ebuild,v 1.6 2005/04/07 16:53:51 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.2.0.ebuild,v 1.7 2005/07/10 15:29:44 lanius Exp $
+
+inherit eutils
DESCRIPTION="ROX is a desktop environment, like GNOME, KDE and XFCE. It is an attempt to bring some of the good features from RISC OS to Unix and Linux."
HOMEPAGE="http://rox.sourceforge.net/"
@@ -18,6 +20,12 @@ DEPEND=">=x11-libs/gtk+-2.2
IUSE="svg"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc4.patch
+}
+
src_compile() {
# rm ROX-Filer/src/configure # see bug #26162