summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-02-06 15:26:06 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-02-06 15:26:06 +0000
commit7c62fd2f8429231d8ef7cfa976ff0bc2a2184458 (patch)
tree36020d8605dcd21a5175028368cab1dad02b033d /perl-core/DB_File/DB_File-1.815.ebuild
parentAdd patch to fix security bug #165606. (diff)
downloadgentoo-2-7c62fd2f8429231d8ef7cfa976ff0bc2a2184458.tar.gz
gentoo-2-7c62fd2f8429231d8ef7cfa976ff0bc2a2184458.tar.bz2
gentoo-2-7c62fd2f8429231d8ef7cfa976ff0bc2a2184458.zip
Version bump
(Portage version: 2.1.2-r5)
Diffstat (limited to 'perl-core/DB_File/DB_File-1.815.ebuild')
-rw-r--r--perl-core/DB_File/DB_File-1.815.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/perl-core/DB_File/DB_File-1.815.ebuild b/perl-core/DB_File/DB_File-1.815.ebuild
new file mode 100644
index 000000000000..5683f333bc77
--- /dev/null
+++ b/perl-core/DB_File/DB_File-1.815.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/DB_File-1.815.ebuild,v 1.1 2007/02/06 15:26:06 mcummings Exp $
+
+inherit perl-module multilib eutils
+
+DESCRIPTION="A Berkeley DB Support Perl Module"
+HOMEPAGE="http://www.cpan.org/modules/by-module/DB_File/${P}.readme"
+SRC_URI="mirror://cpan/authors/id/P/PM/PMQS/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-libs/db"
+
+SRC_TEST="do"
+
+mydoc="Changes"
+
+src_unpack() {
+ unpack ${A}
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e "s:^LIB.*:LIB = /usr/$(get_libdir):" \
+ ${S}/config.in || die
+ fi
+ cd ${S}
+ epatch ${FILESDIR}/DB_File-MakeMaker.patch
+}