summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-17 16:12:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-17 16:12:11 +0000
commit0f2b43291b3bd0a31f0787b7e5e1629ab8f45e5d (patch)
tree5b1962f2495b8f1b3314c485958e0ca77e4b7d38 /net-zope
parentStable on alpha, bug #307613 (diff)
downloadgentoo-2-0f2b43291b3bd0a31f0787b7e5e1629ab8f45e5d.tar.gz
gentoo-2-0f2b43291b3bd0a31f0787b7e5e1629ab8f45e5d.tar.bz2
gentoo-2-0f2b43291b3bd0a31f0787b7e5e1629ab8f45e5d.zip
Initial addition.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zexceptions/ChangeLog10
-rw-r--r--net-zope/zexceptions/metadata.xml5
-rw-r--r--net-zope/zexceptions/zexceptions-2.13.0.ebuild44
3 files changed, 59 insertions, 0 deletions
diff --git a/net-zope/zexceptions/ChangeLog b/net-zope/zexceptions/ChangeLog
new file mode 100644
index 000000000000..7d8795b81e22
--- /dev/null
+++ b/net-zope/zexceptions/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zexceptions
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zexceptions/ChangeLog,v 1.1 2010/07/17 16:12:11 arfrever Exp $
+
+*zexceptions-2.13.0 (17 Jul 2010)
+
+ 17 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zexceptions-2.13.0.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zexceptions/metadata.xml b/net-zope/zexceptions/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/zexceptions/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/zexceptions/zexceptions-2.13.0.ebuild b/net-zope/zexceptions/zexceptions-2.13.0.ebuild
new file mode 100644
index 000000000000..b1957d70d2fb
--- /dev/null
+++ b/net-zope/zexceptions/zexceptions-2.13.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zexceptions/zexceptions-2.13.0.ebuild,v 1.1 2010/07/17 16:12:11 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="zExceptions"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="zExceptions contains common exceptions used in Zope2."
+HOMEPAGE="http://pypi.python.org/pypi/zExceptions"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zope-interface
+ net-zope/zope-publisher
+ net-zope/zope-security"
+DEPEND="app-arch/unzip
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${MY_PN}"
+
+src_install() {
+ distutils_src_install
+
+ # Don't install tests.
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/zExceptions/tests"
+ }
+ python_execute_function -q delete_tests
+}