summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-01 08:55:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-01 08:55:34 +0000
commit57b6df3a38ded7669f9bfae28fae4f0a49543fb9 (patch)
treed500efb61f268af0e950be20e1bfb1b77ea7d2da /net-zope/zope-interface
parentBump (diff)
downloadgentoo-2-57b6df3a38ded7669f9bfae28fae4f0a49543fb9.tar.gz
gentoo-2-57b6df3a38ded7669f9bfae28fae4f0a49543fb9.tar.bz2
gentoo-2-57b6df3a38ded7669f9bfae28fae4f0a49543fb9.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-zope/zope-interface')
-rw-r--r--net-zope/zope-interface/ChangeLog10
-rw-r--r--net-zope/zope-interface/zope-interface-4.0.3.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/net-zope/zope-interface/ChangeLog b/net-zope/zope-interface/ChangeLog
index faa7c76a35c3..202ec6954367 100644
--- a/net-zope/zope-interface/ChangeLog
+++ b/net-zope/zope-interface/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope-interface
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/ChangeLog,v 1.41 2012/06/17 18:51:25 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/ChangeLog,v 1.42 2013/02/01 08:55:34 patrick Exp $
+
+*zope-interface-4.0.3 (01 Feb 2013)
+
+ 01 Feb 2013; Patrick Lauer <patrick@gentoo.org> +zope-interface-4.0.3.ebuild:
+ Bump
17 Jun 2012; Raúl Porcel <armin76@gentoo.org> zope-interface-3.8.0.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #415871
@@ -330,4 +335,3 @@
09 Nov 2004; Radoslaw Stachowiak <radek@gentoo.org> +metadata.xml,
+zopeinterface-3.0.0.ebuild:
First version in portage. Thanx goes to Sourav Mandal and fdrake.
-
diff --git a/net-zope/zope-interface/zope-interface-4.0.3.ebuild b/net-zope/zope-interface/zope-interface-4.0.3.ebuild
new file mode 100644
index 000000000000..b8f9af5250ba
--- /dev/null
+++ b/net-zope/zope-interface/zope-interface-4.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-4.0.3.ebuild,v 1.1 2013/02/01 08:55:34 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+# Test suite requires optional extension modules not available with Jython.
+PYTHON_TESTS_RESTRICTED_ABIS="*-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+MY_PN="${PN/-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# net-zope/zope-fixers is required for building with Python 3.
+DEPEND="dev-python/setuptools
+ net-zope/zope-fixers"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="CHANGES.txt"
+PYTHON_MODNAME="${PN/-//}"
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}