summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-30 19:13:30 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-30 19:13:30 +0000
commit4f06ed86586c70dab5f409234afa481a3c8a9a25 (patch)
tree41c60981a742c6d2537fa4a089acc04bd312e71c /net-zope/extensionclass
parentDelete older ebuild. (diff)
downloadgentoo-2-4f06ed86586c70dab5f409234afa481a3c8a9a25.tar.gz
gentoo-2-4f06ed86586c70dab5f409234afa481a3c8a9a25.tar.bz2
gentoo-2-4f06ed86586c70dab5f409234afa481a3c8a9a25.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'net-zope/extensionclass')
-rw-r--r--net-zope/extensionclass/ChangeLog8
-rw-r--r--net-zope/extensionclass/extensionclass-2.13.1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/net-zope/extensionclass/ChangeLog b/net-zope/extensionclass/ChangeLog
index f34179ceff41..7189dad14446 100644
--- a/net-zope/extensionclass/ChangeLog
+++ b/net-zope/extensionclass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-zope/extensionclass
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/ChangeLog,v 1.7 2010/03/12 18:16:36 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/ChangeLog,v 1.8 2010/05/30 19:13:30 arfrever Exp $
+
+*extensionclass-2.13.1 (30 May 2010)
+
+ 30 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -extensionclass-2.13.0.ebuild, +extensionclass-2.13.1.ebuild:
+ Version bump.
*extensionclass-2.13.0 (12 Mar 2010)
diff --git a/net-zope/extensionclass/extensionclass-2.13.1.ebuild b/net-zope/extensionclass/extensionclass-2.13.1.ebuild
new file mode 100644
index 000000000000..9c70bdc776b6
--- /dev/null
+++ b/net-zope/extensionclass/extensionclass-2.13.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/extensionclass/extensionclass-2.13.1.ebuild,v 1.1 2010/05/30 19:13:30 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="ExtensionClass"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Metaclass for subclassable extension types"
+HOMEPAGE="http://pypi.python.org/pypi/ExtensionClass"
+SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="ComputedAttribute ExtensionClass MethodObject"
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in ComputedAttribute ExtensionClass MethodObject; do
+ ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}/_${module}.so" "src/${module}/_${module}.so" || die "Symlinking ${module}/_${module}.so failed with Python ${PYTHON_ABI}"
+ done
+}
+
+src_install() {
+ distutils_src_install
+ python_clean_installation_image
+}