summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-05-06 15:36:11 +0000
committerChristian Heim <phreak@gentoo.org>2007-05-06 15:36:11 +0000
commitec411a19dc82de2f96fc5b70ce9560fc427c49a4 (patch)
tree4a7bc13573fd749e3436024106b804501b6f52d1 /net-www
parentAdded ~ppc, bug #177287 (diff)
downloadgentoo-2-ec411a19dc82de2f96fc5b70ce9560fc427c49a4.tar.gz
gentoo-2-ec411a19dc82de2f96fc5b70ce9560fc427c49a4.tar.bz2
gentoo-2-ec411a19dc82de2f96fc5b70ce9560fc427c49a4.zip
Version bump, thanks to Nick Palmer <nicholas and slackers.net> and Julien Allanos <dju at gentoo.org> in #151826 for security #169778.
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mod_security/ChangeLog9
-rw-r--r--net-www/mod_security/files/99_mod_security-2.1.1.conf8
-rw-r--r--net-www/mod_security/files/digest-mod_security-2.1.13
-rw-r--r--net-www/mod_security/mod_security-2.1.1.ebuild50
4 files changed, 69 insertions, 1 deletions
diff --git a/net-www/mod_security/ChangeLog b/net-www/mod_security/ChangeLog
index e40c45dacc7e..40e6664f90a5 100644
--- a/net-www/mod_security/ChangeLog
+++ b/net-www/mod_security/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/mod_security
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_security/ChangeLog,v 1.20 2007/01/14 20:09:54 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_security/ChangeLog,v 1.21 2007/05/06 15:36:11 phreak Exp $
+
+*mod_security-2.1.1 (06 May 2007)
+
+ 06 May 2007; Christian Heim <phreak@gentoo.org>
+ +files/99_mod_security-2.1.1.conf, +mod_security-2.1.1.ebuild:
+ Version bump, thanks to Nick Palmer <nicholas and slackers.net> and Julien
+ Allanos <dju at gentoo.org> in #151826 for security #169778.
14 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
-files/1.8.6/99_mod_security.conf, files/99_mod_security.conf,
diff --git a/net-www/mod_security/files/99_mod_security-2.1.1.conf b/net-www/mod_security/files/99_mod_security-2.1.1.conf
new file mode 100644
index 000000000000..78344cde8c87
--- /dev/null
+++ b/net-www/mod_security/files/99_mod_security-2.1.1.conf
@@ -0,0 +1,8 @@
+<IfDefine SECURITY>
+ <IfModule !mod_security2.c>
+ LoadModule security2_module modules/mod_security2.so
+ </IfModule>
+
+ # use Core Rule Set by default:
+ Include /etc/apache2/modules.d/mod_security/*.conf
+</IfDefine>
diff --git a/net-www/mod_security/files/digest-mod_security-2.1.1 b/net-www/mod_security/files/digest-mod_security-2.1.1
new file mode 100644
index 000000000000..af3a5b2f6338
--- /dev/null
+++ b/net-www/mod_security/files/digest-mod_security-2.1.1
@@ -0,0 +1,3 @@
+MD5 ab74ed5f320ffc4ed9f56487bf17c670 modsecurity-apache_2.1.1.tar.gz 650607
+RMD160 17e94c19d51f7e9e09ef435f81d696ec638aad44 modsecurity-apache_2.1.1.tar.gz 650607
+SHA256 fadeb3b4ce5672c99c094611792b827d45fcd6b38c4c4fa81c4cfdc63c63b71a modsecurity-apache_2.1.1.tar.gz 650607
diff --git a/net-www/mod_security/mod_security-2.1.1.ebuild b/net-www/mod_security/mod_security-2.1.1.ebuild
new file mode 100644
index 000000000000..0b3aeb7ba48c
--- /dev/null
+++ b/net-www/mod_security/mod_security-2.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_security/mod_security-2.1.1.ebuild,v 1.1 2007/05/06 15:36:11 phreak Exp $
+
+inherit apache-module
+
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+
+MY_P=${P/mod_security-/modsecurity-apache_}
+
+DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
+HOMEPAGE="http://www.modsecurity.org/"
+SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="doc"
+
+S="${WORKDIR}/${MY_P}"
+
+APXS2_ARGS="-S LIBEXECDIR=${S} -c -o ${PN}2.so ${S}/apache2/*.c"
+APACHE2_MOD_FILE=".libs/${PN}2.so"
+#APACHE2_MOD_CONF="99_mod_security"
+APACHE2_MOD_DEFINE="SECURITY"
+
+need_apache2
+
+src_install() {
+ apache2_src_install
+
+ # install documentation
+ dodoc CHANGES
+ newdoc rules/CHANGELOG CHANGES.crs
+ newdoc rules/README README.crs
+ dohtml doc/*.html doc/*.gif doc/*.jpg doc/*.css doc/*.pdf
+ cp -r "${S}"/doc/html-multipage "${D}"/usr/share/doc/${P}/html/
+
+ # Once APACHE2_MOD_CONF is able to use newconfd (probably never), this line
+ # should go.
+ insinto ${APACHE2_MODULES_CONFDIR}
+ newins "${FILESDIR}"/99_mod_security-${PV}.conf 99_mod_security.conf
+
+ # Prepare the core ruleset
+ for i in $( ls "${S}"/rules/*.conf ); do
+ mv $i ${i/modsecurity_crs_/}
+ done
+
+ # Install core ruleset
+ insinto ${APACHE2_MODULES_CONFDIR}/mod_security/
+ doins "${S}"/rules/*.conf
+}