summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-05-18 18:11:30 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-05-18 18:11:30 +0000
commit9c3761ed9ee84a2db99fb2ce42c514e5f2666d33 (patch)
tree2415c93359f62e8a65036d9b3cc9735ad001c80b /net-www
parentAdd patch to fix compilation with gcc-4.1; bug #132336 (diff)
downloadgentoo-2-9c3761ed9ee84a2db99fb2ce42c514e5f2666d33.tar.gz
gentoo-2-9c3761ed9ee84a2db99fb2ce42c514e5f2666d33.tar.bz2
gentoo-2-9c3761ed9ee84a2db99fb2ce42c514e5f2666d33.zip
Filter --as-needed
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/apache-2.0.58.ebuild8
-rw-r--r--net-www/apache/apache-2.2.0-r2.ebuild6
2 files changed, 10 insertions, 4 deletions
diff --git a/net-www/apache/apache-2.0.58.ebuild b/net-www/apache/apache-2.0.58.ebuild
index 6a23b4eb48fe..ea83436e41c9 100644
--- a/net-www/apache/apache-2.0.58.ebuild
+++ b/net-www/apache/apache-2.0.58.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.58.ebuild,v 1.1 2006/05/16 02:51:48 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.58.ebuild,v 1.2 2006/05/18 18:11:30 vericgar Exp $
-inherit eutils gnuconfig multilib
+inherit eutils flag-o-matic gnuconfig multilib
# latest gentoo apache files
GENTOO_PATCHNAME="gentoo-apache-${PVR}"
@@ -85,6 +85,10 @@ src_unpack() {
}
src_compile() {
+
+ # bug 128505
+ filter-ldflags -Wl,--as-needed --as-needed
+
# actually we do not provide a very dynamic way of those vars
# however, you may predefine them in shell before emerging
# to override the official default locations
diff --git a/net-www/apache/apache-2.2.0-r2.ebuild b/net-www/apache/apache-2.2.0-r2.ebuild
index 7962d493cc8f..27dd20290d54 100644
--- a/net-www/apache/apache-2.2.0-r2.ebuild
+++ b/net-www/apache/apache-2.2.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.0-r2.ebuild,v 1.7 2006/04/19 17:24:59 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.0-r2.ebuild,v 1.8 2006/05/18 18:11:30 vericgar Exp $
-inherit eutils gnuconfig multilib
+inherit eutils flag-o-matic gnuconfig multilib
# latest gentoo apache files
GENTOO_PATCHNAME="gentoo-apache-${PVR}"
@@ -127,6 +127,8 @@ src_unpack() {
src_compile() {
+ filter-ldflags -Wl,--as-needed --as-needed
+
# Detect mips and uclibc systems properly
gnuconfig_update