summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-18 13:31:14 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-18 13:31:14 +0000
commit0b53ec7fcef5577113ed464d5918f971eaf87319 (patch)
tree3f2bab28e798164da5b364e837e07313a5873853 /net-www
parentmove pkgconfig and swig to DEPEND also in old versions. (diff)
downloadgentoo-2-0b53ec7fcef5577113ed464d5918f971eaf87319.tar.gz
gentoo-2-0b53ec7fcef5577113ed464d5918f971eaf87319.tar.bz2
gentoo-2-0b53ec7fcef5577113ed464d5918f971eaf87319.zip
Move pkgconfig to DEPEND.
(Portage version: 2.1.5, RepoMan options: --force)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild9
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild11
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild9
3 files changed, 16 insertions, 13 deletions
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
index 1ca8cb6d7e39..4e1d68b4e0d0 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild,v 1.12 2008/03/14 17:40:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.35.ebuild,v 1.13 2008/05/18 13:31:14 drac Exp $
inherit eutils multilib nsplugins
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 -hppa ppc sparc x86"
IUSE="gtk divx gmedia realmedia quicktime wmp"
-DEPEND=">=media-video/mplayer-1.0_pre5
+RDEPEND=">=media-video/mplayer-1.0_pre5
|| ( =www-client/mozilla-firefox-2*
=www-client/seamonkey-1*
)
@@ -24,10 +24,11 @@ DEPEND=">=media-video/mplayer-1.0_pre5
dev-libs/atk
>=dev-libs/glib-2.2.0
>=x11-libs/pango-1.2.1
- )
+ )"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack "${A}"
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild
index 6453417f723d..1d6827a92b2c 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild,v 1.8 2008/03/14 17:40:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.45.ebuild,v 1.9 2008/05/18 13:31:14 drac Exp $
inherit eutils multilib
@@ -16,7 +16,7 @@ IUSE="gtk divx gmedia mplayer-bin nls realmedia quicktime wmp"
LANGS="da de en_US es fr hu it ja ko nb pl pt_BR nl ru se zh_CN"
for X in ${LANGS}; do IUSE="${IUSE} linguas_${X}"; done
-DEPEND="
+RDEPEND="
|| ( =www-client/mozilla-firefox-2*
=www-client/seamonkey-1*
=net-libs/xulrunner-1.8*
@@ -31,10 +31,11 @@ DEPEND="
>=x11-libs/pango-1.2.1
)
mplayer-bin? ( media-video/mplayer-bin )
- !mplayer-bin? ( >=media-video/mplayer-1.0_pre5 )
- dev-util/pkgconfig"
+ !mplayer-bin? ( >=media-video/mplayer-1.0_pre5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack "${A}"
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild
index fd01597a8916..5e2e2144efc9 100644
--- a/net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild,v 1.4 2008/03/14 17:40:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.50.ebuild,v 1.5 2008/05/18 13:31:14 drac Exp $
inherit eutils multilib autotools
@@ -16,7 +16,7 @@ IUSE="gtk divx firefox gmedia mplayer-bin nls quicktime realmedia seamonkey wmp"
LANGS="cs da de en_US es fr hu it ja ko nb nl pl pt_BR ru sk se tr wa zh_CN"
for X in ${LANGS}; do IUSE="${IUSE} linguas_${X}"; done
-DEPEND="
+RDEPEND="
firefox? ( =www-client/mozilla-firefox-2* )
!firefox? (
seamonkey? ( =www-client/seamonkey-1* )
@@ -31,7 +31,8 @@ DEPEND="
>=x11-libs/pango-1.2.1
)
mplayer-bin? ( media-video/mplayer-bin )
- !mplayer-bin? ( >=media-video/mplayer-1.0_pre7 )
+ !mplayer-bin? ( >=media-video/mplayer-1.0_pre7 )"
+DEPEND="${RDEPEND}
dev-util/pkgconfig"
if has_multilib_profile; then
@@ -43,7 +44,7 @@ DEPEND="
)"
fi
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack "${A}"