summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2003-07-19 17:02:06 +0000
committerLars Weiler <pylon@gentoo.org>2003-07-19 17:02:06 +0000
commit340bdb73a96a854120770878db29e66e453aa265 (patch)
treef202bdce65a5c97a31d9e74d86b5becbe6854bfa /net-www/viewcvs
parentsupport for apache2 (diff)
downloadgentoo-2-340bdb73a96a854120770878db29e66e453aa265.tar.gz
gentoo-2-340bdb73a96a854120770878db29e66e453aa265.tar.bz2
gentoo-2-340bdb73a96a854120770878db29e66e453aa265.zip
support for apache2
Diffstat (limited to 'net-www/viewcvs')
-rw-r--r--net-www/viewcvs/ChangeLog8
-rw-r--r--net-www/viewcvs/Manifest4
-rw-r--r--net-www/viewcvs/files/digest-viewcvs-0.9.2-r21
-rw-r--r--net-www/viewcvs/viewcvs-0.9.2-r2.ebuild100
4 files changed, 110 insertions, 3 deletions
diff --git a/net-www/viewcvs/ChangeLog b/net-www/viewcvs/ChangeLog
index b26fe2235173..32cb5a4ac7cf 100644
--- a/net-www/viewcvs/ChangeLog
+++ b/net-www/viewcvs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/viewcvs
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/viewcvs/ChangeLog,v 1.5 2003/07/16 16:27:30 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/viewcvs/ChangeLog,v 1.6 2003/07/19 17:01:57 pylon Exp $
+
+*viewcvs-0.9.2-r2 (19 Jul 2003)
+
+ 19 Jul 2003; Lars Weiler <pylon@gentoo.org> viewcvs-0.9.2-r2.ebuild:
+ Configuration file for apache2 will be placed in the modules.d directory
+ automatically. No further server-configuration is needed.
*viewcvs-0.9.2-r1 (16 Jul 2003)
diff --git a/net-www/viewcvs/Manifest b/net-www/viewcvs/Manifest
index 8cb029b78fdb..67f9f45db60c 100644
--- a/net-www/viewcvs/Manifest
+++ b/net-www/viewcvs/Manifest
@@ -1,8 +1,8 @@
-MD5 201defa4289439047adb9f17b0b4e04f ChangeLog 1503
+MD5 414fb6fa716da5559aa845dcc834b863 ChangeLog 1503
MD5 0e9c745209df53465fab90183587c6c9 viewcvs-0.9.2.ebuild 2357
MD5 31b0922216251068fc9961a217a61ce5 viewcvs-0.9.2_p20030430.ebuild 2356
MD5 ebe00711ec2eb5bf78951944bf075432 viewcvs-0.9.2-r1.ebuild 2422
-MD5 51b00b1e0d4b0d02b4cf496e2440b76e viewcvs-0.9.2-r2.ebuild 2819
+MD5 f080d22ab0053078246d09fee00cac17 viewcvs-0.9.2-r2.ebuild 2819
MD5 07a07f1a89e77c9f093ade7e395ffe3b files/digest-viewcvs-0.9.2 65
MD5 fbac846bcd488f255dc57fdd27ba99df files/digest-viewcvs-0.9.2_p20030430 69
MD5 07a07f1a89e77c9f093ade7e395ffe3b files/digest-viewcvs-0.9.2-r1 65
diff --git a/net-www/viewcvs/files/digest-viewcvs-0.9.2-r2 b/net-www/viewcvs/files/digest-viewcvs-0.9.2-r2
new file mode 100644
index 000000000000..7ee3ce69fbbc
--- /dev/null
+++ b/net-www/viewcvs/files/digest-viewcvs-0.9.2-r2
@@ -0,0 +1 @@
+MD5 c7857b1ed05240ad1f691ea40044daf2 viewcvs-0.9.2.tar.gz 140063
diff --git a/net-www/viewcvs/viewcvs-0.9.2-r2.ebuild b/net-www/viewcvs/viewcvs-0.9.2-r2.ebuild
new file mode 100644
index 000000000000..b2da7e859505
--- /dev/null
+++ b/net-www/viewcvs/viewcvs-0.9.2-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/viewcvs/viewcvs-0.9.2-r2.ebuild,v 1.1 2003/07/19 17:01:57 pylon Exp $
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="viewcvs"
+PDATE=${PV/0.9.2_p/}
+DESCRIPTION="Viewcvs, a web interface to cvs and subversion"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PDATE}.tar.gz"
+HOMEPAGE="http://viewcvs.sourceforge.net"
+
+S="${WORKDIR}/${P}"
+WWW="/home/httpd/viewcvs"
+
+DEPEND=""
+
+RDEPEND=">=app-text/rcs-5.7
+ >=dev-util/cvs-1.11
+ sys-apps/diffutils
+ net-www/apache"
+
+IUSE="apache2"
+
+doinstall() {
+ # start_location=$1
+ # end_location=$2
+ # mode=$3
+ if [ -d $1 ]; then
+ install -o root -d ${D}/$2
+ for f in ${1}/*
+ do
+ doinstall ${f} ${f/${1}/${2}} $3
+ done
+ else
+ sed -e "{ s,\(^#!.*$\),#!/usr/bin/python,; \
+ s,\(<VIEWCVS_INSTALL_DIRECTORY>\),${WWW},; \
+ s,\(^LIBRARY_DIR\)\(.*\$\),\1 = \"${WWW}/lib\",; \
+ s,\(^CONF_PATHNAME\)\(.*\$\),\1 = \"${WWW}/viewcvs.conf\",}" ${1} >${1}.cpy
+
+ install -o root -m $3 ${1}.cpy ${D}/$2
+ rm ${1}.cpy
+ fi
+}
+
+src_install() {
+ cd ${S}
+ install -o root -d ${D}/${WWW}/cgi
+
+ doinstall cgi/viewcvs.cgi ${WWW}/cgi/viewcvs.cgi 755
+ doinstall cgi/query.cgi ${WWW}/cgi/query.cgi 755
+ doinstall standalone.py ${WWW}/standalone.py 755
+ doinstall tools/loginfo-handler ${WWW}/loginfo-handler 755
+ doinstall tools/cvsdbadmin ${WWW}/cvsdbadmin 755
+ doinstall tools/make-database ${WWW}/make-database 755
+
+ insinto /etc/viewcvs
+ doinstall cgi/viewcvs.conf.dist ${WWW}/viewcvs.conf 644
+ doinstall cgi/cvsgraph.conf.dist ${WWW}/cvsgraph.conf 644
+
+ doinstall lib ${WWW}/lib 644
+ doinstall templates ${WWW}/templates 644
+
+ doinstall website ${WWW}/doc 644
+
+ dosym ${WWW}/viewcvs.conf /etc/viewcvs/viewcvs.conf
+ dosym ${WWW}/cvsgraph.conf /etc/viewcvs/cvsgraph.conf
+
+ cat <<EOF >apache.conf
+# Enables ViewCVS in /home/httpd/viewcvs and creates an alias to /viewcvs
+# Configuration of ViewCVS could be done in /etc/viewcvs/
+
+ScriptAlias /viewcvs /home/httpd/viewcvs/cgi/viewcvs.cgi
+ScriptAlias /cvsquery /home/httpd/viewcvs/cgi/cvsquery.cgi
+
+<Directory /home/httpd/viewcvs/cgi>
+ Options ExecCGI
+ <IfModule mod_access.c>
+ Order allow,deny
+ Allow from all
+ </IfModule>
+</Directory>
+EOF
+
+ if use apache2; then
+ cp apache.conf 47_viewcvs.conf
+ insinto /etc/apache2/conf/modules.d
+ doins 47_viewcvs.conf
+ fi
+
+ dodoc INSTALL TODO CHANGES README apache.conf
+}
+
+pkg_postinst() {
+ ewarn "Before using viewcvs make sure you configure it correctly."
+ einfo "There is a sample apache integration configuration file in the"
+ einfo "documentation directory named: apache.conf"
+ einfo "If you're using apache2 this configuration is already done for"
+ einfo "you in /etc/apache2/conf/modules.d/47_viewcvs.conf"
+}